Jump to content
  • 0
Sign in to follow this  
SallyBees

my commands aren't working

Question

  • 0

ask the creator or user group, think not many here will be able to guess what you are using.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

ask the creator or user group, think not many here will be able to guess what you are using.

Share this post


Link to post
Share on other sites
  • 0

Maybe you're standing in a No Script parcel, or the tool has broken - you could try resetting its scripts.

But Alwin's right, we can't debug scripts here.

Share this post


Link to post
Share on other sites
  • 0

/4 is an instruction that tells SL that whatever you type after that is to be transmitted on chat channel 4.  There are an almost unlimited number of chat channels (and they include negative numbers, too!)  Chat transmitted on these channels is not "heard" by people in world...when you type "/4 bling off" in Nearby Chat and hit Enter, it does not appear on your, or anyone else's, screen.  But it is heard by any device that's "listening" for commands on chat channel 4.

Things that can cause chat commands to fail:

  • Incorrect command.  Devices are very particular about things like spaces, capitalization, and spelling.  My door recognizes the command "addkeyholder Lindal Kidd" but does nothing if I type it as "add keyholder Lindal Kidd"
  • Incorrect chat channel.  Lots of devices listen on channel 1, so with an unknown device, trying /1 is always a first step.
  • Device not within chat range (20 meters).  Not a problem, of course, for things that you are wearing, like roleplay HUDs.
  • Device broken.  Right click the HUD, select Build/Scripts/Reset Scripts in Selection.  Or detach it and wear it again.
  • Device broken by SL.  Updates to Second Life occasionally "break content"...cause things that were working to stop.  LL tries to avoid this, but it does happen now and then.  Contact the device creator and see if there is an update.
  • Scripts are turned off on the land where you are.  Try flying up to 100m or so and see if your device works up there.  Or simply look in your top menu bar for a "no scripts allowed" symbol.
  • Like 2

Share this post


Link to post
Share on other sites
  • 0

Lindal summarized many of the common reasons why chat controls fail. Instead of guessing wildly at all the possibilities, your best strategy is to just ask other people in your RP group.  There's a pretty good chance that they've had the same problem at one time or another and can tell you exactly how they fixed it.

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...