Jump to content

"community support" Where is it?


You are about to reply to a thread that has been inactive for 1666 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

According to the system requirements page, Linden Lab don't support the Linux version of their viewer. It's all left to community support,

They don't provide any links. So where do I find that community support?

I have checked, and my 64-bit Linux should be able to run a 32-bit program (although there are way too many Linux users speculating as to why people are still writing 32-bit code). There are several TPVs that are compiled for 64-bit Linux, though they sometimes fail in interesting ways that suggest a poor understanding of 64-bit memory management. But it's the Linden Viewer that has the new features that I want to try out.

Anyway, where do I find this "community support"? Does it even exist?

Link to post
Share on other sites

Thanks for the link.

The info on that page is pretty old. There's a 2015 last modified date. but the last Ubuntu version is refers to is from 2013, and the context implies it is a new version that a fix might not work for

And user groups accessed within Second Life are a bit useless when the SL viewer doesn't load.

Anyway, why don't Linden Lab even bother to put a link to that page in the footnote where they tell us they don't support Linux?

The various TPVs just work. They don't have to mess around with loading a set of 32-bit libraries (which I have anyway).

And either the syntax for the cp command has changed rather dramatically, or some of the contributors know less about what they're doing than I do,

Is Bento going to be worth trying to use any Linden Lab viewer?

Link to post
Share on other sites
  • 3 weeks later...

UPDATED: 1/30/17-Things have changed a little using Ubuntu 14.04 x64/16.04 x64 & Linux Mint 18 x64. Here is how you still open a viewer on current Debian Linux distros: first download viewer of your choice I am going to use the latest Singularity (2017) viewer as an example although the process I am going to share works on any current viewer. So, we have downloaded the Singularity Linux Test Build 1 8 7 6866 x86 64.tar.xz, which is auto saved to our "downloads"...double click on "Downloads" which opens any files you have downloaded...slide your mouse pointer to upper top left corner of your screen...click on "Edit"...click on "Preferences"...click on "Behavior" tab...select "run executable text files when they are opened"...close that window...go back to the tar.xz download...right click on it...select "Properties"...click on "Permissions"...select "allow executing file as a program"..close that window...now right click on the tar.xz downlaod...click on "extract here"..it will auto create a folder for you...at this point I like to get rid of the tar.xz download by right clicking it...click on "move to trash"...now double click on the newly created folder...double click on the data sheet named (singularity....or firestorm...secondlife which ever viewer you used) & the viewer will open.

Now I am going to share with you what has changed in Ubuntu 14.04 x64/16.04 x64/Linux Mint 18 x64 distros pertaining to 3rd party Firestorm & Singularity viewers. After just recently testing the latest Fiestorm-Linux x64 & latest (2017) Singularity test build viewers I am strongly advising you use a min. of 10-12 GB system RAM; especially on the latest Firestorm - Linux x64 viewer! I have nothing against the Firestorm team, but their latest x64 Linux viewer is sluggish, uses too much system resources; especially system RAM! If you attempt to use SL for a prolonged period of time with 8 GB RAM with the latest Linux Firestorm viewer you'll use it up quick & have to re-log often. Although I found the latest Singularity Linux test build faster than Firestorm's it too uses system RAM a little more quickly then previous versions.

Latest (2017) bento compatible Singularity Linux x64 viewer 1 8 7 6915 x86 64 tar.xz

http://67.170.30.149/

Latest Firestorm Linux x86 & x64 viewers

http://www.firestormviewer.org/linux/

You are definitely going to need some of the following 32 bit libraries. It is a little overkill, but after installing them all you'll be able to run ANY of the current Linux 32 bit, or 64 bit viewers on any of the above listed Linux distros along with Skype, Google Earth, etc

First command run in your Terminal

sudo apt update && sudo apt upgrade     (gets your pc "Up to date"...after installing ALL available re-boot your pc)

32 bit Libs (copy n paste into your Terminal one @ a time)

sudo apt-get install gcc-multilib

sudo apt-get install libc6-i386 libglib2.0-0:i386 libsm6:i386 \
libglu1-mesa:i386 libgl1-mesa-glx:i386 libxext6:i386 \
libxrender1:i386 libx11-6:i386 libfontconfig1:i386 lsb-core

sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0

sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386

sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6

sudo apt-get install libglu1-mesa:i386 libgtk2.0-0:i386 libidn11:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 libqtwebkit4:i386

sudo apt-get install libfontconfig1:i386 libx11-6:i386 libxrender1:i386 libxext6:i386 libgl1-mesa-glx:i386 libglu1-mesa:i386 libglib2.0-0:i386 libsm6:i386

sudo apt-get install gstreamer0.10-pulseaudio:i386 libidn11:i386 libuuid1:i386 libstdc++6:i386

sudo apt-get install lib32z1

sudo apt-get install libgtk2.0-0:i386 libidn11:i386 libglu1-mesa:i386 libxmu6:i386

sudo apt-get install libpangox-1.0-0:i386 libpangoxft-1.0-0:i386

sudo apt-get install libasound2-plugins:i386

sudo apt-get install libasound2:i386 libasound2-plugins:i386 libasyncns0:i386 libattr1:i386 libc6:i386 libc6-i686:i386 libcap2:i386 libdbus-1-3:i386 libflac8:i386 libgcc1:i386 libice6:i386 libjson0:i386 libogg0:i386 libpulse0:i386 libsm6:i386 libsndfile1:i386 libstdc++6:i386 libvorbis0a:i386 libvorbisenc2:i386 libwrap0:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb1:i386 libxdmcp6:i386 libxext6:i386 libxi6:i386 libxtst6:i386 zlib1g:i386

(some commands above are repetitive or obsoleted so do not sweat it if it says already installed or obsolete)

After installing all above listed 32 libs re-boot your pc. Now you'll have audio, CEF media plugins, etc for ANY of the current SL viewers. Here is something else that has changed in Ubuntu 16.04.1 x64...you may experience system errors attempting to open certain programs til you add the above listed 32 bit libraries.

By default Ubuntu 16.04 x64 firewall is turned off

Go to "Ubuntu Software"...in search box type: "firewall"...click on "firewall configuration"...click on "install"...type in your password...as it installs it creates an icon on your task launcher...after install completes re-boot your pc...click on firewall icon...type in your pc password...when firewall window opens select "enable"...close out that window...your firewall is now on.

Want to get rid of that Guest User Account?

Open a Terminal type: sudo gedit /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf    (press Enter on keyboard...type in your password..press Enter again...a gedit window opens...directly below last line of text you see to the far left type: allow-guest=false   click on "save" tab in the upper right corner of the gedit window..close the gedit window...close the Terminal...re-boot your pc & the Guest account will be gone

How to easily install the latest Nvidia graphics card driver

Open a terminal & type these commands one @ a time:

sudo apt-get remove nvidia*    (press Enter on keyboard...type in your password...press Enter again this removes your current Nvidia driver)

sudo add-apt-repository ppa:graphics-drivers/ppa    (press Enter on your keyboard)

sudo apt-get update     (press Enter on your keyboard after udate completes close your terminal & re-bbot your pc)

Now go to "Settings"...to Software & Updates..click on "Additional Drivers" tab. At this point I like to go to Nvidia's site to see the latest Linux x64 driver ver....go back to "Additional Drivers" and select it...type in your password...after it installs re-boot your pc...you are done (Do not use a Beta driver..use the one Nvidia is currently offering)...currently ver. 375.26

Nvidia fan speed control

Open a Terminal & type: 

sudo nvidia-xconfig    (Press Enter on keyboard..type in your password..Press Enter again)

 

sudo nvidia-xconfig --cool-bits=4     (Press Enter on keyboard)

Close your Terminal & re-boot your pc...open Nvidia controls...click on "Search your computer"..in text box type" nvidia"...click on Nvidia icon see it show up in your task launcer as the Nvidia control panel opens?...right click it add to your laucher...go back & delete the word nvidia from "Search your computer" text box...close it out...now under your Nvidia control panel click on "Thermal Settings"...select "Enable GPU Fan Settings"...slide speed bar to percentage of fan speed you desire....click "Apply"...click on the "QUIT" tab You'll need to reset the fan speed each time you re-boot your pc.IF you experience bootup issues after installing the fan speed control it means your GPU is not compatible with fan control, so you'll need to remove your Nvidia driver..re-boot your pc * open a terminal type: sudo apt update && sudo apt upgrade     & autoremove everything the terminal shows that needs to be removed...re-install your Nvidia driver again/re-boot your pc without installing the fan speed control.

AMD *RX graphics cards (I have NOT tested this driver since I gave up on AMD-LInux drivers over a year ago)

http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Driver-for-Linux-Release-Notes.aspx

IF you are using an AMD RX series card the Singularity - Linux viewer is your best option

Keeping your 16.04 x64 system *completely Up-to-date

Approx. once a week open a terminal & type:   sudo apt update && sudo apt upgrade  (press Enter on keyboard...type in your password..press Enter again..after all installations are complete re-boot your pc

If you are using the Singularity-Linux viewer here is a way to get a general idea of your Frames Per Second (FPS) while logged into SL

After logging into SL see the "View" tab located at the upper left of your screen...click on it...click on "Statistics"...a small window will appear with FPS info, etc.

HERE is the biggy: I know you' ve read varying CPU, RAM along with graphics cards requirements posted in this Forum ranging from Advisors, Senior Helpers, Helpers, Members, etc all with varying min. specs required to really run SL well.  This simple pc resources *monitoring program* called Psensor will show you *exactly* how much computer resources SL is using while you are logged in-world. In Ubuntu 16.04 x64 go to Ubuntu Software...in the search text box type: Psensor..click on the thermometer icon...click "Install"...type in your password...it will create an icon on your task launcher..after install completes re-boot your pc. Click on the Psensor icon in your task launcher...close Psensor window ... see a thermometer icon in the upper right corner of your screen next to the up & down arrows?...go ahead log into SL & after logging in click on that thermometer icon and it will show you once & for all how much of your CPU is being used, how much of your RAM is being used, how much of your GPU is being used, CPU, GPU, Hard drive temps, etc, so as to put an end to the conflicting information posted in this Forum!

"I Love Simplicity"

 

 

 

 

 

Link to post
Share on other sites

Thanks for posting such a complete answer.

I have some doubts about the current 64-bit Firestorm under Linux, it can use pretty mind-boggling amounts of memory, and using virtual memory can be a performance killer. But it does work. I am left with the feeling that without the efforts of TPV developers, Linden Lab would have crashed and burned years ago.

Link to post
Share on other sites
  • 2 weeks later...

So glad I saw this post.

I have LM 18 partitioned on my machine with Win 10  and was wanting to install SL on the Linux side (because having to use any Microsoft product it just irks me on principle).

Guess I won't be doing that any time soon, though. Thanks for all the detailed info!

Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 1666 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...