Jump to content

Unusual movement on mesh head


pepper Mocha
 Share

You are about to reply to a thread that has been inactive for 2245 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I've rigged a head that i made in Zbrush and when i upload it into SL for testing, i noticed an error with the movement: the head seems to be moving when the avatar is not, its a slight jolting movement. What could be causing this error? I rigged it using Avastar in Blender and this is my first attempt so it's very likely i did something wrong :matte-motes-stress: but can't seem to figure it out for 2 days of trying different options, still get the same error.

Link to comment
Share on other sites

We generally consider an error something that pops an error message. I assume that isn't happening. The mesh just isn't behaving as you expect. Yes?

You haven't given us enough information to provide much help. Which version of Avastar? Which Blender? Which viewer version?

Are there any animations playing? What about the default animations?

Without anything to go on, I would assume the default animations are causing the movement. That would suggest the weighting isn't as clean as it should be. But, that is a VERY VERY speculative guess.

...and you do know about Porject Bento?

Link to comment
Share on other sites

Thanks for your reply Nalates. To answer some of your questions:

I'm using Blender 2.70, but I'm not sure where to find the version of Avastar I have - 

I'm using Firestorm version 4.7.5.47975, 64bit on Mac OS. I made the head originally in Zbrush and use Blender to rig and weight. 

At first, I did get an error message when I tried to export the dae. file, I don't precisely remember what it said, but it was about having unweighted vertices on my mesh so blender aborted the action. Afterwards, I tried again, and did not get the same error and was able to export, so I'm a bit confused. For the weights I tried two methods, copy from the avastar, and transfer the weights from an already rigged head. Both gave me the same result.

I test the head without any animations playing, just the default and the head moves in slight turns to the right and left, like a click, almost following the movement of the eyes??

And yes, i've heard of project bento, :matte-motes-agape: 

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2245 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...