Jump to content
  • 0
Sign in to follow this  
CordeliaDeLear

Menus are not displaying in a zone

Question

  • 0

I think I better write a brand new answer here, the first one I wrote got a bit too technical.

The reason why the menu fails, is that the server running the sim is too busy. Skinny Dip Inn is an extremely overloaded sim and even at the best of times, when there are "only" about 40 avatars there, the server has to skip between 60% and 80% of the scripts it's supposed to run. I wouldn't be completely surprised if it doesn't have time to run any scripts at all when the sim is really crowded.

Which scripts it skips is random so whether you are able to use the menus or not is just a question of luck.

 

Edit: I can't post twice here in the Answers sections, so I have to add to my original post.

I'm afraid the numbers are very clear. You can read the Scripts Run rate in the stats bar of your viewer. Type ctrt-shift-1 and scroll down about halfway. When I checked, Scripts Run varied between 20 and 40%, which of course means that between 60 and 80% of the active scripts in the sim did not run. That was with about 40 avatars int he region, more avatars mean more scripts and higher failure rate. The reason this doesn't cause lag in the normal sense is that the server has a built in safety mechanism to prevent script lag: when it gets too busy, it simply skips the scripts rather than slow everything else down. But of course, in your particular case, that safety mechanism is what caused the problem.

  • Like 4

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

I think I better write a brand new answer here, the first one I wrote got a bit too technical.

The reason why the menu fails, is that the server running the sim is too busy. Skinny Dip Inn is an extremely overloaded sim and even at the best of times, when there are "only" about 40 avatars there, the server has to skip between 60% and 80% of the scripts it's supposed to run. I wouldn't be completely surprised if it doesn't have time to run any scripts at all when the sim is really crowded.

Which scripts it skips is random so whether you are able to use the menus or not is just a question of luck.

 

Edit: I can't post twice here in the Answers sections, so I have to add to my original post.

I'm afraid the numbers are very clear. You can read the Scripts Run rate in the stats bar of your viewer. Type ctrt-shift-1 and scroll down about halfway. When I checked, Scripts Run varied between 20 and 40%, which of course means that between 60 and 80% of the active scripts in the sim did not run. That was with about 40 avatars int he region, more avatars mean more scripts and higher failure rate. The reason this doesn't cause lag in the normal sense is that the server has a built in safety mechanism to prevent script lag: when it gets too busy, it simply skips the scripts rather than slow everything else down. But of course, in your particular case, that safety mechanism is what caused the problem.

  • Like 4

Share this post


Link to post
Share on other sites
  • 0

It is simply not true. I have been using the zone for at least three months now on a very regular basis and I have only extremely rarely had a problem with lag and then it was minimal. The owner of the zone has made updates and, although that may be coincidental, and I am prepared to accept that I may have done something to cause it, the problem has arisen since then. This is not a lag problem, it is a problem with scripts not working.

 

Share this post


Link to post
Share on other sites
  • 0

If you don't believe me, just check yourself. The scripts failure data is readily available in the viewer for anybody to see. See my edited post for how to do it.

Share this post


Link to post
Share on other sites
  • 0

Well, you were wrong and don't be so arrogant.

There is obviously more than one reason why scripts fail and, as I have said, lag has never (well, extremely rarely) been an issue.

It turns out that the beach towels and hot tub are under the name of someone who had been blocked.

I discovered that by, following an im to the zone owner, with no response, I realised that there were names associated with objects in the zone and tried to im the person responsible for the towel, only to get a message that they were blocked.

Share this post


Link to post
Share on other sites
  • 0

Cordelia, I'm neither wrong nor right. I just tell you what the server statistics say. So if you want to accuse somebody or something, tell the server it's lying, not me.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...