Jump to content
Sign in to follow this  
Luc Starsider

Rich text editing does not work, nor degrade gracefully, on iOS devices.

Recommended Posts

When trying to post, comment or edit using an iPhone or an iPad, you have to go to the HTML tab to be able to edit text. The rich text editor displays correctly, but the text field is totally unresponsive using mobile Safari. 

It may not be possible to make the rich text editor work on iOS devices, and perhaps on other mobile browsers, I don't know. If not, maybe the rich text editor should be hidden when these devices/browsers are used to edit content.

- Luc -

Share this post


Link to post
Share on other sites

Yes. That's what I fond out. Which mean you have to know, at least, some basic HTML if you want to post using an iOS device. (Probably not a big deal, but still). It would be interesting to hear how the rich text editor works in other mobile browsers.

- Luc -

Share this post


Link to post
Share on other sites

dunno, but the quote spellcheck, preview, and macro functions aren't working from the V2 webkit either... and because the mousovers fail, I can't edit a post either....

Share this post


Link to post
Share on other sites

@Void. Does not the menu come up when you click the 'options' button to get to the edit command? I seem to remember I did that on my iPhone the other day, and I got to choose to edit my post. The first time I created a reply on my phone, I had to go back several times to change the html, which didn't behave the way I expected.

@Cerise. Let's hope they do keep up to date this time. This issue is probably not important by itself, but it could be seen as one indicator of LL's attitude towards things in general. Along with other indicators, a picture starts to form...

- Luc -

Share this post


Link to post
Share on other sites

Test.. sent from Android phone running Dolphin HD browser. I don't actually SEE any rich text options. So they ARE technically hidden.

ETA: LL would have to optimize the site for mobile devices (ex.: "m.community.secondlife.com") for some content to work the way people want it to, and I don't know if that's high on their list of priorities.

Share this post


Link to post
Share on other sites

Interesting. Then it seems the community works slightly differently on Android than on iOS. At least with the browser you use. On the iPhone, the rich text interface is on display, but does not do anything. I much prefer the way it works on Android - that you actually don't see the options if they don't work.

You're probably right that a mobile version is not high on LL's priority list. It shouldn't be with all the other things that are half broken in SL It would be cool, though, if they provided a mobile version Considering what Cerise wrote earlier, rich text editing is already fixed by lithium, but just not implemented by LL yet.

- Luc -

Share this post


Link to post
Share on other sites

Right, they will not try to make TinyMCE compatible, they chose the "degrade gracefully" option.

So, the rest of this will make more sense if I add it to the right post!

There is a mobile option for Lithium, but it does not appear to be enabled on the Second Life boards. forums.att.com and the HP support forum are examples wtih it enabled [ I really love the memorable host names HP has for public sites ].

Adding -- to see the mobile option on those boards, you will have to go from a mobile browser, or change the user agent on a desktop browser.

Share this post


Link to post
Share on other sites

 


Luc Starsider wrote:

@Void. Does not the menu come up when you click the 'options' button to get to the edit command? I seem to remember I did that on my iPhone the other day, and I got to choose to edit my post. The first time I created a reply on my phone, I had to go back several times to change the html, which didn't behave the way I expected.

 

doesn't do anything at all (well not entirely true, it refreshes the page and puts you at the top because it's a dead end link.)

same for the board and forum option drop downs, regardless of the mouseover setting in preferences.

 

heck TBH I'm suprised it let's you log in at all via SL webkit, since it was having problems with that before.

Share this post


Link to post
Share on other sites

@Griffin/Cerise. I'm not surprised that TinyMCE have not been able to make RT editing actually work in iOS. Unless Apple steps in and provides facilities for it, I believe the fallback to a simpler interface on these devices is all we can hope for. So, in a sense, it is fixed. :) Personally, I'm ok with that.

@Void. I'm always a bit surprised by how things work - or not work in this case - differently between to devices of the same type. Especially when we are talking two Apple iOS devices. It's the same hardware components inside. In my mind, they should behave pretty much the same. I should be used to it, though. It happens all the time both with the SL viewer and in the place I work...

@Darrius. I agree with Void - that's often the impression I have. Nicely summed up!

@Paladin. That sounds very similar to what I get. I can see the RT buttons, but can not enter the text field.

- Luc -

Share this post


Link to post
Share on other sites

Interestingly,  it is easy enough to post @ SLU from the Ipad.  I'm not sure why LL wanted to make this so much more complicated,  even the answers section has become "tricky".  Personally,  I find it a bit frustrating,  but thankfully I do have enough knowledge of html to post that way, so it's at least doable.

Thanks for the info.,  it is very helpful !!   :smileyhappy:

Share this post


Link to post
Share on other sites

I tried to edit a post on my iPad today, and things have improved! The rich text editor is hidden, and I didn't have to write html into the field but it still came out pretty good. I guess we still have to type html tags to use text effects, links and images, but for basic editing, it works well.

- Luc -

Share this post


Link to post
Share on other sites

I've tried doing a couple of posts from my iPhone and iPad. It's possible using the HTML tab, but a little painful to have to manually type HTML code to even get paragraph breaks. It sort of defeats the convenience of having a mobile device.

For what it's worth, the old Jive forum had the same problem. I could only post from the HTML tab.

Share this post


Link to post
Share on other sites

OK. I don't want to create another thread for this, so I'm adding to this one.

Personal messages have the same issue. Rich text editing toolbar, field, panes for Rich text, HTML and Preview is visible, but Rich text is not possible to use on iOS devices. I don't know if it is the same on Android and other mobile devices.

BTW. I'm sligtly confused as to where to report these things at present. I'm not sure whether to file jiras, post things - like with this issue - to this section in the community, add things to the user group meeting agenda or IM/PM one of the Lindens with issues. I seem to have picked up different info regarding this from different places, and I'm not sure where the best place to bring thses issues up is anymore... :(

- Luc -

Share this post


Link to post
Share on other sites

my take is that the mods here are fairly involved, so reporting lithium issues here is probably more effective, if less trackable.

Share this post


Link to post
Share on other sites

Yeah, I kind of have the same impression. They seem to cach a lot of issues posted here. Guess we could always post in all the places available just to make sure. :)

 

- Luc -

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...