Jump to content
  • 0

Turning off swirling particles?


Britta Bloch
 Share

You are about to reply to a thread that has been inactive for 1869 days.

Please take a moment to consider if this thread is worth bumping.

Question

  • 0

Swirly particles appear when a scripted object is talking to you.  The only way to stop them is to make the scripted object stop talking.  That's easy if you own the object and have mod access to its scripts so you can kill any messages that it's trying to send.  Otherwise, no.

If you are a scripter, I suggest using llRegionSayTo and targeting your messages to a specific person  instead of using llSay and broadcasting to everyone in range.  Swirly particles are only visible to people who can receive the chat message.

  • Like 1
Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 1

To disable the swirling particles when scripts communicate at least if your using firestorm simply do the following. CTRL ALT D to show advanced menu ( at the top of your viewer window ) click advanced and select show debug settings. Type this into the box EffectScriptChatParticles  set to false and tada!

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

  • 1
1 hour ago, dravenrose Resident said:

To disable the swirling particles when scripts communicate at least if your using firestorm simply do the following. CTRL ALT D to show advanced menu ( at the top of your viewer window ) click advanced and select show debug settings. Type this into the box EffectScriptChatParticles  set to false and tada!

@Britta Bloch - Same thing in the regular SL viewer.

  • Like 1
Link to comment
Share on other sites

  • 0

Swirly particles appear when a scripted object is talking to you.  The only way to stop them is to make the scripted object stop talking.  That's easy if you own the object and have mod access to its scripts so you can kill any messages that it's trying to send.  Otherwise, no.

If you are a scripter, I suggest using llRegionSayTo and targeting your messages to a specific person  instead of using llSay and broadcasting to everyone in range.  Swirly particles are only visible to people who can receive the chat message.

  • Like 1
Link to comment
Share on other sites

  • 0
On 4/9/2017 at 4:21 AM, dravenrose said:

To disable the swirling particles when scripts communicate at least if your using firestorm simply do the following. CTRL ALT D to show advanced menu ( at the top of your viewer window ) click advanced and select show debug settings. Type this into the box EffectScriptChatParticles  set to false and tada!

this dont work...

Link to comment
Share on other sites

  • 0
51 minutes ago, Birdychik said:

this dont work...

Then either something has changed very recently or you have done it wrong.  The swirly particles are only visible to the person that the scripted device is sending a message to, and -- contrary to my own post at the top of this thread -- can be toggled on/off with that debug setting.  Many debug settings are only temporary, however, so they revert to a default when you log out of SL.  I can't be sure right now whether EffectScriptChatParticles is one of those temporary settings -- I am away from home and cannot log in to SL to test -- but that would not surprise me.  If so, you'll have to set it every time you log in, or just relax and live with the swirlies like all the rest of us.

Link to comment
Share on other sites

  • 0
On 4/30/2016 at 0:44 AM, Britta Bloch said:

I am wondering if it is possible to turn off the particle swirls that happen when I right click the ground or objects in world? I am not talking about selection beams, that I already have turned off. I've also disabled the particle effects when I am giving someone an item.

A lot of people are giving you wrong advice as there are two types of swirling particles, one set is when an object talks, which they all refer too, and another is when you "right click the ground or objects in world?" as you ask.

Some viewers let you mask this, the SL one doesn't, some don't show it (like firestorm) but it's still there for others to see. I know Singularity turns them off when you disable selection beams.

It's one you sort of need to live with, well, unless Whirly knows a secret setting to stop the swirl when you right click the land.

Edited by Callum Meriman
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 1869 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...