Jump to content
Sign in to follow this  
Illusion Panache

How to select a root prim completely enclosed inside an object?

Recommended Posts

In a build I've been editing, I've stupidly allowed the root prim to become completely enclosed inside other prims in the object. Now I need to move the root prim, but I can't click on it to select it. The work is fairly complex, so i don't want to undo the rest of what I've done. Is there any way to select an inaccessible root prim, or any other linked prim that can't be directly clicked on, without disturbing intervening prims? Thank you for your help.

Share this post


Link to post
Share on other sites

Hey there Illusion!

Open your edit menu select 'edit linked parts' deselect the object if it was selected. From there hold 'shift' and click-drag over the area of the root prim. alternatively, select enitre object and wtih 'edit linked parts' enabled, de-select all the linked prims until you get to the root you are looking for.

 

I hopethis helps.

Share this post


Link to post
Share on other sites

In the Advanced menu, Rendering>>Hide Selected.  This will hide each thing you select.  CTRL-3 to the edit prim menu, turn on Edit Linked Parts and using the shift key to keep adding things to your temporary list of hidden parts as you click in until you find your root prim, then lift the shift key and click the root.  Everything will jump back to visibility, but you will have the root prim and can drag it out to where you can edit it more conveniently.  When you're done getting the root prim out, turn off the Hide Selected function.

  • Like 1

Share this post


Link to post
Share on other sites

much simpler than the above methods.... open edit for the object, check "edit linked parts" press [ctrl+.] (that's a period)

this cycles you forward through the linked prims, [ctrl+,] (that's a comma) cycles you backwards.

those only work while edit link parts is cheked

  • Like 2

Share this post


Link to post
Share on other sites

 


Badpeaches Blackheart wrote:

Ctrl + (period) or (comma) only works for Viewer 2. 

not true, I know that Phoenix and Cool VL both suport it, and I think imprudence as well

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...