Jump to content
Sign in to follow this  
Nadore

Insanely Low FPS GTX 980Ti

Recommended Posts

I have a PC that can run Witcher 3 on Ultra settings 60 FPS+, but in Second Life, I only average around 12 FPS.

Full PC Specs:

Intel i7-4790K

EVGA GTX 980Ti SLi

16GB Ram

500GB SSD

Windows 10.

 

I Don't know what's wrong, but I believe I should be able to get playable FPS (30+) on Ultra settings. Any ideas as to why I only average around 12?

Share this post


Link to post
Share on other sites

You just cannot compare SL to other games. The content is simply vast and nearly completely in optimized. I have a similar machine. I don't get 30 to often on ultra. Just the way of SL

Share this post


Link to post
Share on other sites

Check your settings if Advanced Lighting is turned on it may be dragging your FPS down. Even with the powerful rig you have. 

Share this post


Link to post
Share on other sites

I have your same card and very similar specs. I use shadows ALWAYS and advanced lighting and often Depth of Field.  Just checked my framerate and it was 85.   If yours is ALWAYS low  -- you have some other issue besides your card. Now and then mine goes way down depending on where I am and how many programs I have been running all day but a reboot fixes that.

 

I am on Firestorm but I doubt that is the difference :D. Good luck.

Share this post


Link to post
Share on other sites

what should give you at least those 30 FPS even at busiest places crowded with many high polygon mesh avatars and heavy builds around is untick advanced lightning, tick avatar impostors, set impostors slider to max 20-30 and lower the draw distance, you can also make a profile for your SL viewer in nvidia control centre/manage 3d settings and try various settings there, btw for some reason my card doesnt run in its boosted clock stage when playing SL, this can be fixed by using EVGA precision app and clicking on KBOOST in top right corner (just dont forget to turn it off when youre done playing or your card will be running full speed and loud while it should idle)

Share this post


Link to post
Share on other sites

How do you read out the FPS? Try with the statistics window Ctrl+Shift+1. At the very top are the FPS shown. If the viewer is out of focus (click on the taskbar for example) the viewer will go idle and drops FPS.

Also, do NOT uncheck Advanced Lighting Model, It's performance impact will be very little if any at all with your hardware.

You may set Shadows to None, uncheck Ambient Occlusion, and maybe set Reflections to something else than Everything.

Set Draw Distance to 128, and make sure Enable VBO is checked.

If you still don't get more FPS than 12 in various locations, there is definitely something wrong with your setup.

Share this post


Link to post
Share on other sites

Look in your NVIDIA control panel. You should be able to open it by right clicking the wallpaper on your 'Desktop". Look in your "Manage 3D Settings". Look for an entry for Second Life in Program Settings. If there isn't one, add one. Make sure you set Powre Management Mode to PERFORMANCE.

If you have a laptop this is very likely the problem.

When you ask for tecnical help we need lots of information. The best source is the viewer's HELP->ABOUT... copy and past that info with a question like yours. Also, whether you are running a laptop or desktop makes a difference.

Without that information we are guessing and you'll have to sor through all our guesses good and bad.

Share this post


Link to post
Share on other sites

 

even with mine,  I still only get 12 fps in certain areas. but have learned one thing.  busy area. drop that draw distance to minimum.  you'll pick good fps up and turn off shadows. 


CPU: Intel® Core i7-5820K CPU @ 3.30GHz (4124.99 MHz)
Memory: 32669 MB
OS Version: Microsoft Windows 10 64-bit (Build 10240)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GTX 980/PCIe/SSE2

Share this post


Link to post
Share on other sites

Even the beefiest systems can be brought on their knees by Second Life. You must not forget that this isn't an optimized area that just loads from your hard/solid-state drive with prebaked scenes, and neither is Second Life optimized to utilize stuff like more than two threads, heaps of RAM and other goodies like NVidia's CUDA. (At least not that I'm aware of.)

I have an overclocked 980 Ti, i7 6700K and 16 GiB's of RAM, and I sometimes also get as low as ten frames per second. It all greatly depends on the scene, generally lots of Avatars and lots of Alpha Textures are your worst enemies frame-wise, especially since most people do not even bother to keep low-resource building in mind or aren't even thinking about it. All you can do indeed if you'd rather not sacrifice all the visual goodness is to keeps draw distance limited to what you need, more than 128 meters is pointless unless you're in a battle Sim or anything else that is large. Also play with the Avatar Impostor setting as it can make a huge impact on performance. Else in the worst case scenario you may have to disable Shadows, they also tax the CPU more from what I heard, but might be wrong there.

Share this post


Link to post
Share on other sites

Hello and welcome to SL/Forums.

Okay let's see here.

To compare, my specs are:

* Intel i7-4790K* EVGA Nvidia GTX 970 SC* 16GB RAM* SSDWindows 10 64bit

On the "Second Life" viewer v4.0.x (aka "official", "Linden Lab viewer"), I get a theoretical peak FPS of 200-220 FPS (empty regions), between 25 and 80 during normal use (depending on the scene), and an average of 45-50.

Your machine should be plenty.

So let's run down the basics here:

 

  1. Clear your Second Life Viewer settings (in your case, C:\Users\[user_name]\AppData\Roaming\SecondLife), your viewer cache (C:\Users\[user_name]\AppsData\Local\SecondLife)
  2. Install the latest SL viewer (https://get.secondlife.com)
  3. Go to the Nvidia Control Panel and manually disable SLI (for testing purpose)
  4. Reboot your computer after disabling SLI (it can bug out)
  5. Without touching the graphical preferences at ALL, try the newly installed Second Life viewer in a publicly accessible place that represents the expected "experience" (like "ahern" or "Ivory prim tower") and a fairly empty region (search for "Sandbox" or try a random region on the map)
  6. Keep track of your viewer performance using the statistics panel (control+shift+1), write down the FPS displayed while wandering around the sim, take note of minimum/maximum, and any oddities in your FPS that you encouter.
  7. AVOID the use of "Statistics"/teamspeak/mumble/etc overlays and other "debugging" tools. They can interfer with the viewer performance. (if you don't know if you're using one, you probably aren't).

Please report your findings with FPS values associated with the regions you visited so that we have more information to work with.

Share this post


Link to post
Share on other sites

Just throwing my two cents in, but on a FRESH reinstall of Windows 7 Pro 64-bit, with latest drivers, simular specs (minus the 500G SSD, only have a 240GB on RAID 0 (4x55GB OCZ RevoDrive), and I get about 45 FPS with dips at 30-25 in crowded areas. I know that the GPU topic comes up time and time again, but I will say after upgrading from my GTX 680 Lightning to my GTX980Ti Lightning, just getting 15 more frames per second is... really disappointing.

That being said, if you're ONLY frame rate is 15 FPS, there is something very wrong that I don't think is entirely on Second Life's part. if you have Afterburner or some kind of GPU monitor, check the GPU usages without Second Life running. If you see some kinds of usages with it off and nothing else running, there's something else happening.

Share this post


Link to post
Share on other sites

There is a lot that contribute to why your fps would be so low. I think it mostly boils down to the shadows that mesh bodies render. If you are in an area with a ton of people who have poorly done mesh bodies and you decide to have shadows on you are probably going to have a bad time.

  I personally use Firestorm viewer, I have learned to leave the settings all but stock except for draw distance and shadows. I keep shadows on because it generally forces my clock speeds to stay high.  Now I know most people dont look into this kinda stuff so some of this is going to go in one ear and out the other.   But the thing that you want to do is Maintain a high power profile.

   Make sure that your graphics card has something to do. 900 series cards are designed to slow down when they are not working to their full potential. This can have a very negative impact on sl. If your card is running below 60%gpu usuage I can almost guess that your clock speed will slow down causing your frame rates to drop like a rock.

 

 One thing I would also do is to make sure that  Power management mode is set to  Perfer maximum performance in the "Manage 3d settings" portion of the Nvidia control panel. Doing this should help to stablize the graphical performance.

 

  Your experience is going to vary place to place. At my home I get much better frame rates.  During this post I decided to go Muddy's cafe.  I went from having consistatly over 50 fps to 24/25 with avatar shadows off.  If I turn all shadows off It jumps up again.  The point really is that SL and objects in it are very poorly optimized.  Learning when in where to change settings will help greatly.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...