Jump to content
  • 0

The Flash Player Plugin isn't working for me and I've tried installing 11.7


SwanofWar
 Share

You are about to reply to a thread that has been inactive for 2590 days.

Please take a moment to consider if this thread is worth bumping.

Question

  • 0

Starting with Second Life Viewer 4.0, the internal web browser of the Second Life Viewer has been updated to use the Chromium Embedded Framework.  This allows content creators to use a much wider array of web technologies in their products for Second Life, including Adobe Flash.  However, in order to use Flash in the Second Life Viewer, you must first install a specific version of the Adobe Flash Player on your computer.

Installing the Adobe Flash Player for use with Second Life

To install the Adobe Flash Player on your computer for use with Second Life:

  1. Make sure that plugins are enabled in the Second Life Viewer by choosing Me > Preferences from the top menu bar, then clicking the Setup tab of the Preferences window.  Enable plugins should be checked.
  2. Visit http://get.adobe.com/flashplayer/otherversions/ using your web browser.
  3. Under  Step 1, select your operating system.
  4. Under Step 2, select FP 20 for Opera and Chromium - PPAPI.
  5. Click the Download now button to download the Flash Player installer.
  6. Run the Adobe Flash Player installer and follow the instructions onscreen to complete the installation.
  7. Restart the Second Life Viewer.
  8. You may now view Flash content in the Second Life Viewer's web browser, and on Shared Media-enabled objects in the Second Life world.
  • Like 1
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Starting with Second Life Viewer 4.0, the internal web browser of the Second Life Viewer has been updated to use the Chromium Embedded Framework.  This allows content creators to use a much wider array of web technologies in their products for Second Life, including Adobe Flash.  However, in order to use Flash in the Second Life Viewer, you must first install a specific version of the Adobe Flash Player on your computer.

Installing the Adobe Flash Player for use with Second Life

To install the Adobe Flash Player on your computer for use with Second Life:

  1. Make sure that plugins are enabled in the Second Life Viewer by choosing Me > Preferences from the top menu bar, then clicking the Setup tab of the Preferences window.  Enable plugins should be checked.
  2. Visit http://get.adobe.com/flashplayer/otherversions/ using your web browser.
  3. Under  Step 1, select your operating system.
  4. Under Step 2, select FP 20 for Opera and Chromium - PPAPI.
  5. Click the Download now button to download the Flash Player installer.
  6. Run the Adobe Flash Player installer and follow the instructions onscreen to complete the installation.
  7. Restart the Second Life Viewer.
  8. You may now view Flash content in the Second Life Viewer's web browser, and on Shared Media-enabled objects in the Second Life world.
  • Like 1
Link to comment
Share on other sites

  • 0

In 2013-15 the Flash plug-in was a problem and suffering growing problems. This is from a combination of WebKit, the browser engine used by the previous viewers' built-in browser, not being maintained by its creators and Adobe’s Flash being replaced by newer technology. The Lab looking for a way to restore the functionality turned to Chromium Embedded Framework (CEF), a new core browser engine.

A long series of events has lead to Flash becoming an obsolete technology. One nail in its coffin is the security risk it poses to users. Google peeps consider it so great a risk the current releases of the Chrome browser disable Flash and Flash like plug-ins by default.

Knowing that WebKit and Flash were dying tech and  a change to CEF was coming the Lab has not fixed the WebKit/Flash problems. They did provide the steps to work around the problem for those that need to display Flash. Their instructions make no mention of the security risks. Nor do they mention how poorly it may work or not for any specific app.

As of December 2015 the version 4.0 and newer Linden Viewers have the CEF engine, replacing the WebKit engine. Starting in December 2015 you could find the release candidate in Beta Viewers (See the Second Life download page).

CEF does not support FLASH. In general if you need to display Flash inside the viewer, you have a challenge. Fortunately the Lab has explained how to enable Flash in their version 4.0 and newer viewers. See: How to use Adobe Flash in Second Life Viewer 4.0 and later.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2590 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...