Jump to content
  • 0

i have not been able to download the latest version of SL. i am a Premium member. Help me


Damona Rookswood
 Share

You are about to reply to a thread that has been inactive for 2609 days.

Please take a moment to consider if this thread is worth bumping.

Question

  • 0

You didn't say what sort of computer you have, but it sounds like it may no longer meet the minimum requirements for running a SL viewer.  If you are running your Mac with an operating system that is older than OS X10.7, you will need to upgrade it in order to run any of the current viewers.

If you want to provide extra information or need to clarify your question, click on the Options link in the upper right corner of your question and select EDIT. Please do not start a new thread. Doing that makes it hard for us to see what other people have already suggested, and it pushes other residents' questions off the page.

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

You didn't say what sort of computer you have, but it sounds like it may no longer meet the minimum requirements for running a SL viewer.  If you are running your Mac with an operating system that is older than OS X10.7, you will need to upgrade it in order to run any of the current viewers.

If you want to provide extra information or need to clarify your question, click on the Options link in the upper right corner of your question and select EDIT. Please do not start a new thread. Doing that makes it hard for us to see what other people have already suggested, and it pushes other residents' questions off the page.

Link to comment
Share on other sites

  • 0

Make sure you do a clean install--- 

If you dont do a clean install then you will get more errors and lag

CLICK here for the way to do a REAL clean install

http://www.firestormviewer.org/ttt-clean-install-the-easy-way/

 

As i agree with Miss ROLIG-- your comouter may not meet SL requirements....IF you can ADD to this thread and NOT make a new one of your computer's settings...

you can do that by going on your viewer and CLICK HELP>>> them ABOUT FIRESTORM (copy and paste the information there) in to the ADDION of this thread...it REALLY helps us help you  --- 

ALSO CLICK HERE to see if you meet SL minimum requirements https://secondlife.com/support/system-requirements/

 

OR....

one suggestion is to try version 4.7.3.37323....OR go back to the firestorm viewer you had work for you before

I hope that helps you

 

HUGS

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2609 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...