Jump to content
Sign in to follow this  
Shaade Fallen

.anim or .bvh?

Recommended Posts

Hello =3

 

I recently got into making my own animations and furniture, using blender and Avastar. I began to run into problems however, as some of my .bvh animations weren't behaving correctly within SL.

I contacted Avastar support and they suggested I save the files as .anim instead. I was under the impression though, that people need to use a certain viewer or something for .anim files to work properly? All the tutorials I read said to use .bvh also.

Just want to know if anyone has experience on the subject, and can tell me whether it's ok to use .anim files for animations on furniture that is intended to be sold?

Thankies~

Share this post


Link to post
Share on other sites

Anim is SL's native format, use it, it's perfect.

Tutorials will say bvh because likely the software doesn't support anim or the tutorial writer hasn't discovered anim yet :)

  • Like 2

Share this post


Link to post
Share on other sites

Seconding .anim format, animations run much smoother.

At the beginning I was using the .bhv format, as stated in many tutorials but upon closer inspection of my uploaded animations they seemed to be a bit laggy. Minorly so but enough to drive me batty. A fellow creator on the BB group chat pointed me toward using .anim and now my uploaded animations are 100% smooth and play exactly as they do in blender.

One note though, if you do use blender for your animations; if you upload in .anim format you will need to tick the box inside blender to loop an animation, unlike with the .bhv format where you tick the loop box during upload within the SL client.

Happy creating :)

Share this post


Link to post
Share on other sites

If I use Qavimator, I should always save to *.anim to preserve the animation so I can edit it later, right?

Sorry to ask, never knew I could upload *.anim to SL, I always assumed BVH, because Qavimator says "Export for 2nd Life" and saves it as BVH.

Share this post


Link to post
Share on other sites

I made an animation (.anim) in Blender and uploaded it. When I want to play it, it holds the first frame and plays on when I hit the stop button...

it plays to the end, then stops, though I checked the loop button before exporting in blender. Can somebody please give me a hint?

got it, have to set the loop start and ending...

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...