Jump to content

Kernel Exception (error 3) HELP!!!!


Flea Habilis
 Share

You are about to reply to a thread that has been inactive for 2643 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

What follows is a re-post from the Q&A section that I put in. I have no way to respond to the people who send me advice in the Q&A area except for a private message, so I have chosen to move my question here. I will be paying attention to both, but I would prefer responses to be directed here. Thank you.

 

_____________________________________________________________________________________________________

Please read the whole post before responding...

I am not writing this for myself but for my friend. I will try to provide as much information about the situation as I can, but I am trying to give her the confidence not to give up on trying to fix this problem. Graphics card is Nvidia Geforce GT 740. The crashes began on Windows 7, but the PC currently runs Windows 10 with no issues. Windows 10 has been completely re-installed as well, following a complete hard drive format. This was not by choice, as an issue entering safe-mode without the password required formatting the hard drive.

 

http://postimg.org/image/6x8ij6t1b/

http://postimg.org/image/of88dzagr/

http://postimg.org/image/o4eamftz3/

 

The above images are from an event viewer description of the error in question. Here are the particulars of the crash:

1) The crash only happens in Second Life viewers and has occured with the use of the Linden Lab viewer, Firestorm, Singularity, and Black Dragon. Every other game, including graphically intense games, like Saints Row 4, runs like a dream. We have tried clean installs of all viewers multiple times. Not just uninstalling via the program's built-in uninstaller, but using the method recommended by Firestorm's "clean install" instructions. All viewers that have been tried are either currently the most recent version or were the most recent version at the time the install was attempted. Currently using Firestorm 4.7.3 (47323) as the most recent. We have also tried the 32 bit versions of the Viewer with no improvement.

2) It seems to happen at random intervals. Sometimes it will not crash for 4 or 5 hours of pay, sometimes it will happen 3 or 4 times in the space of 15 minutes.

3) We have tried updating the graphics drivers (they are currently at the latest version), we have tried installing older drivers, we have tried uninstalling Geforce Experience, we have tried clean-installs of all drivers. Nothing seems to affect the frequency of the crashes.

4) We have replaced the hard drives, power supply, the case, the motherboard, the graphics card (All GT 740s, from the 2 gig to the 4 gig. The 2 gig card resulted in BSODs so we stopped using it), the ram sticks, fans, the keyboard, the mouse more than twice. The only thing that has not been replaced is the processor, but we have reapplied the cooling gel with no noticable impact on the crashes, either good or bad. The Pc has been cleaned by a professional and has no dust buildup.

5) Every method of determining the error in question points to this Kernel exception 3. There is virtually no deviation from this except for an occasional Error Code 7.

6) The crash happens regardless of how many people are around in a sim, as it happens both in populated sims and empty ones. There is no framerate drop or any other flucctuation in performance up until the crash takes place. The computer, itself, both before, during, and after the cash functions normally with no performance issues.

7) We have tried many recommended compatability modes for running Firestorm or the SL viewer. They all have administrator rights. We cannot claim to have tried every possible combination under compatability mode.

 We are mystified after how many times this computer has been rebuilt and, like the Ship of Theseus, one could make the argument that it is a completely different computer from the one we started with. We are completely out of ideas about what could be causing the problem across these different machines.

We welcome ANY advice that doesn't involve repeating advice we have heard from multiple sources to update the drivers. We have updated the drivers. Please do not ask us to update the drivers. We will not install an old driver unless you can specifically tell us which old driver we need to install and why.

If you know where else we might post this question to get answers, I would also welcome these answers as well. We have been running under the assumption that the graphics card, either the driver or the card itself, is to blame. However, there are conflicting symptoms. If the graphics card was somehow physically damaged, why does it only affect second life and no other game? La Noir, Sims 3 and 4, Saints Row 3 and 4, GTA4, Star Wars:The Old Republic, Civilzation V and a host of other games are ALL played on the HIGHEST settings specifically for the purpose of stress testing the machine to reproduce the error.

If the graphics card was physically damaged, we would have expected to see performance issues or errors there. We have yet to see any other program behave like this. This leads us to believe the issue might be with Second Life alone, but we don't know for a fact. There is only one other game that crashed like this and it was Minecraft. We don't know what caused that, either.

We have run out of options and ideas. Please help.

 

-Fiona

 

P.S. Seriously... don't ask us to update the drivers.

 

__________________________________________

VIEWER INFO

 

Firestorm 4.7.3 (47323) Aug 18 2015 03:46:39 (Firestorm-Releasex64) with OpenSimulator support
Release Notes

Second Life Server 15.10.14.305984
Release Notes

CPU: AMD Phenom(tm) II X4 965 Processor (3400.07 MHz)
Memory: 16346 MB
OS Version: Microsoft Windows 10 64-bit (Build 10240)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GT 740/PCIe/SSE2

Windows Graphics Driver Version: 10.18.0013.5582
OpenGL Version: 4.5.0 NVIDIA 355.82

RestrainedLove API: RLV v2.8.0 / RLVa v1.4.10a
libcurl Version: libcurl/7.38.0 OpenSSL/1.0.1i zlib/1.2.8
J2C Decoder Version: KDU v7.6
Audio Driver Version: FMOD Ex 4.44.56
Qt Webkit Version: 4.7.1 (version number hard-coded)
Voice Server Version: Vivox 4.6.0017.21209

Settings mode: Firestorm
Viewer Skin: Firestorm (Grey)
Font Used: Deja Vu (96 DPI)

Font Size Adjustment: 0 pt
UI Scaling: 1
Draw distance: 128 m
Bandwidth: 1200 kbit/s
LOD factor: 2
Render quality: High (5/7)
Advanced Lighting Model: Yes
Texture memory: 512 MB (1)
VFS (cache) creation time (UTC): 2015-9-26T8:19:20
Built with MSVC version 1800
Packets Lost: 8/47,783 (0.0%)

Link to comment
Share on other sites

Rhonda Huntress wrote:

 

"I saw you have tried another power supply, but are you sure you are getting enough power to the graphics cards?  Have you tried using an overclocking tool?  Try LOWERING the speed of the card or bumping the power up a few millivolts."

 

I would do this if I knew how to do it safely without damaging the graphics card. Can someone give me pointers on how to do this?

Link to comment
Share on other sites

EDIT: This is actually very very close upon further inspection. My response below is still somewhat relevant, but I'm going to be reading all the attached forum responses very closely.

 

Thank you!!!

_________________________

 

Almost, except that the problem you're pointing to has to do with a recent driver version with Windows 10 and the problem we are experiencing goes back to Windows 7. There is over a year of this and we have no idea what driver to roll back to because it has been exactly that long since a driver has worked for us.

Unless someone can provide us with a good strong hint about which driver to go back to, pointing out that the latest Nvidia Driver doesn't work isn't really much use to us at the moment.

TL;DR: If we knew which driver to roll back to, we would have done it by now. The devil is in the details.

Link to comment
Share on other sites

I'm curious if the driver crash still happens if no web browser is open while running an SL viewer.

Some people with Nvidia cards have found this driver crash is triggered by having a website page open displaying flash content while running an SL viewer - Chrome browser in particular seems to trigger the crash most easily.

For those that use Firefox, disabling hardware acceleration for flash can fix the problem.

I have another friend who suffered badly from this driver crash on her Win 7 system. Her card was factory overclocked and on the advice of Nvidia support, she set the card back to the default clock for that card and it totally fixed the problem.

Link to comment
Share on other sites

given what you said in 4) about all the stuff that you have replaced then:

a) it could be a BIOS incompatibilty. Try to update the BIOS if you can

b) a second possibility is Remote Access. If the computer is set up to allow you to remote into it then this has always been iffy. Try turn that off and see

c) if is not hardware and not remote access then there is a Assert() in the codes somewheres (not necessarily LL codes, could be but could not be as well. Like in Flash, or Anti-virus, or etc)

the Assert() exception is being unhandled bc

1) is no exception handling code for the assert()

2) is no Debugger running

+

is more tech stuff here

https://msdn.microsoft.com/en-us/library/windows/hardware/ff559271(v=vs.85).aspx

 

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2643 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...