Sign in to follow this  
Linden Lab

Project Valhalla: CEF - Media on a Prim and in-Viewer Browser Overhaul

Recommended Posts


Linden Lab wrote:

Let us know your thoughts about the CEF - Media on a Prim project! For more context and information -
first!

 

Will the new features also include the ability to read PDF files on a web site? At the moment, that's one of the things the current shared media technology lacks.

Share this post


Link to post
Share on other sites
Whirly Fizzle    1,039

On Windows 7 64bit, using Second Life 4.0.0 (305703) Oct  6 2015 16:16:54 (Second Life Project Valhalla)

Reading pdf files in the internal web browser does not work for me.

It didn't work under webkit either though.

Share this post


Link to post
Share on other sites
Ai Austin    1

This is a good move and should be very useful for MOAP... but the legacy things that QuickTime gave us on the plot media texture were very useful.

MPEG4 (.mpg) movie playback and loops, and real time streaming media (.sdp) even for live events, is something we have used a lot at the Virtual University of Edinburgh for things such as virtual graduations (e.g. streaming the real graduation to our virtual graduands, and vice versa).  Will such things work with the default configuration or will addins be required?

If addins are required it would be nice if you can find a way to package those into the release so everyone has them avalable.  Or if that is impossible at last some "common addons" web page with download links so there is an easy way to tell any user how to set up to make things that were accessible on the media texture and hence media screens in world work.

An initial test of the Project Valhalla viewer on my Windows 10 setup did have the media texture screens showing a quicktime server .sdp stream and a looping MPEG-4 video on the screens (as shown in the image above), but I am not sure if that is because of other elements I already have installed or if its included by default in the Valhalla viewer.

Share this post


Link to post
Share on other sites
davidventer    2

Wow, it's about time! Web on a prim has been broken on OS X since around 2012-ish. Vidoes would play but there would only be sound, no visuals, just a black screen.

I reported it year after year and every time the issue got accepted but I thought that it was never going to get fixed.

I tried this new viewer and I can now watch videos in SL again! Yay! Thank you for FINALLY working on this issue and for putting modern web standards into SL! I can't wait for this to be in the official viewer.

Now if only you can fix the retina display issue too, that would be great.

Share this post


Link to post
Share on other sites

Oh nice! The Web Storage API works now. That should open up some possibilities. I was actually just tinkering with that in the current viewer for a HUD idea and was disappointed to see it wasn't supported in the current viewer.

It's good to see you all making this effort, it should help head off some security issues by getting us away from plugins while keeping MOAP capabilities up to date with where web development seems to be headed.

Out of curiosity, is there any work being done to provide some sort of proxy layer for viewer doing MOAP? I've seen many comments since MOAP came out concerned about the direct access to third party web servers from the SL client, allowing those third parties to associate IP addresses to avatars. I think a fair number of people disable MOAP just so they can remain more anonymous, and having some sort of default proxy service might help adoption.

Share this post


Link to post
Share on other sites


ObviousAltIsObvious wrote:

the new browser is still a little rough yet, but PDF viewing is working here.
 

Oh, awesome! This solves a dilemma I had encountered, a few days ago, concerning the issue of getting my PDF book into SL, for the convenience of Residents. Because of the charts and tables in the book, simply copying and pasting into a notecard was not a solution. The only one I'd been able to find was using shared media, but then I found that PDFs simply didn't load, correctly, on it, which was incredibly frustrating. I'm so happy that this is now a viable solution! Or, at least, that it will be, when it's official. I hope that's soon! Until then.... I think I'm going to have to download this viewer, because I'm not sure I can wait. :D

Share this post


Link to post
Share on other sites


KeeperS Karu wrote:


ObviousAltIsObvious wrote:

the new browser is still a little rough yet, but PDF viewing is working here.
 

Oh, awesome! This solves a dilemma I had encountered, a few days ago, concerning the issue of getting my PDF book into SL, for the convenience of Residents. Because of the charts and tables in the book, simply copying and pasting into a notecard was not a solution. The only one I'd been able to find was using shared media, but then I found that PDFs simply didn't load, correctly, on it, which was incredibly frustrating. I'm so happy that this is now a viable solution! Or, at least, that it will be, when it's official. I hope that's soon! Until then.... I think I'm going to have to download this viewer, because I'm not sure I can wait.
:D

So I downloaded the viewer, and I immediately checked a few random web sites to see if I can read PDF files. For me, now matter how many times I reloaded the page, the PDF pages just wouldn't load.

 

Here are my system specs, if it will help:

Operating System: Windows 10 Home 64-bit (10.0, Build 10240) (10240.th1.150930-1750)

Language: English (Regional Setting: English)

System Manufacturer: Gigabyte Technology Co., Ltd.

System Model: GA-A55M-DS2

BIOS: Award Modular BIOS v6.00PG

Processor: AMD A8-3850 APU with Radeon HD Graphics (4 CPUs), ~2.9GHz

Memory: 8192MB RAM

Available OS Memory: 7678MB RAM

Page File: 4701MB used, 4639MB available

Windows Dir: C:\WINDOWS

DirectX Version: 11.1

DX Setup Parameters: Not found

User DPI Setting: 144 DPI (150 percent)

System DPI Setting: 96 DPI (100 percent)

DWM DPI Scaling: Enabled

Miracast: Not Available

Microsoft Graphics Hybrid: Not Supported

DxDiag Version: 10.00.10240.16384 64bit Unicode

Share this post


Link to post
Share on other sites
Oz Linden    106


Loraan Fierrens wrote:

 

Out of curiosity, is there any work being done to provide some sort of proxy layer for viewer doing MOAP?

Not at this time.

 

Share this post


Link to post
Share on other sites

Any chance there will be functionality to allow everyone to see realtime actions an avatar is making to a website?  "Scrolling, clicking, playing videos in sync"

I believe in a virtual world being able to share the experience in real time would be very important.

Share this post


Link to post
Share on other sites

I tested the html5 and wish it could still run flash because alot of websites are still using it (i know html5 is the future but i wish we can switch back and forth to which we like better). Also  i wanted to see if the html5 could play some html5 games but it cant (only some). Hopefully it will be stable and what I really wanted was a way to do webcam on a prim but it would ask for permission. Im just happy they working on it and hopefully improve it.

 

Also here is a simple example of a game i wanted to test out but it didnt work 

 

http://oldboyfx.com/space_shooter/

Share this post


Link to post
Share on other sites

So I played around, further, with shared media in the project viewer. As one person noted, while I'm still having trouble loading up pdfs from other sites, I can kind of see pdf files from google drive. I had uploaded a pdf file and navigated to that link. While it displays the first page, it won't let me scroll to the other pages. So the ability to view pdf files is very much still rough and needs to be smoothed out, quite a bit.

Share this post


Link to post
Share on other sites
Whirly Fizzle    1,039


Deadly Olivier wrote:

I tested the html5 and wish it could still run flash because alot of websites are still using it (i know html5 is the future but i wish we can switch back and forth to which we like better). Also  i wanted to see if the html5 could play some html5 games but it cant (only some). Hopefully it will be stable and what I really wanted was a way to do webcam on a prim but it would ask for permission. Im just happy they working on it and hopefully improve it.

 

Also here is a simple example of a game i wanted to test out but it didnt work 

 


 This html5 game works in the Valhalla internal web browser just fine, but keyboard input is pretty broken when playing on a MOAP.

http://www.mikanse.com/PacMan/pacman.html

I filed a JIRA issue for that & made a note about your broken game in the comments.

https://jira.secondlife.com/browse/BUG-10487

Share this post


Link to post
Share on other sites
Baloo Uriza    51


Linden Lab wrote:

Often the most resource-intensive part of rendering a scene in Second Life is the avatars around you. The Viewer has a measurement of how avatars are affecting your performance, and now we are putting the control over whether to render them in your hands!

Finally!  Seriously this is long overdue, given how many people can't golf-score a build they're wearing (or blame the recipient).

 

 

Share this post


Link to post
Share on other sites
Whirly Fizzle    1,039

What URL are you trying to view on the MOAP?

Do you have media enabled in Preferences -> Sound & media?

Can you see the contents of Profiles, Search (World -> Search),  the avatar chooser (Me -> Choose an avatar) & the Destination Guide (World -> Destination Guide) or are those windows just blank?

Share this post


Link to post
Share on other sites
Whirly Fizzle    1,039


Tech Robonaught wrote:

llcflib_host.exe arror also coming up when I start the viewer.  Do I need to install Chrome to the system prior to running the viewer?  (Shouldnt have to) ....

 

 

I'm not seeing that error.

http://shoutcast.flashradio.info/#/60s/32933/ loads for me on Valhalla but I get no sound when pressing play in the center. It should play the radio station as it does in an external web browser. I have working sound for other media I've tried on Valhalla though. No sound when using either the internal web browser or a MOAP on Valhalla for that URL.

The rest of the web pages UI seems to function as expected when clicking on both the internal web browser and on a MOAP.



 

When running Valhalla I have 10 llceflib_host.exe processes running in Task manager. Plus the usual 5 slplugin.exe.

 

Hmm, is 10 normal?

 

llceflib_host.exe is located in I:\Program Files\SecondLifeProjectValhalla\llplugin.

 

Do you have that file in the llplugin folder in the Valhalla viewer install folder?

I wonder if your antivirus software may be blocking llceflib_host.exe running in the same way people often get media plugin webkit error messages when their antivirus blocks slplugin from running?

Or maybe when slplugin itself is blocked on a CEF viewer, the error message given is for llceflib_host.exe

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this