Jump to content

Magellan's Grid Scavenger Hunt: Stuck [SOLVED]


KeeperS Karu
 Share

You are about to reply to a thread that has been inactive for 2547 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Heyla, everyone!

 

So, I wanted to tour the different adventure and puzzle games in SL, a few months back, and I had come across Magellan's Grid Scavenger Hunt (http://secondlife.com/destination/magellans-grid-scavenger-hunt). I was doing pretty well in it, until I arrived at the Theme Park. For the life of me, I can't figure out where that mind mangler is! I've gotten to the underwater part, and the narrator keeps telling me I'm right there, but I don't see anything, at all. Does anyone have at least a hint as to where I'm supposed to go?

Thanks for the help!

KeeperS Karu

 

PS--

I HAVE found the Prim of Life. Just not the Mind Mangler, which is supposed to be my main objective.

 

PPS--

For those who are also stuck at the Pyri Peaks portion of the hunt and are at their wits' end, I will leave a few tips. I'll type them out in white, so those who don't even want hints don't have to see it:

1. The first time I did this, the monocole told me that the mangler was right there. What I didn't realize, at the time, was that it had spawned behind me. I was so focused, for a change, on what was in front of me that I didn't even notice, and I either TPed out, in frustration, or turned around and got caught by one of their many traps, or I was just searching, so long, in front of me, that it eventually disappeared. I don't recall which. So, the thing to remember is that, if the monocole sends you this message, and you don't see it, after a few seconds, rotate around, as it might have appeared behind you. If, after a minute or so, it's still not there, but it insists that the mangler is right there, it's possible it's either a glitch or it only stays in existence, for a certain length of time. Either way, you may need to restart that mission by either teleporting out of the region, then back to the start point, or, well, dying and being automatically ported away, then going back to the start point. Dying might be the better way to get it to restart the mission. I haven't tested that idea, though.

 

2. When I finally found the mangler, there was an error in sending me the end quest reward. I WANTED that prize, so I redid the mission, again (you have to click on the mission title at the home base, to do so), and I discovered that there are at least two different spawn points for the mangler, as the second time around, it was not where I had originally found it. So that is working as intended, if someone tells you where it is, but when you go there, it isn't there. There could be other spawn points for it, but I haven't tested it.

 

I hope that helps, without actually spoiling the hunt, for you!

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2547 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...