Jump to content
Sign in to follow this  
Pussycat Catnap

OSX 10.11 - El Capitan

Recommended Posts

The new version of OSX seems to have shown up this weekend. Noticed it by random chance (I had no idea it was inwork).

I upgraded one of my two Macs (need to the other one untouched for a conference coming up). My older 2011 iMac is now doing BETTER in SL than my new 2013 Macbook Pro.

Before the update my iMac was sluggish, and I had to use lesser preferences to get things to feel natural. Now its about 2-5 fps above the MacBook. The quality of my 2011 iMac is notably BELOW my 2013 MacBook Pro. The iMac was the entry level Mac, and the MacBook was the best Mac on the market in late 2013 - priced about 3x the cost of the iMac.

- So, to see the old machine jump up in performance this much is astounding.

 

And I was able to enter the upload image box without it crashing - something I've been unable to do on my Macs for over a year now... (the "fix" on the firestorm blog did NOT work for me, or did in 2014, but stopped working in January). hoping that stays...

 

This new OS had as one of its features, some changes meant to make older Macs perform better than OSX 10.10 had left them...

So if you're on an older Mac, this upgrade might be a good one to get to regain some lost performance. Especially if you have a graphics card that has been "left behind" by the last two OSX versions.

- If we believe Apple's hype that is. To new to be sure, the above are my impressions with about 10 minutes on it...

Curious to see impressions from other people. I saw the thread about "space navigator" mice not liking the new cheese... so there is one downside, but that's a kind of mouse I didn't even know existed before just now. So this will hopefully be an improvement for most of us.

 Unless something drastic happens in testing 10.11 on my old machine, I am seriously looking forward to putting the upgrade on the MacBook as well.

 

Edit: My old machine just claimed I was getting 84 FPS in an event I TP'd an alt to, which dropped to 30 once I started running around. That's better than it got even back when it was a new machine.

Share this post


Link to post
Share on other sites

I had some different issues.

it seems when every i upgrade my Macbook Pro to anything beyond mavricks 10.9.5 i cant keep SL running for more that about 10 minutes then it crashes. I've done clean loades to to avail. The only thing that fixes it is rolling back to 10.9.5.

have the same issue with FS as well. Both SL and FS on the latest Rev's..

Any help would be wonderful.

its pretty anoying i have to stay on an older platform to make it work.

when i see others are working i dont get it..

thanks

Ziggy

Share this post


Link to post
Share on other sites

I just logged in for a moment and find that my Space Navigator works as always. I'm not in-world much, but I haven't encountered any problems with El Capitan so far. My frame rates don't seem much different than before. Outside of SL, I'm quite happy with the new OS, which has fixed a few small issues I've had with networking and spinning beach balls.

ETA: It appears that my Space Navigator works because I'm running ancient drivers. The newest drivers are claimed not to work at all.

Share this post


Link to post
Share on other sites

Delayed crashing sounds suspiciously like a graphics heating issue, ZigRay. Try dropping to a lower graphics setting and reign in your draw distance. SL is prone to crashing when the GPU is overworked. MacOS will throttle the GPU clock to preserve battery life and reduce heating. At some point, the burden of running SL will cause the GPU to be throttled back to the point that SL crashes.

I imagine it's possible that improvements in the OS allow your graphics card to do more work than it could before, increasing your frame rate, but possibly at the expense of increased power draw. If, prior to crashing, your Macbook Pro was getting higher frame rates than before, you could be experiencing this sort of tradeoff. Dialing back your settings a little might allow you to keep those higher frame rates (again, if you have them).

Share this post


Link to post
Share on other sites

Same here. My MacBook Pro on El Capitan can't run SL for more than 5 minutes. I'm thinking I have to accept that secondlife and mac is for ever incompatible. Alas. RL here I come. (unless miracles happen!)

Share this post


Link to post
Share on other sites

There is a general issue running any viewer based on the Linden Lab code on OS X 10.11 which I have reported to and that has been accepted for possible resolution by Apple Engineering. 

In the meantime, downloading NVIDIA's web driver will resolve the issue for most users, although at some loss of performance over using the Apple driver. 

Turning off Shadows will possibly resolve the issue even for the Apple driver. 

More info and link to the driver download here

Share this post


Link to post
Share on other sites


DrJ Darkfold wrote:

I'm have the same problem on a fairly new Macbook Pro running I7 processors - haven't tried the LL viewer but Firestrom is definitely a problem

It is not the MBP that is the problem, but the viewer code. All viewers – which all use the same render code (Cool, Singularity, FS, Kokua, SL, Alchemy) crash with the same error on OS X 10.11.  

Share this post


Link to post
Share on other sites

There is a fresh build of the Mac version of Kokua that does not restart the GPU as all other viewers does on my test machines when running on OS X 10.11.

This version has been completely rebuilt with Xcode 7.1.1 

It would be great of you could download the new build from https://bitbucket.org/dayturn/kokua-mac/downloads and see if you get the same result.

Share this post


Link to post
Share on other sites

I'm on a Macbook Pro Retina 2012

I tried this new build of Kokua - was trying not to crash at the 'new stuff' opening at Kustom9 store where a lot of people are at - using the official SL viewer I crash after about 2 min. just being near the store - with Kokua I can get close to the store, zoom in with my viewer and browse inside for about 10 min. and then I crash. 

I find it a bit silly that I can't be in a crowd - that sl is that much weaker on a mac - why is it ?!?!

I have my draw distance set to the lowest possible setting but I've tried messing about with the graphic settings and that doesn't seem to change the fact that if I'm around 8 people or more I have to keep my view focused on the grass or a wall so I don't crash in the first 20 minutes. But if I'm with one person at Botanical gardens I can be on sl for as long as I like ?!?!

Share this post


Link to post
Share on other sites

I am running a late 2013 desk top and after i updated to capitan i kept crashing after about 5-10 mins in SL.. today i tried the nividia web driver you posted a link for and i seem to be able to stay in SL now... my movements become a little jerky and not as smooth as before but it was better than crashing... I then went back to the osx driver and downloaded the test Kokua build and i have been trying it... No crashes yet and it seems like a good build i think i will stick with this combo.. osx driver and Kokua... thanks for the help..

Share this post


Link to post
Share on other sites


Arena Jashan wrote:

I can be on sl for as long as I like ?!?!

We'll see if it gets sorted out in 10.11.2. Apple is working on the graphics drivers in the current 10.11.2 beta, and Linden Lab may also update their code to remove some very old stuff that could cause the crash. 

Share this post


Link to post
Share on other sites

I'm having similar problems to other contributors. I'm using a late 2012 iMac. 27 with the standard specs. SL worked fine on all versions up to and including Yosemite. The minute I upgraded I ran into this crash problem. I can run SL viewer for maybe 20 mins. FS loads but then crashes immediately. I tried most of the suggestions made here but none of them have worked.

Hopefully LL and Apple can get together and fix the problem soon. Meanwhile would reverting to an earlier version of OS be feasible. Or am I just going to have to dig out my old windows laptop?

 

I really look forward to any update on progress with this problem

 

Thanks

Cass

Share this post


Link to post
Share on other sites


cassandra Ushimawa wrote:

I'm having similar problems to other contributors. I'm using a late 2012 iMac. 27 with the standard specs. SL worked fine on all versions up to and including Yosemite. The minute I upgraded I ran into this crash problem. I can run SL viewer for maybe 20 mins. FS loads but then crashes immediately. I tried most of the suggestions made here but none of them have worked.

Hopefully LL and Apple can get together and fix the problem soon. Meanwhile would reverting to an earlier version of OS be feasible. Or am I just going to have to dig out my old windows laptop?

 

I really look forward to any update on progress with this problem

 

Thanks

Cass

The problem with El Capitan mostly seems to be hitting Macs with Nvidia video systems. One thing that seems to be helping people is to install the Nvidia "web drivers" for Macs.

Share this post


Link to post
Share on other sites

To me, it looks like the SL viewer starts using too much resourses for audio causing the app to lose a heartbeat connection (if one exists in SL).  OQE supports as I can only go to blarney stone for 2 mins before the beachball of death.  I last for about 5 mins in some of the Gov's property (Murray, etc).  My syslog is below if it helps.

 

1/25/16 11:49:29.649 PM com.apple.photomoments[469]: Detected nil DataManager, so will abort analyzer: (0x7fa14d100560) mode: Idle, error state: None, analyzing all moments: NO, last GEO provider id: 7618, last GEO version file fetch date: 2016-01-24 23:06:40 +0000
pending GEO request count: 0, active GEO request count: 0
processing Moments count: 0, has mega-moments to process: 0, years to process: 0
1/25/16 11:49:29.649 PM com.apple.photomoments[469]: GEO: Moment Analysis: Network error requiring immediate abort encountered, next attempt allowed after 0.000000 seconds
1/25/16 11:49:33.679 PM com.apple.SecurityServer[85]: Session 100005 created
1/25/16 11:49:40.000 PM kernel[0]: AMDRadeonX3000_AMDAccelDevice: IOUserClient outputCount count mismatch
1/25/16 11:49:40.383 PM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:40.384 PM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:40.384 PM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:40.392 PM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:40.392 PM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:40.393 PM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:40.394 PM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:40.394 PM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:40.395 PM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:40.428 PM appleeventsd[57]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:40.428 PM appleeventsd[57]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:40.428 PM appleeventsd[57]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:40.000 PM kernel[0]: AMDRadeonX3000_AMDAccelDevice: IOUserClient outputCount count mismatch
1/25/16 11:49:40.000 PM kernel[0]: AMDRadeonX3000_AMDAccelDevice: IOUserClient outputCount count mismatch
1/25/16 11:49:40.000 PM kernel[0]: AMDRadeonX3000_AMDAccelDevice: IOUserClient outputCount count mismatch
1/25/16 11:49:40.000 PM kernel[0]: AMDRadeonX3000_AMDAccelDevice: IOUserClient outputCount count mismatch
1/25/16 11:49:40.000 PM kernel[0]: AMDRadeonX3000_AMDAccelDevice: IOUserClient outputCount count mismatch
1/25/16 11:49:42.000 PM kernel[0]: AMDRadeonX3000_AMDAccelDevice: IOUserClient outputCount count mismatch
1/25/16 11:49:43.314 PM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:43.322 PM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:43.323 PM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:43.349 PM appleeventsd[57]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:43.000 PM kernel[0]: AMDRadeonX3000_AMDAccelDevice: IOUserClient outputCount count mismatch
1/25/16 11:49:45.428 PM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:45.428 PM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:45.431 PM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
1/25/16 11:49:45.465 PM apsd[82]: Failed to send activation record to service com.apple.ManagedClient.enroll
1/25/16 11:49:48.115 PM SLVoice[480]: 23:49:48.114 WARNING: 140: This application, or a library it uses, is using the deprecated Carbon Component Manager for hosting Audio Units. Support for this will be removed in a future release. Also, this makes the host incompatible with version 3 audio units. Please transition to the API's in AudioComponent.h.
1/25/16 11:49:48.347 PM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
1/25/16 11:50:33.705 PM mds[67]: (DiskStore.Normal:1705) Starting health check...
1/25/16 11:51:11.000 PM kernel[0]: process Second Life[437] thread 5127 caught burning CPU!; EXC_RESOURCE supressed due to audio playback
1/25/16 11:51:41.977 PM mds[67]: (Volume.Normal:2464) volume:0x7fa775807000 ********** Bootstrapped Creating a default store:0 SpotLoc:(null) SpotVerLoc:(null) occlude:0 /Volumes/firmwaresyncd.6DW1uL
1/25/16 11:51:42.615 PM deleted[324]: normalizeUserMountpoint:736 volRoot failed for /Volumes/firmwaresyncd.6DW1uL
1/25/16 11:51:42.616 PM deleted[324]: _validateVolume:758 unable to normalize volume: "/Volumes/firmwaresyncd.6DW1uL", vol: (null)
1/25/16 11:53:08.000 PM kernel[0]: process SLVoice[480] caught causing excessive wakeups. EXC_RESOURCE supressed due to audio playback
1/25/16 11:54:14.000 PM kernel[0]: ignored is_io_service_close(0x100000444,IOHIDParamUserClient)
1/25/16 11:54:54.144 PM Console[530]: Failed to connect (_consoleX) outlet from (NSApplication) to (ConsoleX): missing setter or instance variable

Share this post


Link to post
Share on other sites


Ynot Zehetbauer wrote:

I am seeing reverse issues.  SL view works fine on a standard macbook air but won't run for more than 5 mins on a more provisioned imac  (16 GB Ram, 3.4 CPU)

Not a revere problem. As said before in the thread, machines with only Intel integrated graphcis are not affected. Machines witn NVIDIA graphics processors such as the iMac will crash in high mesh content scenes. 

Share this post


Link to post
Share on other sites

There is a sporadic issue with the audio thread burning the CPU. In most cases the duration is short enough for OS X not to kill the application, but in some cases it last long enough that it gets terminated. 

The fix would be to re-write the viewer to use the built in OS X audio frameworks and not the opensource solution currently in use. 

Share this post


Link to post
Share on other sites

ONE SOLUTION: For what this is worth, I have disovered a solution which prevents frequent crashing with Mac OS 10.11.3 ("El Capitan"). Up until this upgrade, my system ran smoothly with no issues, with all graphics set to max. With the El Capitan upgrade, I was no longer able to use SL. Here is what I did to fix it:

1. Install the "NVIDIA GeForce GTX 675MX 1024 MB" driver, and restart.

2. Clear SL Viewer cache, turn all graphic settings to their lowest settings.

3. Enable "OpenGL Vertex Buffer Objects" and "Texture Compression" in Prefs> Graphics> Hardware.

4. Slowly experiment with increased graphics settings, until you reach a stable state.

I hope this helps some of you Mac users out there.

This has been a public service announcement.

Carry on!

- mondaybeam.com

Share this post


Link to post
Share on other sites

Thanks, but Mesh kills the Nvidia 675MX even at the completely lowest settings.

This is probably due to very old Apple drivers. The Nvidia "web drivers" are even slower.

With mesh clothing, and now mesh bodies and buildings and etc, the 675 just can't keep up.

 

And the reality is, each release of the Viewers is 10-20% slower, regardless of the amount of mesh around. When Firestorm blocks older viewers, SL becomes unusable.

 

I was told my iMac was obsolete (quite rudely) and to buy a new one (right, old age, limited income, can't afford a new Mac every year or two ), even though it's hugely capable of everything I do, EXCEPT SL.

 

 

 

Share this post


Link to post
Share on other sites

Do me a favor and try the lastest build of the Kokua viewer 

It will crash on grapics, but you should be able to get to med - high settings with your card. In the Hardware tab, make sure you set the texture memory to max 75% of your graphcis card memory.

This build should be significantly faster than FS (which is not good at all.)

Share this post


Link to post
Share on other sites

MacBook Pro's with Intel graphics or AMD graphics cannot install the NVIDIA driver. So you have to stick with it till Linden Lab has fixed it I am afraid. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...