Jump to content
  • 0
Sign in to follow this  
Kathya Szczepanski

How do u activate SHADOWS in Second Life 2.5.2 (223426)

Question

15 answers to this question

Recommended Posts

  • 0

Edited as I missed a step...ok now.

1. Press CTRL+ALT+D to activate Advanced Menu.

2. Select Show Develop Menu

or: just press CTRL+ALT+Q to open Develop Menu.

3. Set your Graphics slider to Ultra. Lighting & Shadows will not work in High, only in Ultra.

4. In Develop Menu, select Rendering and activate Framebuffer Objects.

5. In Develop Menu, select Rendering and activate Lighting and Shadows.

6. In Develop Menu, activate Shadows from Sun/Moon Projectors.

You now should be able to see Shadows if your graphics card supports it but remember this option decimates FPS. Note also anti-aliasing does not work with Lighting & Shadows activated.

 

  • Like 5

Share this post


Link to post
Share on other sites
  • 0

Thanks leliel. Kudos don't bother me at all. :) I suspect the responders above are using Snowstorm but those options are of course not yet activated in the main official viewer 2.5.2.223426 Graphics menu as you are aware. I hope LL make it clear in Graphics > Advanced when they do find their way into the main viewer that Ultra must be activated and also Framebuffer Objects in the Develop Menu for Lighting & Shadows to work (or automatically activate Framebuffer Objects if Lighting and Shadows is ticked).

Share this post


Link to post
Share on other sites
  • 0

Correct. Not on the official viewer but have been in Kirstens viewer for a few versions as well as the development viewers. Unless you already know, it's really not obvious that Framebuffer Objects must be turned on for Lighting and Shadows to work and that Ultra must be selected so I expect we'll get a number of questions here once this option appears in the main viewer. For many computer systems, Lighting and Shadows will simply not be viable for while it creates gorgeous views and wonderful photos, it greatly reduces frame rates.

Share this post


Link to post
Share on other sites
  • 0

You don't need Ultra enabled to turn on Lighting and Shadows, just Hardware skinning. FBO is automatically enabled when selecting Lighting and Shadows (on the mesh viewer). You can actually disable everything but Basic Shaders and Hardware skinning with Lighting and Shadows still enabled. Altho last I checked the Bump mapping and Shiny option didn't work with it enabled, the Local Lights option probably doesn't either. Kind of pointless tho, if your GPU is fast enough for shadows there's no reason to disable Atmospheric shaders or Water Reflections.

Share this post


Link to post
Share on other sites
  • 0

Yes, my error, FBO is automatically enabled on selecting Lighting and Shadows. Strangely, although I believe Lighting & Shadows should work on High in Kirstens according to a tutorial I found this morning it only works in Ultra for me. No Shadows on HIgh. Maybe I need to update my graphics driver again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...