Jump to content

Uploading Physics causes error?


maeglutz
 Share

You are about to reply to a thread that has been inactive for 2695 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

"If the mesh upload error reporter could also do this. That would be good."

That's the truth! There are just too many things that might cause this error. Meanwhile, the most effective way of getting answers here is probably to give us access to the physics mesh dae file, say whether you clicked "Analyze", and tell us all the parameters if you did. Also, what the numbers at the bottom of the physics tab were (before and/or after "Analyze"), and exactly at what point the error occurred (immediate, calculate button, or upload button). Pictures of the physics mesh might help, but it's hard to know at this point.

Link to comment
Share on other sites

Oh you of little faith.

The Lindens have not given up on improving the error messages. It just takes initiative, time and the occasional poke with a stick.

An example for you that doubt:

If I remember correctly Non Analyzed Physics meshes with tiny triangles or overlapping vertices used to just give a Mav- something- or-other error.

Improvement 1: A year or so ago these thin triangles in the Physics mesh were indicated in the uploader preview window by thick black lines with  little black squares at each end.

Improvement 2: A couple of weeks ago I had a physics mesh with some overlapping vertices in it and ..................... see the image below.



 

       ".... The physics shape contains triangles that are too small. Try simplifying the physics model.

 

A error message that tells you in plain english what is causing the error, a second message suggesting a way of fixing it and a visual indication of exactly where in the mesh the error is occuring.

Well done that Linden. Well done that Linden employee who realised that if s/he invested 60 mins of their time in improving that error message they could be saving hundreds of people many hours of frustration later on. A care bear for that Linden. Thank you.

"Mav" is the Uploader ? I used to think it had something to do with materials, so thats yet another improvement :)

Edited yet again........ Could MAV stand for Mesh Asset Validator ?

Link to comment
Share on other sites

Hi maeglutz

I think I can see two errors in your Physics mesh.

1: the physics mesh is smaller than the visual (high LOD mesh) This is probably because the Visual mesh is made up of several mesh Objects and your Physics mesh is only one mesh object ?  Each Visual mesh Object has to have its own Physics mesh.

If your building is made up of 3 separate mesh objects (Object1 , Object2, Object3) then each of those parts needs a corresponding Physics mesh, (Object1 Phys, Object2 Phys, Object3 phys)

If you are using Blender, in the Collada.dae export window, Export Collada Menu, (the panel on the left hand side), at the the very bottom of the menu check the Sort by Object name checkbox.

The visual and physics mesh will be sorted alpa-numerically so that the correct physics mesh gets used with the appropriate visual mesh object.

  ( If the building is only one mesh object then perhaps check that both Visual mesh and Physics mesh have their X Y and Z scale set at 1.000,  If not select object and Object > Apply > Scale.  (Ctrl + A   Scale)

2: In my post above I mentioned the error of small triangles in the Non Analyzed Physics mesh , Indicated by thick black lines ending in black squares............... i can see some of those in the preview window.

Link to comment
Share on other sites

A bit more that might be useful after you have solved the error from Aquila's answer - This is a triangle-based shape (no "Analyze"), which is appropriate for this building. However, the triangle count is 254 and I can only see nine walls. I can see enough diagonals to see that the four walls with doors have 9 triangles on each side. So that's 18x4 = 72 triangles. Then you seem to have seven walls without doors, which accounts for another 4x7 = 28 triangles. That's 100 so far. The edges of these walls, if I have seen them correctly, would add 144 triangles, giving us 244 in all. The remaining 10 could be in the floor I can't see and/or in the offending triangles Aquila pointed out. These numbers lead me to believe you left the narrow edges of the walls in your physics mesh. I so, these narrow triangles will give you an excessive physics weight, even if you get rid of the error-causing ones. So you should delete all the narrow edge faces. They don't contribute to the collision behaviour of the walls anyway. You could also reduce the triangles per side for the door walls from 9 to 5, by using a two-segment "curve" instead of four. You could replace the ctwo adjacent walls at each end with one. If you are prepared to accept a little bit less accurate collisions, you could use just one plane per wall instead of having both sides.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2695 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...