Jump to content
Sign in to follow this  
Teflonhotpocket

Prejump AO timing

Recommended Posts

What sort of specs does the prejump animation require? It seems to lock up for a split second between the pre jump and jump animations, just wondering if there is specific settings, or how long the animation needs to be in order to make it flow smoothly.

Share this post


Link to post
Share on other sites

The amount of time an avatar spends in pre-jumping depends on how long it's prejumping animation is set for. When the prejumping animation is over, the avatar will automatically continue into the jumping animation.

If you replace an avatar's prejumping with llSetAnimationOverride, it must be an animation that ends on it's own. If the animation loops endlessly, you'll get stuck in pre-jumping and never actually jump.

I haven't tested if there are upper or lower bounds, but so long as the animation is <2.0 seconds, it should automatically move into the jumping animation when it's over, without needing to time it.

Share this post


Link to post
Share on other sites


It's a short none looped animation, I've tried adjusting the length, the frame rate, the easing, I've tried BVH, ANIM. No matter what I adjust or mess with it always glitches out and freezes up between the pre jump and jump, I tested the landing, and its the same with that as well. It plays the prejump, pauses (and goes to the default animation) for a second, then proceeds onto the jump animation. During the landing, it goes smoothly from the jump to the land, at the end of the landing animation it does the same thing in that it pause/glitches. It's starting to drive me insane at this point because I've exhausted all I can think to change, you are the first person for days now to even respond after posting here, asking in various chat groups, asking random people I know who do animations.

It's obviously something on my end that I'm doing wrong, it's probably something obvious I'm just not seeing, and I'm goin nuts because this one thing is completely holding up a large project.

Share this post


Link to post
Share on other sites

Hi there, congates on experiencing the mess LL made with its system animation priorities when they updated their system anims :).  I prefure to use the standard sl pre jump and landing as the main base of those animations...and just change arms legs slightly...as the transition from prejump to your animated jump is smooth this way.  If you want to continue with what your doing..then maybe set your pre and landing anims to run for 2-3 seconds and make them -1 priority to your jump.

Good luck :).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...