Jump to content
Sign in to follow this  
adamBRJ

Making a mesh Frame work ...

Recommended Posts

hello all.

 

 i've read this https://gyazo.com/cde601688d3014d80da7ab5413f79599 from top to bottom but i still dont get it !! i know my way around blender pretty well i think but i think i get lost in this one !!

 

anytime i try to make a mesh frame .. the face where i drop my picture  still doesnt show the  picture i drop in it properly its always half and stuff ... can someone explain this to me one more time ? :( 

Share this post


Link to post
Share on other sites

Here is a simple frame with two materials. The lighter is the picture area. Look directly down in the frame (Num pad 7 if it's horizontal, as here). Select just the picture face and then press U key and  select "Project from View (bounds)" from the options. You will get the UV map of that face as shown at the top, filling the whole UV space exactly. Now a texture dropped on it inworld will also exactly fill that face. The mapping of the rest of this frame is superimposed in the lower picure after selecting everything. The details of that don't matter for your question, but note that there is only one UV map because SL will only ever use one. The Mappings of different materials can overlap like this.



  • Like 1

Share this post


Link to post
Share on other sites

Simply put the part where you put the photo needs to be a separate MATERIAL. The frame would be another (or maybe two or three materials --  whatever you choose).

 

Here are my beginner blend tips. https://plus.google.com/100190052320604204973/posts/a8DDxZXB5Eh

 

There is a photo frame in the list. I am guessing that SHOULD solve your problem. Here's hoping.

https://plus.google.com/100190052320604204973/posts/Z8BgTGgxXyS

 

Note that I do not do mine AT ALL in the way Drongle does LOL.    So funny. Mine works very well though and might be easier for ya *wink*. HE however is king of the complicated stuff.

 

These are WRITTEN tutorials with photos. Not video. Note there are MANY PHOTOS at the bottom of that post.

 

 

Good luck!

 

Share this post


Link to post
Share on other sites

"Note that I do not do mine AT ALL in the way Drongle does"

I don't know why you say that. For the picture-bearing face we both used project from view (bounds). That's the important  thing.

I did mapped the frame and back in one go using default unwrap, which is quicker, but requires knowing how to make and use seams. My frame is a bit  more complicated because the woodgrain of the edges continues on the back, and the picture is inset, but those details don't really matter, I think. We both used face inset to make the frame (although there are plenty of alternatives).

Share this post


Link to post
Share on other sites

I  don't know what to say Drongle but I looked and read your post and honestly had NO IDEA what you were doing - LOL. It has been a long day. I got very confused over the UV mapping photo. That was likely it.

I KNOW you are WAY smarter than I am. But I taught beginning computer classes for about 20 years so perhaps I look at things in a more simplistic way because of that. Even after almost four years of Blender there are things that you post that I have NO CLUE what you are talking about.

 

I am guessing that you are absolutely correct because when I DO understand you, you are. But sometimes having so much knowledge in ones head makes it difficult to communicate with those with little.

 

That was in NO WAY a disparaging remark. I have the greatest respect for you and your talents. I just know that even now I sometimes have no idea what you are trying to say *wink*.  Hopefully between the two of us, they will get the idea. Sometimes it takes several directions to get to the center of the problem.

:D.

Share this post


Link to post
Share on other sites

oh ? for me i did understand what he said  ( HOPEFULLY lol ) and i uploaded my DAE even tho with no AO map just to test if the picture would show fully and it did .. its flipped but that can be fixed i'll just flip it in the uv'ing .. but i baked the  AO map ( with overlapping faces ) and just like i expected the AO map  ... wont do it  



 

everything worked fine the pic is fully showen now still have AO map issue .. ( overl apping faces)

 

Share this post


Link to post
Share on other sites

Hi :)

Baking out only an AO texture for the picture frame........

Once you have created your picture frame mesh, assigned the two materials (mat_1= Frame, mat_2= picture) and have it all UV unwrapped :

1: In edit mode make sure you have the mesh deselected.

2: In the UV Editor create a new image and name it Frame AO (for example).

3: In the 3D Editor select only the part of the mesh that has had the “Frame” material assigned to it.

4: Return to the UV Editor and open the “Frame AO” image. (Opening the image with the frame part of the mesh selected has linked that part of the mesh to  this image).

5: Bake out the AO texture for the frame.





     That’s it you are done.

The part of the mesh that has been assigned the “Picture” material has not been baked because it was not assigned/linked to the “Frame AO” image before baking.

There are other ways of doing this , for example using the Node Editor but I think this is probably the easiest way to start with.

The complete AO texture will appear on the mesh in Blender but once you have uploaded and rezzed the picture frame inworld you need to edit the frame and check the “Select Face” option, select the face and give it your proper picture texture.



If for some reason the AO bake did include the picture part of the mesh what you have to do is disassociate/unlink the “Frame AO” image from that part of the mesh. To do this :

1: In the 3D Editor select only the picture part of the mesh.

2: Go to the UV Editor and hit the little “x” to the right of the field which shows the name of the active image.

3: Return to the 3D Editor, deselect the picture part and select only the Frame part. Check that the “Frame AO” image is active in the UV Editor then you can bake the AO texture as before.



  Edited to add : check out this forum thread for some tips on AO baking parameters in Blender

https://community.secondlife.com/t5/Mesh/Need-advice-buildings-in-blender/m-p/2368791#M24858

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...