Jump to content

Upgraded to Windows 10; now viewers are crashing


You are about to reply to a thread that has been inactive for 1966 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I use Cool VL Viewer, Singularity and the official LL viewer. All three of them are crashing horribly since I upgraded to Windows 10. I've updated all the drivers (nVidia GTX 460 SE2), I've got plenty of RAM (16GB) and everything seems to be running cool. Usually the error I get is a Kernel Exception 3 in Open GL although occiasionally it's some kind of TLD error 7 thingy. Generally, the SL LL standard viewer simply poofs while Singularity & Cool VL Viewer cause my system to generate the above error reports.

Is anyone else seeing this sort of behavior? Any suggestions? I'm thinking of trying a clean install of Windows 10.

Snick

Link to post
Share on other sites


Snickers Snook wrote: [...] I'm thinking of trying a clean install of Windows 10


Might as well. I have two computers which I recently upgraded, but only went as far as clean-installing in one of them; the other seemed to upgrade most smoothly, but afterward I’ve come to have with it the sensation of issues “swept under the rug” but still existent. Clean-installing may be annoyingly time-consuming, but at least you work with a smaller set of “I don’t even remember what other stuff I have installed that might be giving me trouble”.

Still, before trying that, do read this. It’s related to Firestorm, but probably good info for other viewers as well, especially considering it mentions explicitly your “error 7 thingy”.

Link to post
Share on other sites
exception 3 is caused by the GPU not going fast enough for the SL Graphics settings (or any other 3D program). Windows (any version) will timeout the GPU, when the GPU cant keep up with the CPU. and give this error
 
+
 
NVidia have released 3 versions of drivers now for Win10
 
355.60 (the latest)
353.62
353.30
 
can try rolling back thru them
 
+
 
have assumed that in NVidia Control Panel you have set :
 
1) Power Management Mode: Maximum Performance
2) Multi-display/mixed-GPU-acceleration: Single display performance
3) Vertical sync: On
 

also there is a weird trick that some people have reported that works for them on older cards
 
go to NVidia Control Panel: Configure Physx Settings: where by default is set to: Auto-select(recommended) and change to your GPU
 
what happens as reported is that more voltage is boosted to the GPU
 
is weird bc SL dont use Physx. yet some people have said that it helps. So can give it a go and see if it works for you
 
+
 
the only other option (other than roll back to Win7) is to reduce your SL graphics settings. Assume you dont want to get messing with your Windows Registry, or going low-level on the GPU itself boosting the voltage yourself
 
Link to post
Share on other sites

Interesting. Thanks for the info. I backed down to 353.62 and things are a bit more stable but I haven't tried returning to "High" graphics settings which is what I've always run at in the past. Another thread suggested running nVidia Inspector which I am now doing. It shows some interesting things -- most of which I have no clue about lol.

One thing it shows is that the default settings for Second Life (which apparently most SL viewers force permanently onto whatever graphics settings you may have) have:

Multi-display Performance Mode = on. -- I turned this to Single display

Power Management - Prefer max performance = on -- No Change

Vertical sync = Let 3D app handle -- I changed this to force on.

I'll let you know if these work.

Here is the related thread: https://community.secondlife.com/t5/Second-Life-Viewer/Second-Life-and-nvidia-drivers/td-p/2958144

Link to post
Share on other sites

i just thought of something else that may be affecting

it might be that you have begun crashing recently bc there is now some mesh thingy (which has a zillion poly/vertices) on/near your parcel, or where you go regular. Or somebody might be wearing it, or even something you wearing yourself that you got recently

extreme high poly/vertice on mesh objects, is the main cause (after shadows) for getting this exception 3. If your frame rate just suddenly dives then go into wireframe mode in the viewer and have a nosey at whats in your view

 

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

OK, a techie friend of mine suggested (similar to one of the posts above) that I muck with the voltage settings on my graphics card. So per his instructions, I installed MSI AfterBurner and upped the GPU core voltage slightly from like 950 to 960. Wow. No more crashes in Second Life with either Singularity or Cool VL Viewer (I haven't tried the official viewer).

After verifying the lack of crashes, I made a slight change to the fan profile so it kicks in sooner as well -- just to be safe. I really have no idea what I'm doing lol.

In sharing this in the NCI group, one seemingly knowledgable person speculated that because Windows 10 uses a later version of DirectX (which is running all the time) and it places more demands on the GPU, that the voltage increase may have been the right fix. I have no idea. 

Anyway, it had nothing to do with the driver version or other stuff.

Link to post
Share on other sites
  • 2 months later...
You are about to reply to a thread that has been inactive for 1966 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...