Jump to content

Problem with rigged mesh avatar, deformed when worn.


Guest
 Share

You are about to reply to a thread that has been inactive for 2727 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Okay, I first started using Blender just a few days ago. I apparently picked it up quick, because I made a 3D dragon (no wings) and rigged it in the first day.

I decided I wanted to use it as an avatar in SL, and yes it is a full quadruped. So I got rid of my custom armature and downloaded an SL skeleton, and then conformed that to the dragon mesh in a way that worked as a quadruped. I used automatic weights, if that says anything bad. That fixed my issue with the uploader not recognizing the skin weights.

So my problem now is, as soon as I click the skin weights option in the uploader, the mesh gets deformed beyond recognition. It looks like a plate of spaghetti. :/ When worn in world, nothing changes. Even using AO's designed for quadrupeds doesn't fix a thing. Right now I only want it to look the way it should when worn, I'm not worried about animating it yet.

Where did I go wrong?

Here are my steps exactly, I believe. I think I might be missing a few key things but since I'm new to everything, I don't know any better.

-Sculpt 3D mesh, then use Decimate modifier to reduce the poly count to an acceptable range.

-Import SL skeleton, then stretch and rotate it to fit the mesh as a quadruped.

-Select mesh, and then armature, ctrl p: - Armature Deform, With Automatic Weights.

-At this point I test out all the bones in Pose mode, and they all affect the mesh how I'd like them to.

-Export-COLLADA

-Upload in SL, preview of the avatar looks completely fine, save for a slight rotation issue that makes it appear to be tilted a little upwards.

-Select Skin Weights, and the thing explodes into spaghetti. Looks the same way worn in world.

Now I can be pretty sure I didn't do something I should have. Can anyone tell me what I need to do? It seems like the whole mass of the mesh gets squashed onto the skeleton and deformed. The mesh is weight painted. I am at a loss here, tutorials seem to be all over the place and I've looked at at least 20 of them.

If Anyone could help me out I'd sure appreciate it, and I appreciate you even taking the time to read this.

And for reference, I am using Blender v2.75, the new one and I don't believe any of the SL addons work with it. I probably should have started with a biped for my first avatar rig but, I can't bring myself to scrap this project after the work I've put into it.

Thank you for your time! I'll owe you one if you manage to help me dig myself out of this mess!

 

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2727 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...