Jump to content

Need some help streaming music into SL.


You are about to reply to a thread that has been inactive for 2734 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hi everyone

I am currently trying to stream my spotify playlists into SL so my music can be played in my parcel.

I am using spotiamb, which is then pushing the stream to my locally installed DNAS Server 2.4.7 which is set as a relay to upload it to the outside world.

I have been able to access the DNAS server stream on both local and WAN IP's, and have even managed to get other people to connect and listen to the music via the wan IP. So far so good.

The problem is as soon as I input the same link into the SL browser, I get no music at all. If I input the link of the spotiamb stream, it does play, but this application only allows one listener at a time, which isn't ideal if I'm trying to have guests over.

I spoke with a DJ, and she suggested that I lower the KBPS down from 320KBPS to 160 or 128, but how do I do this in Shoutcast DNAS Server 2.4.7 ?

Link to comment
Share on other sites

when you host your stream yourself you need a very good upload from your ISP, and when streaming with 320 kbps it's full in no time with only a few listeners.

 

  • 1 MB = 1024 kb so that means if you stream at 128 kbps
  • 1 MB Upload connection = 8 Listeners
  • 5 MB Upload connection = 40 Listeners
  • 10 MB Upload connection = 80 Listeners

divide this number of listeners by 3 for 320 kbps ..... and add your own use of the uploadbandwith, ......  i think that doesn't keep a lot free space

I would recommend you go rent a streamserver inworld, it will save your machine. And keep in mind you can use your bandwith only once, when you also use SL it will also send and receive data over the same line.

When your machine doesnt support dual channel, you can't listen to your own ip.

 

Link to comment
Share on other sites

My connection is a 78 mbps down and 14 mbps up fibre connection.

I can listen to the stream absolutely fine when I browse to it in web browser with everything running (the DNAS server etc is on a laptop) and experience no loss in quality or buffering, but as soon as I put the stream info into SL is when I have the issue of just hearing silence.

Link to comment
Share on other sites


RobynVanNistelrooy wrote:

I've downloaded SC Transcoder, but have no clue how to configure it, can anyone suggest how to do so? I would be grateful for any help in getting this working.

http://lmgtfy.com/?q=configuring+sc+transcoder

 


RobynVanNistelrooy wrote:

I am currently trying to stream my spotify playlists into SL so my music can be played in my parcel.

Tell the RIAA I said hi.

 

Link to comment
Share on other sites


bigmoe Whitfield wrote:

very helpful, ~slow clap~  you can find other thigns to do right, instead of trolling, I'm pretty sure of it.   because I think you troll them, I troll you from now on, this could be fun.

I have no thigns at all, unfortunately, to do right, left or middling.

Alec - to wash my kilt sometimes, but then I can't do a fling with it

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2734 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...