Jump to content
Sign in to follow this  
Plato Novo

Mesh upload "dae parsing error" possible fix

Recommended Posts

Hello. I had an issue uploading a mesh file yesterday and I wanted to share the fix I discovered. This will not fix every "dae parsing error" issue, but it's a fix I wasn't able to find prior when looking through the SL forums and knowledge base. I'm on a MacBook Pro, and using Blender 2.73.

The file I was trying to upload was the  "version d" of a file that had previously uploaded fine, ("version d" had it's own LOD and physics files.) The original file folder was getting too cramped, so I created a new folder inside it for this version, and moved all the associated files for it into the new folder. The only differences between "version d" and the previous versions were some verticies had been moved around, and the UV map had been altered to reflect the changes. Once I finished "version d", I tried to upload it, to no avail. The viewer upload screen was telling me "dae parsing error" with the LOD3 version of the file. My secondlife.log listed the issue as "2015-07-31T14:24:58Z INFO: doLoadModel:  Error with dae - traditionally indicates a corrupt file." I knew the file likely wasn't corrupt.

I went back through the Blender file and checked all the verticies and texture seams. No issues there. I tried uploading an older version again, and that one worked fine. I then looked through all SL help section and tried the suggestions. I learned a few new things, but nothing was helping with my upload.

I gave up and decided to redo "version d" from the last working file. After an hour or so of more changes, the new one wasn't uploading either.

Finally, I tried moving "version d" to the folder above, where the still-working versions were located. This actually worked! The ONLY issue was the file was buried one level too deep in the folders. Extremely frustrating!

I've since been told by another SL user, they've had the same issue with the same fix before, so I wanted to put the info in a place where it might help someone else.

I was going to file a bug, but there was no "create new bug" button on the SL page. All I saw was "create new dashboard," and that didn't appear to be the right thing to do. My browser uses an ad blocker and some other script-watching apps, so it's possible the button was there, but not showing up. I used the link off this page: http://wiki.secondlife.com/wiki/Issue_tracker to go to this page: https://jira.secondlife.com/browse/BUG which was the page recommended, but not showing where to put the information. If anyone can help with that, and send me a link to the actual starting point of typing out new bug info, I'd be happy to move this there.

Share this post


Link to post
Share on other sites

If you log in on the jira page retrieved by your second link, you should see "+ Create Issue" at the right of the tab bar near the top, just before the search block. Before you use that though, are you sure you didn't have any relative external references in the collada file, such as those to to any textures included in the upload? Those could become invalid whenever you move the file, irrespective of the path nesting level.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...