Jump to content
Sign in to follow this  
Bitsy Buccaneer

Is there a way to keep UV islands in proportion to the mesh?

Recommended Posts

Hello kind people,

I've made a mesh in the shape of this ancient relief. The reference image is included because it will become the basis for the texture. It's a box with slightly beveled corners and edges pulled up/in.

Screen Shot 2015-06-12 at 14.28.55.png

Here's a wireframe in case it's helpful to see the edges and one attempt at seaming. In this case, there are three pieces - front, back and side(s). There's a wee seam across the width of the side(s) so it lays flat. It's tucked away at the bottom left.

BP - to see seams.png

I'd like the UV to look like this, with the sides and back scaled smaller underneath. Because it's all about the detail on the front face, I'd like that to be as large as possible - and in the correct proportion. The back and sides can be significantly smaller, but it will be much easier to texture them neatly if they are in proportion to each other.

BP - want this UV.png

What I get, regardless of how I seam it, is something like this. The long piece is the long but very narrow side(s) and the two squares are the front and back (which are separate islands, so it's not that I missed a seam).

BP - am getting things like this.png

Blender already has the correct proportions on the Mesh side. Is there a way to get it to stop changing them on the UV or do I have to fix the mistakes it's imposing on me by hand? Any tips on doing that accurately? I'm using Blender 2.7.

Many thanks.

Share this post


Link to post
Share on other sites

Go into Front, Side, or top view (NumBlock 1, 3, 7). Hit 5 for Ortho. Select the front face(s), U > Project from View. Scale and move the UVs into position. Repeat for the other sides of the object.

Although, it would only take a few seconds to move the UVs by hand into position, on such a simple object.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for replying. If I'm remembering correctly, Smart UV was the option which chopped it up (and disproportioned them) into even more equal sized squares. I tried playing with its settings, but couldn't find anything which, shall we say, dumbed it down. :-)

Share this post


Link to post
Share on other sites

Hi

In orthographic view go into a view that is looking straight on at the front of your mesh.

Select all the faces that make up the front of your mesh and then open the UV Unwrap menu and choose Project from View.

Repeat for the back view and then for the edges.

Then go to your UV Editor window and scale the UV islands so that the front UV unwrap is using as much UV space as possible without stretching in the Y axis then scale the back etc to fit the rest of the space.

 

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

To have things to the correct scale: Hit Ctl A to set Location and Rotation before Auto Unwrapping.

  • Like 2

Share this post


Link to post
Share on other sites

That's even better.

I knew I shouldn't reply to a Blender question, since I don't use it since 2.49b. :matte-motes-dead:

Share this post


Link to post
Share on other sites

Will Ctrl A keep things in place if I tweak them and need to unwrap again?

I got far enough along to want to improve the shape after seeing it with the texture on the beta grid. The uploader doesn't like something I did on the new version so I have some more questions.

1) Do I have to unwrap before every export if I'm just testing the shape?

2) Will Ctrl A (or another hidden trick) help keep things in place so I don't need to redo the UV?

3) Any advice on workflow for testing in SL, making adjustments in Blender and testing again?

4) Any advice on getting less texture distortion on beveled sides? Is this something I just have to accept if I use the orthographic Object Project method of unwrapping? Ideally, the finished result would be a smooth continuous surface over the corners and around the curves.

Share this post


Link to post
Share on other sites

Pamela has given the answer that will help in the future. The unwrap functions work on the geometry before Object-mode transformations are applied. So it's seeing the original cube. Applying rotatoin and scale resets the Object mode transformation and changes the geometry instead. There are other problems that arise with Object mode transformations So the best thing is to do as little editing of mesh as possible in Object mode, preferably none. When you do, always apply rotation and scale before going into edit mode. After applying, the default unwrap will give you islands with correct proportions. Then yoiu can just move, rotate ans scale them to get what you want, without changing the correct shape of the fromt face. If you keep the long thin unwrapped edges spanning right across the UV space (as I expect they do by default), then there will be no visible join if you use (a whole number of repeats of) a tileable texture.

Here's a default unwrap, with the seams you have, to which just move scale and rotates used to get the one on the right.. No scaling in just x or y, so that the shapes stay the same as they are in the geometry. The active face (dotted) is the front.

uwtab.png

ETA: inserted "of mesh" in response to Drew's correction below.

  • Like 1

Share this post


Link to post
Share on other sites

Also to unwrap just certain parts at a time, you can sometimes just select those parts then unwrap separately. You get a different result depending on type of unwrap.  Selecting a certain part can be difficult sometimes, tho, or you don't wind up with a good island, and Aquila's suggestion can be helpful with these at times.

  • Like 1

Share this post


Link to post
Share on other sites

You wrote: " do as little editing as possible in Object mode, preferably none."

 

Here are two instances I know of where you might actually want to transform your mesh in object mode without applying rotation/scale and or location:

 

In the first instance if the geometry you want to transform is at an off-axis angle:

 

1) like this:

prefOrient.png.png'

2) In object mode you can rotate the geometry temporarily so the vertices you wish to translate or scale align with an axis making it easier to transform.

RotObj.png

3) Switch to Edit mode and perform the Transform action.

 

Edit.png

 

4) Return to Object Mode, press Alt R, and your mesh snaps back to it's original orientation.

(You can, alternatively, set up a custom orientation for this kind of edit, but I find the above method very fast and convenient.)

 

The other instance for editing in Object mode (and there may be others I'm not familiar with)  is when setting up a lattice modifier.  The lattice is scaled in Object mode to conform to the volume of the mesh it will be deforming.  Any editing in edit mode will deform the mesh so the initial scaling is done in Object mode.  in this instance, as well,  you do not apply the Object mode scaling with CLT A.

 

 

 

Share this post


Link to post
Share on other sites

All the best rules have exceptions :matte-motes-smile: (although I think your first example can just as easily be done in edit mode if you take the trouble to read the angle while you rotate)

Share this post


Link to post
Share on other sites

Ah! Well I'm sure many people would prefer to take the trouble to read the rotation angle from the bottom left of the screen before the rotation numbers disappear when you left click to commit to the rotation, then keep that in memory or jot it down, perform the transform and then type the numbers back in to reverse the rotation. :smileyindifferent: And I alternatively created custom orientations for this sort of thing.  However after I learned the technique I described from a Blender (Modo?) user forum post, I've found it simply quicker to, again, just rotate in object mode, edit in edit mode, re-enter object mode and snap the rotation back with" Alt R".  (In any event "never" is so very final.)  Here's hoping someone new to modeling and Blender will benefit from the tip.

(And being told repeatedly never to edit in Object mode consistantly screwed me up using the lattice modifier which, again, requires initial editing in object mode but NO application of the  object transformation with CTL A which would completely screw it up.  So frustrating for a beginner trying to learn to use these tools.)

Share this post


Link to post
Share on other sites

Thanks to everyone who helped. It worked. :-) Even got it done the day before a hunt. Which was then cancelled. :-( Which means I can't invite you to saunter along to my shop at your convenience to pick up a copy as a thank you gift. Not that it would be difficult to arrange it by other means if you like.

Here are a couple of pictures so you can see what you contributed to. Thanks again.

Bacchic Musicians photo right side cropped.png

Bacchic Musicians photo ledge cropped.png

Share this post


Link to post
Share on other sites

I agree that the way you describe for reversible temporary rotation is very useful, especially for the majority who don't like numbers*. It remains the case that not applying rotation and scale is one of the most common sources of problems raised here, and avoiding object-mode editing is the easiest way to pre-empt them. So I will stand by that advice for beginners. As they learn more, they can take advantage of nice tips like yours.

Lattices are a different matter, and thanks for pointing that out. The advice is really intended only for editing mesh, not other kinds of objects, but I guess that was not explicit. I'll change it. I haven't used lattices enough to claim familiarity, but the Blender manual is now quite clear about this, which might avoid confusion in the future. I'm still not sure I fully understand the effects of object-mode lattice transformations after linking the lattice modifier though. Can you offer a simple description?

*Personally, I do prefer to work with the numbers, but I know I'm peculiar in that way.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...