Jump to content
Sign in to follow this  
Dictatorshop

Maya & Mudbox & multiple texture tiles on a single object

Recommended Posts

Hi All,   I appear to have gotten too fancy and have run into trouble, I hope someone out here knows what I am talking about - here goes.

 

I am using Maya & Mudbox (2015).  I have created a cave that is approximately 12x15x6m with one single 1024 texture it was horribly stretchy and my attempts to make the top of the cave multiple pieces was equally unsatisfactory.  So, I figured out how to make six UV tiles UV Faces u1v1-u3v2  for the top of my cave.  Everything is working wonderfully with the layered texture and six texture tiles, UNTIL I try to upload it to SL. On upload the six faces become a single face in sl, so using the various tiles simply doesnt work.  

I tried saving it as dae directly from Maya, and also saving as fbx and using the autodesk converter to turn it into dae, neither seems to work.  The only thing that DOES work is if I go in and reassign each texture face to a NEW lambert before I upload.  Unfortunately the texture faces are not all one piece and by trying to select them to reset them i keep moving the uvs and then i have horrible seams.

Is there some TRICK to getting a layered multitile mesh into SL without having to do all this hoop jumping?

 

Share this post


Link to post
Share on other sites

I am thinking that what would fix my problem easiest would be a mel script that could grab the face for each of the six uvs and assign a new blank lambert.  I have never done mel so I dont even know where to start.  Any mel pros who might be able to lend a hand?

Share this post


Link to post
Share on other sites

Hi

I don't use  Maya but the workflow has to be similar to Blender so i'm only mentioning this just in case its something you were not aware of ......... :)

You didn't mention how you created those 6 UV tiles or anything about assigning materials.

In Blender I would assign 6 different materials to the relevant faces and then UV unwrap each material one at a time.

So for your case the faces of the mesh for each or those UV tiles has to have thier own material assigned to them.

Select all the faces that make up the first UV tile and Assign them a material. (Lambert 1)

Select all the faces that make up the seconf UV tiles and assign them a second material. (Lambert 2)

Repeat for each UV tile.

For SL one mesh object can have a maximum of 8 materials.

I found this video tutorial on assigning materials to faces in Maya

You have to do the same thing as was done to the sphere in the video at 3:45 .

If this is what you were already doing ........ I would guess its a problem with the Collada exportor ?

If you knew all this already .....well no harm done :)

 

 

 

 

Share this post


Link to post
Share on other sites

It should be easy enough to select the faces within the the UV Editor, and assign a new material then in the viewport. Either by draging a selection box over each UV tile, or by selecting UV Shells (shift + left click).

Share this post


Link to post
Share on other sites

Thanks for your answers so far.  I know how to do the "usual" texture assigning but in order to get the maya -> mudbox integration I followed this tutorial http://www.digitaltutors.com/tutorial/688-Multi-Tile-Texture-Workflows#play-14430[/url]  which has you make a layered texture with the texture tiles assigned to it.  This appears to be how it needs to be set up to be able to pass it back and forth.  Unfortunately maya and mudbox then start using it all like it is one big tile not six separate ones.

 

I have the kludgey work around of going and selecting the UVs convert selection to faces and assign an empty lambert.  BUT that breaks my integration and then I cant re-edit in mudbox without having to go and do it all again.  I am just not that patient.  I am trying to figure out how to keep the mudbox integration for editing AND get my six texture faces exported.  

Any ideas?

Share this post


Link to post
Share on other sites


Dictatorshop wrote:

Ok totally off topic but how do i change my picture on my posts?  I am NOT a gorilla lol!

My Settings (on top of your screen) -> Avatars

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...