Jump to content
Sign in to follow this  
Phinneas Philgarlic

Baffling camera problem

You are about to reply to a thread that has been inactive for 1285 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

When I logged in this afternoon, everything was fine. Then suddenly I noticed I could not move my camera using CTRL+ALT+(arrow key) or CTRL+ALT+SHIFT+(arrow key) as I have been doing for years. My avatar is wearing no scripted attachments or active gestures. I use the built-in AO in Firestorm, which is my normal viewer.

I have done the following steps in order to troubleshoot this (not necessarily in this order, and I'm tired so this probably is not a complete list.)

  1. Relog
  2. Reboot computer/modem
  3. Reload viewer settings
  4. Clean install of Firestorm (all settings, login info, skins, cache, etc wiped)
  5. Swapped keyboards
  6. Installed keyboard checking utility to see if keypresses and combos were registering (they were)
  7. Installed another third party viewer to see if anything was different (it wasn't)
  8. Logged into SL from another computer to make sure it wasn't an SL problem. (the viewer on the other machine worked fine)
  9. Contacted Firestorm Support
  10. Disabled all OS keyboard shortcuts
  11. Logged in an alt (same problem)

#7 would seem to indicate that the problem is with my system. The puzzling thing is that the keys all work otherwise: the arrow keys move my avatar, CTRL+SHIFT+H teleports me home, CTRL+ALT+SHIFT+G results in the "Now leaving god mode, level 0" message and so on.

I am running Ubuntu 14.04, 64 bit. Though I have installed the 32-bit compatibility environment, I haven't been able to get the official SL viewer to run, so I haven't been able to test with that. I am pretty sure what my result would be, though. My keyboard works fine in games and other applications, and of course I am typing on it right now. 

If anyone can think of anything I haven't I would be grateful. I really, really don't want to have to use the camera controls.

 

 

Share this post


Link to post
Share on other sites

Iteresting just ALT+(arrow keys) has always worked for me. Of course since I have a mouse I mainly just use the hold ALT+(left click) then move my mouse to pan or zoom. 

Share this post


Link to post
Share on other sites

Yes, they have always worked for me as well. The mouse is a workaround, I suppose, but it doesn't allow for horizontal or vertical camera movement without changing the angle of the camera. It simply focuses on whatever you've pointed it at, then circles around it. With CTRL+ALT+SHIFT+up arrow, you can, for example, stand on the ground floor of a multi-storey building, and move your camera vertically through the floors above you without it being locked on any particular object. 

Share this post


Link to post
Share on other sites

Even though it started while you were using a viewer, this seems to me less a viewer problem and more as if the window manager has started gobbling up those specific key combos. You say you already tried "10. Disabled all OS keyboard shortcuts" but my theory is that you got one level of those but others are still falling into the evil clutches of the window manager. Especially if you're using Ubuntu's default "Unity" UI, this can be a stupefying labyrinth of bindings.

On the other hand, admittedly, I have no theory about what would suddenly make this happen.

There must be a more efficient way to find what any particular keyboard event triggers, but lacking that magic and assuming it's "stock" Ubuntu with Unity, one might search CompizConfig Settings Manager for any enabled key bindings that match CTRL+ALT+[sHIFT+]<arrow>.

[ETA: This from Ask Ubuntu on Stack Exchange may help.]

Share this post


Link to post
Share on other sites

I had the same problem. Turned out to be my graphics driver. It had some hotkeys to flip and rotate the screen. Even though they were disabled, they still captured the keys.

Had to change them and then disable again. Works great now.

 

Share this post


Link to post
Share on other sites

I realize this is an old thread but I'm having a similar issue. I recently reset my computer (Windows 10) and now I can no longer use ctrl-alt along with my arrow keys to zoom and rotate the camera. I'm a builder and I've been using these for years. Trying to build without it is like having one hand tied and I really to to correct it.

I use Firestorm but I tried it with the SL viewer with the same results, so it has to be a setting that was changed during the reset. I'm not real computer savvy but with a little help I can usually correct most things. I'm guessing that keyboard shortcuts have captured these keys, as someone mentioned earlier in the thread. My question is, how do I check the keyboard shortcuts and disable them to see if it will fix it? Tried a google search but couldn't find a way to disable or change any of them.

Share this post


Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 1285 days.

Please take a moment to consider if this thread is worth bumping.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...