Jump to content
Sign in to follow this  
Hieronimos Audeburgh

Strange UV-mapping problem upon upload / Black model

Recommended Posts

Hey all!

I'm running into a rather strange problem with a piece of furniture upon upload in SL. For some reason when I add the texture, the model turns almost completely black (with exception of a part of the handles on the drawers):

Snapshot_007.jpg

And this is how it looks like in Blender and should look like in SL:

Table.jpg

By now I've done quite a number of far more complex models for SL, but I never ran into this problem before. Anyone have any idea in what direction the solution may be?

Thanks! 

  • Thanks 1

Share this post


Link to post
Share on other sites

I'm not sure, but I guess it has something to do with the phong shading. Try to adjust that in your 3D program, by choosing a different degree for the phong shading. Or you could make a few breaks in the phong shading.

Share this post


Link to post
Share on other sites

Have you checked that all the faces use the same UV map? SL can't handle multiple UV mpas for the same object and unless you're careful Blender tend to apply separate UV maps to objects when they are joined in object mode.

Share this post


Link to post
Share on other sites

If you did make this by joining objects, ChinRey is surely right. Blender now combines UV maps by name, ending up with a map for every unique name in the objects before they were joined, and SL only imports one map. If any joined object doesn't have a UV map with one of the names, then in that map of the joined object, that object's vertices are all mapped to 0,0, so that it is entirely textured with only one pixel. If that is the map that gets uploaded, and that pixel is black, the the whole face will be black.

So what you have to do is make sure the UV maps you want to be used for each individual object are all given the same name before you join the objects. Then make sure the map with that name is selected, and check the "Only Active UV layer" option in the exporter (it should say "Selected" instead of "Active" - that will be corrected soon).

There have been a couple of recent threads about this, either here or in the texture forum.

Share this post


Link to post
Share on other sites

I should have mentioned in my first post the quick way to find out if multiple UV maps is the problem:

 

  1. Open the Blender file
  2. Click on the Obecjt Data icon (in the row of icons to the right of the screen - looks like a trianlge with dots in each corner)
  3. Look at the list of UV Maps - you may have to scroll down a little. There should only be one entry in that list. If there are several, there's your problem!
  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...