Jump to content
Sign in to follow this  
adamBRJ

Why am not getting the Shadows i want in my texture !

Recommended Posts

Hello i finally got the modeling part or building part on blender figured out that was the easy part ... now the texturing is giving me a hard time !! super super frustrating !! i'm sure people  have been through this before but  i thought i'd make a thread  out of it ! 

 

 

first of all here a picture to just see where am at ! Capture.PNG

as you can see or maybe tell thats only an ambient occlusion  bake which if you ask me look okay since i want to use black and grey for  it  BUT !!! whenever i apply my textures they just wont bake with the dark edges and shadows you see in the picture above :( 

Share this post


Link to post
Share on other sites

Not sure what you are trying to do. But usually you would want to do it like this.

Save out the ambient occlusion bake.
Open your color texture (called Diffuse map), and the AO bake in an image editor like Photoshop/Gimp.
Create a new layer on top of the diffuse layer and copy/paste the AO bake to it.
Set the AO bake layers blending mode to Multiply.
Adjust Opacity/Levels if needed.
Save out the image.

Share this post


Link to post
Share on other sites

...yes i understand how to do that ... but that will only serve as a " tint " for my mesh .. what i want to  know is how can i bake the textures  in blender and have the same  result ? .

 

 textures and shadows  " full rendered " :) 

Share this post


Link to post
Share on other sites

Try turning off all lights, turning on "Environmental lighting" in the world tab, then doing a full render bake. It's not exactly the same as AO, but it may do what you want. You can use the "Gather" controlsm but I don't think you can gat as good control as if you do separate texture and AO bakes and combine them. The combining step also gives you more control.

Share this post


Link to post
Share on other sites

hello :) i have trie that but noting at all the textures  still look very flat and boring i'm pretty sure i'm missing something or i'm doing something wrong cause there has to be a way to do the bake ^properly :( heres what i end up with when i bake full render Capture.PNG

no AO at all and if i wanted to tint my AO map i would have just bought a full perm and did it :P frustrating really ! i would love to if someone took a look at my blender file maybe i'm doing something wrong 

Share this post


Link to post
Share on other sites

Are you baking with AO set to add or multiply? Try changing that setting back and forth and see if yu get the result you want. I also like making sure under AO in the bake tab that normalized is checked.

Share this post


Link to post
Share on other sites

You haven't said where your texture is coming from, or whether you are using the Blender or the Cycles render engine. If you are applying the texture by putting it in the UV window, then the bake will overwrite it. Anyway, her are examples for both render engines. I thinbk the Blender one is preferable for this job because it gives more detailed control over the AO (Blender 7.61 - may be changed now).

In both case, there is no illumination except for the AO and/or Environmental lighting. For the Blender rednderer, set up the texture via a material, with appropriate mapping. Now switch the 3D view shading method (button at the bottom) to Rendered, so that you can see and adjust the effect of the AO. Play with the controls indicated on the left, especially Distance and Falloff, until it looks ok in the 3D view. Then do a bake with Full Render. You can see the output on the right of the picture.

combobake_blender.jpg

For the Cycles engine, set up the texturing as you want it in the Node editor, something like the way shown at the top here. Remember there is no lighting and note that there is no glossy shader. Remember to add and select the image texture to receive the bake. Set the 3D view to Rendered, as above. Now turn on Ambient Occlusion and adjust its parameters (mainly Distance) until it looks like what you want in the 3S view. Finally do a Combined bake, to get the result shown at the bottom right.

combobake_cycles.jpg

  • Like 1

Share this post


Link to post
Share on other sites


adamBRJ wrote:

no AO at all and if i wanted to tint my AO map i would have just bought a full perm and did it
:P
frustrating really ! i would love to if someone took a look at my blender file maybe i'm doing something wrong 

Well creating textures is not just tinting AO maps, and also not just doing it by a full render. Indeed you can do that, but you won't get that much of a convincing result. There is a lot more to it, than just doing a full render.

You will have much more control, and more versatility if you bake out specific maps, and compose the final image in a 2D image Editor. I actually know nobody who uses full render bakes as textures.

Share this post


Link to post
Share on other sites

I actually know nobody who uses full render bakes as textures.

That includes me, by the way. Although I attempted to show what you can do with a full bake above, that doesn't mean I would ever actually do it! At the very least, having the AO bake separate from the texture means you can use it with different textures, with different woodgrains, fo example, without having to do any more baking.

Share this post


Link to post
Share on other sites

hi :)

Looking at the image of your cabinet rezzed in world I would say you don't have the AO texture applied to it ?

Just a recap so you can confirm you have done these steps.

1; Upload and rezzed your cabinet inworld.

2: Upload your AO texture into your Inventory.

3: Edit your cabinet, open the Texture tab and drag your AO texture into the Texture square.

 

As Arton has already said the easy way to do it is, in a 2D editing programme like Gimp :

1: Open the wood texture you want your cabinet to have.

2: On the layer above the wood texture you open add your Baked AO texture

3: With your AO layer selected look to the top of the layers panel and you will find a Blend Type drop down menu which is usually set to Normal, you need to change it to Multiply.

4: Export this combined image file as a .png file.

5: Upload the .png to SL and apply to your mesh cabinet.

 

The more awkward way is to do the same thing in Blender :

1: Create a new Material for your mesh.

2: Create two Textures for that Material the first will be your wood texture. The second will be your AO bake texture and in the Influence panel for this texture you set the Blend mode to Multiply.

3: Add some sort of lighting to your scene.

4: In the UV/Image Editor create a new image to bake your Full render to

5: Bake out a Full render.

6: Save the resulting Full render Image and Upload it to SL and apply it to your mesh .

 

Its too late for me now but if need be i will re-explain the Blender way (with pictures)  tomorrow. But i urge you to do the Gimp way first :)

One last thing , as Roland suggested you should have baked your AO with the Normalized check box checked. Your AO is too grey and will result in a dull/dark finished texture when combined with the wood texture. Enabling the Normalized function will give you a much better AO texture so that the parts which have no "shadow" will be pure white instead of the light grey you have in yours. 

 Check out messages 3 and 4 here for tips on how to get better control of your AO baking in Blender

https://community.secondlife.com/t5/Mesh/Need-advice-buildings-in-blender/m-p/2368791#M24858

 

Edited to Add :

Drongle has shown you a slightly different (Blender) way in his first image so no need now for me to repeat it again tomorrow :)

Share this post


Link to post
Share on other sites

Here is the missing step; setting up the texture via a material.
1. Go to material tab.
2. Add a material (name it if you like).
3. Go to texture tab.
4. This is just a "New" button. Click it and the rest appears.
5. Tell it you want to use an image (assuming you do!).
6. Use this button to open image via file browser.
7. After scrolling down, set repeats if you need to.
8. Change mapping coordinates to UV.
9. Make sure only the colour is influenced.
Other settings can be changed if you want. I think this is all essential ones.
Now you should see the texture in the 3D view if you switch to "Rendered", but not if you switch to "Texture" which uses the texture in the UV editor instead. Te inset shows where to change view type.

texmat.jpg

Share this post


Link to post
Share on other sites

you guy !! thank you for all the help ! i finally made it work and figured out the process ! i was missing ALOT of steps !! 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...