Jump to content

WASD Keys not working (and no it's isn't because it's not toggled in Firestorm)


You are about to reply to a thread that has been inactive for 2431 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Ok here's my situation:

I have (3) accounts, my main (which is what I'm logged into now), and 2 alts.

On my main account:  The S and D keys do not move the avatar at all, they just quit working one day and haven't worked since.  I can still use arrow keys, but it's driving me nuts, I build bikes and vehicles in SL and can't drive them properly with just arrow keys.

On both my ALT accounts, the WASD keys work as intended with no issues at all.

 

Here's what I've tried:

1. Complete reinstalls of Firestorm: including cleaning out the proper directories (full cleanses).  

- Turns out, it wasn't just Firestorm, it does the same thing and has the same results as mentioned above, main account can't use the S and D, the alts can both move around happily.   This makes me think that this is the avatar itself or something ON the avatar which is somehow disabling my movement keys.

2. Completely resetting the Avatar (ie, Preferences, Avatar Health, Reset Avatar to Default Male).

- No change, still cannot move using S and D.

3. Recreate LSL Bridge.

- Noc change.

 

The only thing I can possibly think of that could be causing this, is some sort of local setting, something "hidden" that affects just the account in question, but I can't figure out where it is or what I'm looking for.  Any help would be appreciated because I'm definitely at my wit's end on this.

 

Rio

 

 

Link to comment
Share on other sites


Riodan wrote:

Ok here's my situation:

I have (3) accounts, my main (which is what I'm logged into now), and 2 alts.

On my main account:  The S and D keys do not move the avatar at all, they just quit working one day and haven't worked since.  I can still use arrow keys, but it's driving me nuts, I build bikes and vehicles in SL and can't drive them properly with just arrow keys.

On both my ALT accounts, the WASD keys work as intended with no issues at all.

 

Here's what I've tried:

1. Complete reinstalls of Firestorm: including cleaning out the proper directories (full cleanses).  

- Turns out, it wasn't just Firestorm, it does the same thing and has the same results as mentioned above, main account can't use the S and D, the alts can both move around happily.   This makes me think that this is the avatar itself or something ON the avatar which is somehow disabling my movement keys.

2. Completely resetting the Avatar (ie, Preferences, Avatar Health, Reset Avatar to Default Male).

- No change, still cannot move using S and D.

3. Recreate LSL Bridge.

- Noc change.

 

The only thing I can possibly think of that could be causing this, is some sort of local setting, something "hidden" that affects just the account in question, but I can't figure out where it is or what I'm looking for.  Any help would be appreciated because I'm definitely at my wit's end on this.

 

Rio

 

 

Take a look at your attached gestures - some may be capturing those keys.

Link to comment
Share on other sites

Went through my inventory and disabled every single gesture, still no change.  I'm running outta options here.. anyone else wanna take a shot at it?

 

I'd contact LL direct, but I stopped premium and have suddenly become unhelpable.

 

Link to comment
Share on other sites

Alright just for those who may or may not read this;

Certain huds, combat hud(s) especially, tend to take the WASD key assignments and use them for slinging weapons, drawing weapons, etc etc.  thus you lose the ability to move with WASD. Instead you get W and A.  If you ever run into this, simply type Control G in Second Life (if you are using Firestorm) which will bring up your gestures menu.  Find the active gestures, and unassign the keys they have overridden.  Keep in mind, you may search your inventory and use the filter, but it will NOT always find the active gestures, which is why I couldn't find them to begin with. 

 

-Solved- 

Thank you Firestorm Support Team, for a job well done!  

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2431 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...