Jump to content
  • 0
Sign in to follow this  
koto Nizna

Why am i having a dramatic drop of fps randomly ?

Question

  • 0

Its hard to say. I've seen this happen with several different viewers old ones did it and those since 2.5.1. Sometimes one has to reboot the computer and clear the cache to clear things up.Often the problem is a texture that the viewer is having a problem with. As the viewer decompresses the texture it sometime gets caught in a loop.

Also the texture may have corrupted in either the initial upload or your specefic download. In some cases the viewer never reads an end of file marker and keeps trying to download a new copy. Several things can go wrong. Often you can get FPS back by tirning 90 degrees left or right. If turning back slows you back down, it is probably a texture.

If the problem repeats after a reboot and cache clear, reinstall the viewer over the top of the previous install. It should save your settings. Reboot after the install.

If the problem still repeats, do a clean install of the viewer. Remove the viewer using the uninstall program. Manually clear all the program, cache, and settings folders. There are lots of steps, considerations, and file locations so read Second Life Clean Install, which is a blog post of mine. There is lots of additional information about the process. The SL WIki has a Clean Install set of instructions, with Mac file locations, but they mostly ignore the possibility you use more than one viewer. Sorry the posts are for Windows users... but the ideas are the same for the Mac. The file locations are different.

Also, if you use an nVidia graphics card make sure you have turned off multithreading. That is done in the nVidia control panel under Manage 3D Settings. One makes a profile for each 3D program. There are two tabs; golbal and programs. Profiles are in Programs. You will probably need to add the viewer program. When you click ADD a file open dialog appears. In Program Files->[Viewer Name] will be the viewer folder. You are looking for the EXE file, i.e., for SL = secondlife.exe or basically [viewer_name].exe. Click it and OK. In the settings list look for Threaded Optimization. Set it to OFF. Having this on Auto or On can cause crashes and FPS slow downs. You can see the actual dialog and settings in  Graphics Tweaking for Second Life plus there are other settings you may want to check.

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Its hard to say. I've seen this happen with several different viewers old ones did it and those since 2.5.1. Sometimes one has to reboot the computer and clear the cache to clear things up.Often the problem is a texture that the viewer is having a problem with. As the viewer decompresses the texture it sometime gets caught in a loop.

Also the texture may have corrupted in either the initial upload or your specefic download. In some cases the viewer never reads an end of file marker and keeps trying to download a new copy. Several things can go wrong. Often you can get FPS back by tirning 90 degrees left or right. If turning back slows you back down, it is probably a texture.

If the problem repeats after a reboot and cache clear, reinstall the viewer over the top of the previous install. It should save your settings. Reboot after the install.

If the problem still repeats, do a clean install of the viewer. Remove the viewer using the uninstall program. Manually clear all the program, cache, and settings folders. There are lots of steps, considerations, and file locations so read Second Life Clean Install, which is a blog post of mine. There is lots of additional information about the process. The SL WIki has a Clean Install set of instructions, with Mac file locations, but they mostly ignore the possibility you use more than one viewer. Sorry the posts are for Windows users... but the ideas are the same for the Mac. The file locations are different.

Also, if you use an nVidia graphics card make sure you have turned off multithreading. That is done in the nVidia control panel under Manage 3D Settings. One makes a profile for each 3D program. There are two tabs; golbal and programs. Profiles are in Programs. You will probably need to add the viewer program. When you click ADD a file open dialog appears. In Program Files->[Viewer Name] will be the viewer folder. You are looking for the EXE file, i.e., for SL = secondlife.exe or basically [viewer_name].exe. Click it and OK. In the settings list look for Threaded Optimization. Set it to OFF. Having this on Auto or On can cause crashes and FPS slow downs. You can see the actual dialog and settings in  Graphics Tweaking for Second Life plus there are other settings you may want to check.

Share this post


Link to post
Share on other sites
  • 0

Sadly, on the Mac we don't have a controlpanel to change the graphics card settings, so we simply have to accept the settings that are given to us....

 

- Luc -

Share this post


Link to post
Share on other sites
  • 0

Nalates post has a lot of tips for you to try, but are you having these issues from the moment you log in, or do you start at a 'normal' framerate and see it dropping slowly when in world? Or is it something that happens from time to time while in world?

I'm on a MacBook Pro myself, and are not seeing these dramatic drops.

- Luc -

Share this post


Link to post
Share on other sites
  • 0

There does seem to be a significant number of Macbook users that are claiming problems with v2.5, they seem to be ok on 2.4 so you could try downloading & using that one or see if the new Development Viewer  works better for you.

Get Viewer 2.4 here:  http://wiki.secondlife.com/wiki/Supported_Viewers

Get Development Viewer here:  http://wiki.secondlife.com/wiki/Linden_Lab_Official:Alternate_Viewers

 

Share this post


Link to post
Share on other sites
  • 0

i start at a normal fps. I cant really say when or how long from the moment i logged inworld im getting the drop its very random. I thought it was because of the areas with lots of sculpted prims but it also happened to me when i was in some areas with normal prim builds and not that busy.

Share this post


Link to post
Share on other sites
  • 0

I've had random framrate drops, from 30's down to single digits, and it turned out to be the GPU overheating. I put laptop cooling fan under the laptop and blew out the dust with a can of air and the framerate drops stopped.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...