Jump to content
Sign in to follow this  
Apple May

Blender cycles render noise help!

Recommended Posts

I've been trying to resolve an issue I'm having with youtube tutorials and multiple interenet searches to no prevail. Regardless of what nodes I use, clamp settings, etc... my render bake still has 'noise' through out the texture. Sure these things can be worked out in photoshop and I've always hand painted my lighting before, but I'd really like to solve the issue with in blender as it'll just continue to bug me and I'd really like to move into a new work flow.

I tried adding a slew of nodes following a despeckle tutorial I had found on youtube but what worked for him doesn't make a difference (AT ALL) in my texture.

The preview screen below shows exactly how my texture is baking.

ScreenShot.jpg

I'm sure it's something simple I may be missing... I'm a self taught blender user and I think being sleep deprived isn't helping. Any help is greatly appreciated (my brain will thank you)!

 

Oh... don't mine my light source in the background :)

Share this post


Link to post
Share on other sites

First thing is the number of samples. Camera tab; Sampling section; Set Render to at least 32, then check the "Square Samples" box. That box isn't about shape, it squares the number in the slots below. So 24 becomes 24 x 24 = 576. I use 32 squared (1024) for a 512x512 image at 100% resolution. It's SLOW. That's the price of using Cycles.

There are a lot of other settings that might have effects, especially Filter Glossy in the Light Paths section.

  • Like 1

Share this post


Link to post
Share on other sites

-------EDIT--------

It came out perfect, thank you for your help! I had read to keep the render number lower for noise... which was obviously wrong.

 

 

Giving that a try now. It's definitely MUCH slower.... snails pace infact... which I'm oddly happy about because I didn't notice a difference in the render time before so I feel (fingers crossed) that will work.

I'll keep ya posted. Thanks!

Share this post


Link to post
Share on other sites

Also please make sure to check if you have the CUDA support enabled.

 

Ok this only works with a certain range of grafic cards, but speed up the process immensly.

CUDA_Enabled_Render.JPGCUDA_Enabled_Prefs.JPG

 

As you can see ther are 2 places to do this. In the render settings where you also set the samples. And also in the prefernces of Blender. In the 1rst screenshot you set the the Devise to GPU. But this only works when in the prefs (screen 2 ) your card is recognized. See the blue CUDA Button down left in the second screenshot? Well normally Belnder would recognize your grafics card. But there are cases where this diddnt worked. This can mean

A:) You card is too old to support CUDA

B.) Somehow blender was not able to verify your card.

 

In the second case you can click the drop down field ( that the one where GeForce GTX 770 is noted ) and choose your card manually. If that dosent work, well see pont A. Sorry, no more speed.

After this is set and you where able to choose a card or one is recognized already, make sure the CUDA button is clicked ( blue ) and then set the render setting "Device" from screenshot 1 to GPU. This should speed things up.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...