Jump to content
Sign in to follow this  
BonitaBunny

Distortion with cloth modifier? (3DS MAX)

Recommended Posts

Hello! I'm trying my hand at meshing clothing on 3ds max.. before I always used Marvelous Designer and imported it into 3ds max, but I no longer have that program. Anyways, I'm following this tutorial to a T, using the SLAV avatar provided.

I'm just doing a basic test for my first try. Just two square planes so I can get the just of the garment maker and cloth modifier. Made sure the top and bottom avi meshes were set to collision objects, chose a cloth type for the planes.

 

Everything looks good, yeah?

 

But when I hit Simulate Local, this happens. 

 

Is this a problem due to scaling? Since secondlife requires the whole 'scale to meters' thing, which I have done. Everything is set up as it should be, and I've used this scene multiple times to create accessories. I dunno what I'm doing wrong with the cloth modifier, and I can't find any answers. As for the video, everything up until that point is done exactly as described.

My only thought is that the settings have to be tweaked to work with 'scale to meters', and I don't know where to begin with that.

 

Any help is appreciated :( Thanks bunches. ♥

Share this post


Link to post
Share on other sites

Okay, so it was the scaling. I set it back to centimeters and it's working fine now.

 

Now my problem is that I can't skin and export the mesh from that scene, or it'll end up exporting in a different unit - EVEN if I change the units back to Meters. So now I have to create the mesh in one scene and import it into another, where the units are already in meters. 

This is kind of a pain. Does anyone know an easier way?

Share this post


Link to post
Share on other sites

3 Ways:

#1: If you did set your scene units to centimeters, you can try to compensate it in the export settings. It maybe depends on what version of Max you have, at least I have an option "export units as..." in the export dialog. Default it's on 'automatic', so maybe you can get it right there by trying other settings.

#2: If you set your scene back to meters, then keep in mind: the default 'offset' (collision distance) for cloth and collition objects is "1.0"...which would mean 1 meter. So, on a scene with meters as unit, set the 'Offset' of your cloth and collider to something like 0.03 and "Depth" to around 0.15. You find these by clicking "Object Properties" in the Cloth-modifier.

#3: In the Cloth-modifier, rollout 'Simulation Parameters' you see the "cm/unit" setting. This might also let you make adjustments to the cloth-world-scale relation.

 

Edit:

One thing I forgot: When you'Re working on meters as scene-units, you'll probably run into problems with the Garment-Maker-modifier ... it doesn't like small objects. So if you're going to make a thin, 3 cm wide belt, the Garment-Maker will probably strart to throw errors.

The only solution then: Scale your SLAV-figure up by a factor of 100 or 1000, then make and simulate your clothing for it. When ready, collapse the cloth to an editable poly, scale the SLAV-figure and the cloth back to normal size and continue with skinnung.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...