Jump to content

Mesh Transparency Issue


Aurelia Chauveau
 Share

You are about to reply to a thread that has been inactive for 1170 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hi Guys

 

I've done transparent parts of mesh in the past and I haven't come across this issue before. Now all of a sudden I'm seeing it everywhere! I get this triangular effect when adding my texture with transparent parts to my uploaded mesh. I don't see the triangles if it is opaque.

 

I've started noticing it on some other designers outfits too and I've tried it on 2 different computers and I still see it. Is this just something that can't be done? Or is there a fix for it?

triangles.jpg

 

Thanks!

Aurelia

Link to comment
Share on other sites

Thanks, where do I find the Phong specular setting? is it in the build menu? I have only uploaded a model with a lambert texture applied, then done the texture in photoshop with an alpha map to create specular highlights... I have played around in SL and have found that if I reduce the transparency setting in the build menu that the triangles disappear quite a bit. I was hoping not to have it soooo transparent but if thats what it takes to look good I can live with it...

Link to comment
Share on other sites

Thanks guys -- I remembered that thread but did not remember the solution, which should come in handy (and all that part about angles:  whoosh.)


Drongle McMahon wrote:

Have a look at
. A solution is found in message 20. Make the overlapping transparent faces different materials. That may not be so easy, or even possible, with the amount of overlap you have here though.

ETA - Snap!

ETA: There are other solutions before 20, adding some hard edges, that might be much better in your case.

 

Link to comment
Share on other sites

  • 2 years later...

I've had the same problem and have tried the solutions put forth in this thread.  I'm using a bit more complicated of a mesh and in the smoother, open areas all is well, but in the crinkled area where my cloth bends in it, I get the triangles.  Haven't been able to make them go away :(

 

https://gyazo.com/8f9f703f9e6e7f4e33a21266b87315d9

 

Link to comment
Share on other sites

With surfaces that convoluted, it may be impossible to arrange materials so that none overlap themselves from all points ov view. If you are using Blender, you might achieve some improvement by deselecting the "Triangulate" option in the colladaexport options, letting the oploader do the triangulation. (It seems that the Blender triangulation puts half of each quad in different halves of the triangle list.) That's not likely to remove the problem entirely though.

Do you really need inside andoutside for this mesh? It looks to me as if you only ever see it from the outside.

Link to comment
Share on other sites

Here's an example of what I was trying to describe. This is a bowl with a very concave base and a double surface. Where you are looking through the outside and the base, there are thus up to eight surfaces you are looking through, but half always have their normals pointing away and are not rendered. So in effect we are looking through up to four rendered surfaces. The versions on the left were all exported without triangulation, while those on the right were triangulated by the exporter. At the bottom, all the surfaces are a single material. In the middle, the inside and the outside are each a different material. At the top, the main bowl and the concave base are further separated, so that there are four materials.

The four material version removes all the artifact for this relatively simple geometry, because we are now never able to look through two rendered surfaces that share a material. In the middle, where we are looking through both the outer bowl and the base, and only there, we are now looking through both outside and inside materials twice, and the artifacts appear. They are different depending on whether the triangulation is done by the uploader (left) or exporter (right), but neither eliminates them. At the bottom, we are now looking through the same material everywhere (except through the opening at the top) - with the uploader triangulation (left), the artifacts are much less obtrusive where we are looking through only two layers, but are still very bad when we are looking through both bowl and base - with the exporter triangulation, the artifacts are terrible everywhere.



If you can arrange your geometry and materials so that you can avoid all views where you are looking through the same material twice, then you can avoid the artifact. Otherwise, you may be able to mitigate its severity by avoiding the exporter's triangulation (which produces the most damaging ordering in the triangle list).

Link to comment
Share on other sites

Just wanted to add that it seems like SOME of the issues have been fixed in the uploader now since that post. a year ago.  I have noticed it often lately and I frequently reference that post which happily comes up in search if you remember the PHONG part :D.

 

In that thread along with making the "inside" one material and the "outside" another I believe you also had to let the uploader generate normals (something that I had never done). At least there was an extra step similar to that. That is the only way THEN that I could get it to work for me. Lately when making glasses similar to the ones I showed at the end of that post, there was no need to do that. I just uploaded as I would normally and it worked perfectly. I even put wine in the glasses with no issues. 

 

As it has been said your design might have too many overlapping areas to have a clean transparency, but making the underside of the skirt one material and the rest another material would be the first thing to try. You "might" also have to make any small thickness at the bottom (if that is a part of your mesh) a third material so that you wouldn't have a tiny thin "line" showing through from some angles. I have only seen that once on a garment but it was there.

 

Good luck!!!!!

 

Link to comment
Share on other sites

I've noticed another thing about this bug.  It seems to be worse on some GPUs.  I have an ASUS Strix with a GTX980m GPU and I have some nice wine glasses that look absolutely perfect.  On my wife's brand new iMac (AMD Radeon R9 M380) they look completely horrible, triangled mess.  I wish someone could actually explain this issue with facts instead of guessing.  It seems to make transparent objects undoable, especially when you're trying to sell items and uphold some reputation for quality.  

 

 

Link to comment
Share on other sites

Thanks for the reply.  Yes, I'd say that I need 2 sides to this mesh, as you can see the other side of the cloth hanging down on the far side of the harp.  Without that, I believe the result would look unrealistic.  I've experimented with this up and down and have found no way to get rid of the problem.  I guess transparent objects are just something we should avoid in SL.  I wish that was in a manual somewhere, it would have saved me days of futile testing. 

 

Link to comment
Share on other sites

  • 1 year later...

Sad that so much time passed and nothing changed. Only firestorm viewer found the workout from this bug. it shows the models properly most of the time(if not - right click on model fixes it). But when i jump on default second life viewer or other viewers based on it, it become a complete mess. Crease angle and Auto Smooth didnt make any valuable difference. Just the level of brokeness... Double sided check

The models are still transparent. Unticking the "Triangulate" option in export model menu also doesnt help.

Counting that my models actually doesnt supposed to be transparent at all. it`s not a glass or something.

So just ugh.

https://i.gyazo.com/90da2c3556774de44bb58db8c93b633e.png

 

 

Update: that was my fault. My models contains many details, including transparent shadows, combined into one model. Firestorm understands this on easy, but other browsers - dont. So when i set up textures, i need to just put Alpha on model to NONE, then select by Select Face the prim, that supposed to be transparent, and set alpha to blending. That fixes the trouble.

Edited by LynxHopps
Trouble fixed.
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 1170 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...