Jump to content
Sign in to follow this  
Feynt Mistral

Blender animation import problems - Failed to initialize motion

Recommended Posts

As per another thread mentioned elsewhere (specifically this one), I've tried to import several animations with the rig and scripts contained within.  It seems largely inconsistent though, sometimes it'll work (though avatar rotation doesn't seem to be affected) but most times I get "Failed to initialize motion" when I try to upload the exported BVH files.

Admittedly my reading the BVH file is far from perfect, but it looks just fine from one working file to another not working one.  Is there any guidelines which the BVH motion should fall into so that it doesn't fail?  For reference I've got a slightly modified version of the .blend file here for perusal.  The IK in the source file was inadequate for my needs.

Share this post


Link to post
Share on other sites

My testing seems to suggest it might be an issue with rotating the hip.  For some reason once the hip is rotated to allow the avatar to be laying down or flying, the SL client starts complaining about the motion.

Share this post


Link to post
Share on other sites

I believe I've discovered the issue.  For some reason the rotations of the control objects aren't translating to the bones.  So no matter what positions I put the IK controllers into, they always end up being in the initial T pose.  To confirm I set up an IK/FK switch in my scene.  Sure enough, when I turn off IK, even though my figure's bones have been keyframed in various poses, every frame of the animation is a T pose.  When I export FK animations from this blend file though, everything does export properly and I do see an animation occur.

 

I should point out I'm a programmer, not a Blender head, so I'm not really sure how this isn't working.  If I default to my programming skills I can make the exporter ignore bones which have certain naming conventions (like .IK.), but I think there's a better way.  Anyone out there have any ideas?  If I can finish this, it'll certainly be an asset to the Blender community on SL.

Share this post


Link to post
Share on other sites

So apparently I was doing it wrong.  I was keying the bones, however I should have been doing the keys on the controllers alone and then exporting the bones.  I've been able to get proper outputs now.  I'll have to do some additional testing to see if the default Blender exporter will work, and if so I can release my changes for public consumption as just the blend file.  Not having to replace scripts would be ideal.

Share this post


Link to post
Share on other sites

Well, I'm not a coder, but just an animator. What you are describing is consistent with what I have seen. Yes, you need to keyframe the IK bones. I use Avastar, and it would work the same way. If you don't keyframe the IK it doesn't transfer over. It would be cool if the keyframing did transfer to FK bones, cause then you could use IK, and FK whenever you wanted, but I'm sure there would still be issues.

Share this post


Link to post
Share on other sites

It made sense to me that where ever the bones happened to be when you set a keyframe, that's where they would be when you turned off IK.  Silly me for using logic on artist tools.  >D

 

Anyway the good news is that the output for Blender 2.68's default BVH exporter seems to work just fine.  The bad news is there's a slight rotation issue which I can't account for where my dude in Blender is just rotated perpendicular to the ground, but in world I'm rotated similarly but also slightly askew on the X axis (so that I'm banking to the left, if I were flying).  I'm sure it's just that I didn't turn something slightly to make SL pick up on that one bone (somewhere in this skeleton) as a clue that it should animate that too.

 

SL is very particular in how it takes its animations.  If it were a coffee patron, I'd hate to the barista that got its order wrong.  I'd end up with hot coffee on my face.  >S

Share this post


Link to post
Share on other sites

I'm still wrestling with this rotation issue.  Is it common for an avatar to appear rotated slightly clockwise when previewing animations?  It's rather annoying.  It would be great if someone else could confirm this issue.  A link to my current work can be found here.  It contains the BVH I exported with the default Blender 2.68 scripts and the blend file.

Share this post


Link to post
Share on other sites

I really know nothing about making a compatible rig, so keep this in mind. The first thing I notice when I select a bone, is that none of them are set to zero rotation, despite the rig being in a Tpose. Every single SL rig, or any rig for that matter, that I have ever used, has all the bones set to zero in the default pose. I don't think I've ever had to really do this, as most of the rigs I make myself go into platforms that it doesn't matter, plus it's a custom rig. I'm sure there is an easy way to set all the rotations to zero, in that Tpose. In Pose mode, probably just select all the bones, and then click Pose in the options next to the Mode. Then , Apply pose to rest pose. That's the options that I have, but I also use Avastar, and it might be an Avastar option. In Edit Mode, there is also an option to correct Bone Roll, under the Amature option next to the Mode option. I hope this helps. I only took a quick look and saw the issue, but it looks like you did a good job with it.

Share this post


Link to post
Share on other sites

You're right, the original skeleton wasn't zeroed for the base pose.  I did apply the rotations, but I don't think that made a difference.  I was still encountering the rotation issue.  I believe however it's an issue with previewing animations, perhaps a Firestorm issue entirely.  The default stand pose was for some reason skewing the rotation, even though I'm moving every bone on every axis (rotation and loc), even if just a little, from the default, and even through priority 4 on the animation.  Changing the preview pose to something else like flying seemed to correct the issue.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...