Jump to content

Mesh distorts after rigging in Blender.


Eliwood407
 Share

You are about to reply to a thread that has been inactive for 2585 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Good day!

I have just followed a tutorial on how to rig.
I started with a simple poncho wrapped around the shoulders.

I followed every step, and managed to do everything exactly the same, however when I want to upload the model, it looks completely distorted. (picture: http://gyazo.com/3321c9d9933b606ac28484877e9e5da2)

I am at a loss, and have no idea what could have caused this.
Some information that might make things clear:

-Model consists only out of triangles.
-Blender 2.49 used (just so it looks the same as the tutorial).
-Exported as COLLADA 1.4(.dae).
-The rigging itself works perfectly.
-The "fabric" of the model is flat, and has double sided triangles.
-A screenshot of the model in Blender, in edit mode. Maybe I have a setting somewhere wrong? 
 http://gyazo.com/d0d551dec4e95bed78272d7c07c2eac5
-I never use Blender, So I am not aware of the obvious noob problems that everyone might already know :X

 

I hope some one can help me!

Link to comment
Share on other sites

From what I understand is SL doesn't like Triangles, you may need to re build your object using vertices that make rectangles and squares.Or are generally four sided.

I am also, rather noobish, so I can't honestly go into more detail other thna to say I read it in a Blender help forum somewhere. 

 

I hope this helps somehow!

Link to comment
Share on other sites

I think this needs clarification:

In fact SL can only handle triangles!

What you mean is: Creating your models using Quads (4 sided polygons) is preferred for 2 reasons:

 

  1. Quads produce less artifacts when texturing (because of the way how the lighting is calculated)
  2. Quads make less trouble when you animate your object (because of cleaner topology)

I believe that you can read complete books about both topics :matte-motes-sunglasses-1:

However, when you upload a model to SL it is always converted to a mesh made only of triangles. But this does not contradict the statements above.

Link to comment
Share on other sites

It looks like some of your normals are facing the wrong way.  If you go into edit and select the whole mesh and press ctrl n that will recalculate the normals.

If that doesnt work correctly you will have to go in and manually flip the dierction of the normals by selecting each face that is the wrong way with them highlighted press w and select flip normals.  Not sure if this will be the same on your version of blender though.

To see if your normals are facing the wrong way you can enable backface cullling which is found the shading properties panel.  Im not sure if this will be in a different place with the version of blender you are using. 

Also it looks like your mesh is flat shaded.  I would turn on smooth shading so the mesh looks less jaggy.  You can change the shading mode when in object mode with your mesh selected you should see the option in your tool panel.  Again this maybe different on your version of blender.

 

The above shortcuts and information is all based on me using blender 2.71, so you may have to google how to do this on your version of blender or better still upgrade your blender to the newest one.  I do realise though that a lot of the tutorials all use different versions of blender, which have different UI layouts dont let the put you off using a more up to date version.  You may just have to google some parts to find out where the have now been moved to. 

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2585 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...