Jump to content
  • 0
Sign in to follow this  
Guest

How do i turn off the hovering text that appears over a scripted object?

Question

  • 0

Hi Jordan!

If it's a scripted vendor, you click the vendor to get the menu and disable hover text.

If it's an object with a simple hover text script in its Contents tab you would think you could just right click/edit then open the Contents tab and delete it. Unfortunately, that still leaves the hover text visible. Hover or floating text is a prim property and not dependent on a script for its continued existence.

What you should do is open the contents tab then open the hover text script and delete all the hover text wording between the inverted commas but leave the inverted commas alone. Then your text will disappear as there is no text left to display. In other words you may have "click here for landmark" as hover text. After deleting the words you just have "".

There is also another script you can place in the contents tab if you go the delete route which nullifies the remaining hover text. I think I have it somewhere but not online at the moment. However the method I suggested above will work.

Nyll

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Hi Jordan!

If it's a scripted vendor, you click the vendor to get the menu and disable hover text.

If it's an object with a simple hover text script in its Contents tab you would think you could just right click/edit then open the Contents tab and delete it. Unfortunately, that still leaves the hover text visible. Hover or floating text is a prim property and not dependent on a script for its continued existence.

What you should do is open the contents tab then open the hover text script and delete all the hover text wording between the inverted commas but leave the inverted commas alone. Then your text will disappear as there is no text left to display. In other words you may have "click here for landmark" as hover text. After deleting the words you just have "".

There is also another script you can place in the contents tab if you go the delete route which nullifies the remaining hover text. I think I have it somewhere but not online at the moment. However the method I suggested above will work.

Nyll

Share this post


Link to post
Share on other sites
  • 0

No, you misunderstand, i don't mean HOVERTEXT -- I mean the white box of text you get when you hover your pointer over a scripted object. It tells you the creator, item name, stuff like that... Maybe its only an emerald viewer thing?

Share this post


Link to post
Share on other sites
  • 0

If you have modify permission, and there is a script in the prim that does not do anything else like, like sit, just delete it, then jump to the Script part below. Most often ppl name hover text scripts, hover_text, floating text or something similar. Look for that if there are multiple scripts. Remember in a multiprim object (link set) the text script may not be in the root prim, it may be in a daughter prim so it ends up above the object.

-------- Script Part -----------

Create, either in your inventory and drag into the object or use the New Script button, a script called Kill Text. In that script put the following:

default
{
    state_entry()
    {

        llSetText("", <1,1,1>, 1.5);
      
    }
}

Thats it. The little script will kill your hover text.

Share this post


Link to post
Share on other sites
  • 0

I'm gonna reedit the question because i don't mean HOVERTEXT. I know what that is, and how to kill that... this is a generated white box of text that appears - for instance on a game or other scripted object - when the POINTER hovers over it.

 

Thanks for trying, though...

Share this post


Link to post
Share on other sites
  • 0

From the look of it, I'm almost sure that what can be seen on your screenshot is a (viewer 1.x-style) hover tip. Have you tried with Snowglobe or with the official client? Maybe Emerald has a bug so that some objects' tips are displayed regardless of the settings ...

Share this post


Link to post
Share on other sites
  • 0

Jordan, that's a hover tip. Just make sure there is no X against Show Hover Tips in the View menu. Ctrl+Shift+T is just a shortcut to manually doing it via the View menu.

I see you have marked the question answered so is it now solved?

Nyll

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...