Jump to content
Sign in to follow this  
Seth Ock

Is SL Voice Chat Working?

Recommended Posts

For the past week or so, I've been unable to use voice chat in SL. It was fine up until then, but then stopped without any obvious changes on my part. At least one of my friends is having the same problem, and we're running different operating systems (Linux vs. Windows 7). Relogging, rebooting, and changing sims doesn't seem to make a difference. When I run in terminal mode, I see the following message in the output:

2014-07-02T15:12:04Z WARNING: newview/llvoicevivox.cpp(135) : errorWithContent: ProvisionVoiceAccountRequest returned an error, retrying502]: {'reason':'Bad Gateway:'}

 

This suggests connection issues, and I'd expect to see others complaining, but there's nothing. Does anyone else know anything about this?

Share this post


Link to post
Share on other sites

I've had trouble with voice for some time and generally hate using it because I get frustrated.

Which viewer are you using? That might help to determine your problem. If you're using Firestorm, join the Firestorm support group and ask them if they've heard of your issue.

What I tend to do is go into Voice Settings, then the button on the bottom (whatever that's called. Sorry not on my system at the moment). I usually play with that a few times and EVENTUALLY it works, but takes a while.

Good luck

Share this post


Link to post
Share on other sites

Thanks, Tex! I'll check in with Firestorm, too. Good idea!

 

I have the latest Firestorm x64 beta -- which has generally been working great since download in every respect until voice just stopped working. My friend is using one of the Singularity viewers. Different viewers, different OSes, and yet we've both lost voice at roughly the same time when we've done nothing to change voice or hardware settings. I suspect something at the server level, but is anyone else having trouble with voice?


Is anyone else even using voice?

Share this post


Link to post
Share on other sites

Alright, this really doesn't appear to be something happening just on my end. I've spoken with other people with similar problems. Nevertheless, here are my specs:

Firestorm 4.6.5 (40833) May  6 2014 13:41:23 (Firestorm-Betax64) with OpenSimulator support
Release Notes

You are at xx, yy, zz in Oedo No located at sim10541.agni.lindenlab.com (216.82.52.47:13011)
SLURL: http://maps.secondlife.com/secondlife/Oedo%20No/20/20/20
(global coordinates 263990.0, 231579.0, 20.4)
Second Life Server 14.06.13.291023
Release Notes

CPU: Intel® Core2 Quad CPU    Q6700  @ 2.66GHz (2666.65 MHz)
Memory: 5901 MB
OS Version: Linux 3.2.0-65-generic #98-Ubuntu SMP Wed Jun 11 20:27:07 UTC 2014 x86_64
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GTX 560 Ti/PCIe/SSE2

OpenGL Version: 4.2.0 NVIDIA 304.116

RestrainedLove API: (disabled)
libcurl Version: libcurl/7.24.0 OpenSSL/1.0.1g zlib/1.2.6 c-ares/1.10.0
J2C Decoder Version: KDU v7.3.2
Audio Driver Version: FMOD Ex 4.44.32
Qt Webkit Version: 4.7.1 (version number hard-coded)
Voice Server Version: Vivox 3.2.0002.10426

Settings mode: Firestorm
Viewer Skin: AnsaStorm (Bright Blue)
Font Used: Deja Vu (96)
Draw distance: 128
Bandwidth: 1450
LOD factor: 4
Render quality: High (5/7)
Texture memory: 512 MB (1)
Built with GCC version 40407
Packets Lost: 12/39325 (0.0%)


It seems that if you log in from some sims, Oedo No being mine, voice chat doesn't work and will not work until you log in from a different sim. I assume that the bad sims are feeding incorrect connection data for the voice server (hence the bad gateway errors I get), and that is retained by the viewer until the next login.

I'll post more data here as I learn more and then compile it for a JIRA entry if necessary.


Thanks for any help or info anyone else can provide!

Share this post


Link to post
Share on other sites

download and install the SL viewer.. then copy the SLvoice.exe file from there to the firestorm folder.. should work fine after that, there seems to be a bug with the non SL viewer versions of that file. Sometimes anyway.. Worked for me.

 

Share this post


Link to post
Share on other sites


Seth Ock wrote:

It seems that if you log in from some sims, Oedo No being mine, voice chat doesn't work and will not work until you log in from a different sim. I assume that the bad sims are feeding incorrect connection data for the voice server (hence the bad gateway errors I get), and that is retained by the viewer until the next login.


Thats spot on.

When a region gets into this state, anyone logging into this region will have broken voice chat for the rest of their session.

Those logging in elsewhere and teleporting into that region will still have working voice chat.

The affected region needs a restart and all should be fixed.

Share this post


Link to post
Share on other sites

Alright, just got the problem solved. I contacted LiveChat, told them my problem. A tech guy showed up and looked around for a couple minutes, then there was an announcement for a sim restart.

 

And that fixed it.

 

Thanks for the feedback, folks. I appreciate the discussion.

Share this post


Link to post
Share on other sites


Seth Ock wrote:

It seems that if you log in from some sims, Oedo No being mine, voice chat doesn't work and will not work until you log in from a different sim. I assume that the bad sims are feeding incorrect connection data for the voice server (hence the bad gateway errors I get), and that is retained by the viewer until the next login.

I'll post more data here as I learn more and then compile it for a JIRA entry if necessary.

That was bang-on, Seth. Thanks a million!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...