Jump to content
  • 0
Sign in to follow this  
Meros Denothar

SL Viewer doesn't show "the world" but some strange shapes

You are about to reply to a thread that has been inactive for 3828 days.

Please take a moment to consider if this thread is worth bumping.

Question

  • 0

Hello Meros,

maybe it helps to set the graphic settiings to the recommend.

To do so click in 'edit' menu on 'Preferences' and on the 'Graphics'-tab on 'Recommended Settings', hit 'OK' and restart SL

Ciao

Dil

  • Like 1

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Hello Meros,

maybe it helps to set the graphic settiings to the recommend.

To do so click in 'edit' menu on 'Preferences' and on the 'Graphics'-tab on 'Recommended Settings', hit 'OK' and restart SL

Ciao

Dil

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

See this Torley's video tutorial: How to deal with some common annoyances

 

Title: How to deal with some common annoyances

Tv_top.jpg
Tv_left.jpg
Tv_right.jpg
Tv_bottom.jpg
Notes
This video tutorial contains the topics:
  • How to stop “triangles coming out of stuff!” (If you’ve seen it, you may very well know what I mean.)
  • How to stop animations
  • How to turn off foot shadows
  • How to mute sounds
  • How to stop viewer-side effects on your objects (like particles and floating text)

 

 


  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Try Preferences > Graphics > Hardware options > deselect "enable VBO"

From Turn off WindLight rendering (paragraph 2):


1. Start by turning your Graphics preferences to 'Low'

This is the same thing as turning OFF the special WindLight rendering that was introduced in version 1.19.1. 

Choosing "Low" graphics turns off the the shaders ("shaders" aresmall graphics programs) that make your computer draw the fancieravatar and world details like sky, water, etc.

In fact, once you are using on the Low setting, you arerunning the same underlying code that was in version 1.19.0! All along,we made careful considerations to ensure that the Low settingwill allow your computer to run Second Life with the same performance(and sometimes even better) than even the older viewers could.

 

Here's how:

  1. Run Second Life from your desktop.  You don't have to log in.
  2. Open Edit menu > Preferences...
  3. Click on the Graphics tab.
  4. There is a slider dial for Quality and Performance.  Drag it all the way to the Left!  That is the Low setting!
You can click this screenshot to enlarge it for a closer look:
500px-Graph_low_1.jpg

This is the #1 most important step you can take.   That's it!

 

More details:

By choosing Low, you have turned OFF the a) Basic Shaders, b) theshaders for Bump mapping and Shininess, and c) the Atmospheric shaders-- this is the key code that makes up the WindLight technology. If youreally want to see things under the hood, you can click on the Custom checkbox to ensure that these necessary bells & whistles have been turned off:

You can click this screenshot to enlarge it for a closer look:
500px-Graph_low_1b.jpg

Troubleshooting: But I am crashing

  1. If, in an extreme circumstances, you are unable to get SecondLife 1.20 to open up its login screen (yikes!), then add the followingthree words to the command line or desktop shortcut (How do I do this?).  This will turn OFF the Basic shaders before you even start:
Add this:
--set VertexShaderEnable 0
note, the last character is a zero (0).

2. If you still see glitches, try to disable 'Vertex Buffer Objects' (VBO)

An extra step that can help (in some cases) is to turn off VBO.  This is done in the Hardware Options of your Graphics preferences, because this is a setting on your graphics card.

Here's how

  1. Run Second Life from your desktop.  You don't have to log in.
  2. Open Edit menu > Preferences...
  3. Click on the Graphics tab.
  4. Click on the button for Hardware Options.  Now, look for the fourth option, Enable VBO:  Set this to be UNchecked.  This means it is turned off.
You can click this screenshot to enlarge it for a closer look:
500px-Graph_low_2.jpg

3. A minor improvement in some cases is to turn off 'Classic Clouds'

Here's how

  1. Run Second Life from your desktop and Log in.
  2. Open World menu > Environment Settings > Environment Editor
  3. Click on the button Advanced Sky
  4. Click on the tab for Clouds
  5. UN-check the option at the end of this window:  Draw Classic Clouds.  Un-checked means they are turned OFF.
  6. Now you can close all the windows.
  • See Also:  There's more information about the Advanced Sky Editor in the Knowledge Base

 

4. A minor improvement (only in rare cases) is to turn off an advanced feature 'Frame Buffer Objects' (FBO)

Start Second Life from your desktop shortcut with this advancedoption turned OFF. You will need to add the following three words tothe command line or desktop shortcut (How do I do this?).  This will turn OFF the Frame Buffer Objects (FBO).  Normally this is true anyway, but this is one way to confirm it.

Add this:
--set RenderUseFBO 0
note, the last character is a zero (0).

Share this post


Link to post
Share on other sites
  • 0

ATI graphics card and weird shapes? That's almost every time the Vertex Buffer! Try turning it off:

  1. Open Preferences (CTRL-P)
  2. Open the Graphics tab
  3. Click on the "Hardware Options" button at the bottom right
  4. Uncheck "Activate OpenGL Vertex Buffer objects"

Share this post


Link to post
Share on other sites
  • 0

i know the question is answered but you may want to upgrade your graphics drivers i tried upgrading mine went in to sl turned on VBO and got bombarded with those 'strange shapes' you mention which i never got before with this turned on i've turned it off and it makes a huge difference i get the feeling what i thought was an upgrade might've been a downgrade

Share this post


Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 3828 days.

Please take a moment to consider if this thread is worth bumping.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...