Jump to content
Sign in to follow this  
Caius Septimus

Crash Logger on Close

You are about to reply to a thread that has been inactive for 2301 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

For a couple of weeks now, I've been experiencing a weird issue: Whenever I close my SL viewer (latest Linden viewer), the program closes just fine, but I get a small pop up window:

Second Life Crash Logger
Sending to alternate server, try 1 ...

It's the strangest thing. I've tried reinstalling the viewer, but it continues to flash this error every time I close out.

i5-3570k @ 3.4 GHz
8 GB RAM
GTX 660Ti
Win-7 64x (SP1)

Share this post


Link to post
Share on other sites

"latest Linden viewer" isn't enough information... at present we have 5 "latest" viewers.  Which do you have?

Share this post


Link to post
Share on other sites

The one currently available on your website...

3.7.5.288464

 

Second Life 3.7.5 (288464) Mar 26 2014 06:41:28 (Second Life Release)
Release Notes

CPU: Intel® Core i5-3570K CPU @ 3.40GHz (3410.07 MHz)
Memory: 8142 MB
OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GTX 660 Ti/PCIe/SSE2

Windows Graphics Driver Version: 9.18.0013.3750
OpenGL Version: 4.4.0

libcurl Version: libcurl/7.24.0 OpenSSL/0.9.8q zlib/1.2.5
J2C Decoder Version: KDU v7.0
Audio Driver Version: FMOD Ex 4.44.31
Qt Webkit Version: 4.7.1 (version number hard-coded)
Voice Server Version: Not Connected
Built with MSVC version 1600

Share this post


Link to post
Share on other sites

We are not the ones with that problem. It's happening me too. I have this information:

 

CPU: Intel® Pentium® Dual CPU T3400 @ 2.16GHz (2161.25 MHz)
Memory: 3033 MB
OS Version: Microsoft Windows XP Service Pack 3 (Build 2600) compatibility mode. real ver: 6.0 (Build 2900)
Graphics Card Vendor: Intel
Graphics Card: Mobile Intel® 4 Series Express Chipset Family

Windows Graphics Driver Version: 6.14.0010.5420
OpenGL Version: 2.1.0 - Build 6.14.10.5420

libcurl Version: libcurl/7.24.0 OpenSSL/0.9.8q zlib/1.2.5
J2C Decoder Version: KDU v7.0
Audio Driver Version: FMOD Ex 4.44.31
Qt Webkit Version: 4.7.1 (version number hard-coded)
Voice Server Version: Not Connected
Built with MSVC version 1600

Share this post


Link to post
Share on other sites

I have the same on a any viewer with the google breakpad changes. I also thought this was an "expected" change with breakpad.

I do not see the crash logger window when I close the viewer but I see it very briefly (for less then half a second) flash onscreen when I launch any breakpad build.

When launching Second Life 3.7.5 (288464) Mar 26 2014 06:41:28 (Second Life Release) , SecondLifeViewer.exe *32 and win_crash_logger.exe *32 are launched Task manager -> processes.

Pre-Breakpad builds do not launch win_crash_logger unless a c rash report is being sent in.

Also on launch, a new folder is created in C:\Users\Whirly\AppData\Roaming\SecondLife\logs named dump-f3fe84aa-833e-49b3-5a59-b2ec81f32c61 containing a file named static_debug_info.log.


After logout this dump-f3fe84aa-833e-49b3-5a59-b2ec81f32c61 folder is removed from the logs folder.

A new dump-<different random letters and numbers> folder is created each launch.

Is this expected or not Oz?

Testing system:

Second Life 3.7.5 (288464) Mar 26 2014 06:41:28 (Second Life Release)Release NotesCPU: Intel® Core i7-4770K CPU @ 3.50GHz (3491.96 MHz)Memory: 16268 MBOS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)Graphics Card Vendor: NVIDIA CorporationGraphics Card: GeForce GTX 750/PCIe/SSE2Windows Graphics Driver Version: 9.18.0013.3750OpenGL Version: 4.4.0libcurl Version: libcurl/7.24.0 OpenSSL/0.9.8q zlib/1.2.5J2C Decoder Version: KDU v7.0Audio Driver Version: FMOD Ex 4.44.31Qt Webkit Version: 4.7.1 (version number hard-coded)Voice Server Version: Not ConnectedBuilt with MSVC version 1600

 

 

 

Share this post


Link to post
Share on other sites

I just checked on my older desktop system too and on that system I see the crash logger briefly appear when closing the viewer, not when launching it - go figure :smileywink:

Second Life 3.7.5 (288464) Mar 26 2014 06:41:28 (Last)Release NotesCPU: Intel® Core2 Quad CPU    Q8300  @ 2.50GHz (2493.75 MHz)Memory: 3326 MBOS Version: Microsoft Windows Vista 32-bit Service Pack 2 (Build 6002)Graphics Card Vendor: NVIDIA CorporationGraphics Card: GeForce GT 230/PCIe/SSE2Windows Graphics Driver Version: 9.18.0013.3523OpenGL Version: 3.3.0libcurl Version: libcurl/7.24.0 OpenSSL/0.9.8q zlib/1.2.5J2C Decoder Version: KDU v7.0Audio Driver Version: FMOD Ex 4.44.31Qt Webkit Version: 4.7.1 (version number hard-coded)Voice Server Version: Not ConnectedBuilt with MSVC version 1600

 

 

Share this post


Link to post
Share on other sites

Something else is going very wrong with the crash reporting on the Breakpad builds.

I suspect some of you were actually reporting what I am now seeing.

I am now having multiple crash reports being sent in at viewer launch, viewer close and even while logged in, even though the viewer does not crash.

I filed a bug report at BUG-5707

Share this post


Link to post
Share on other sites

To clarify, I'm only seeing the crash logger pop-up once I've closed the viewer. Though, reading your report, it does sound like you're experiencing what I've been going through for over a week now. Hopefully this can be resolved; it doesn't impact my experience, but it's annoying.

EDIT - I deleted my logs folder as you mentioned in the report, but while I'm still seeing the crash logger appear after closing the client, it's now closing very quickly (as you oringally reported). This is using the current public viewer build available from the site.

Share this post


Link to post
Share on other sites

Yeah, deleting the logs folder seems to put behaviour back to the (expected?) very quick flash of the crash reporter on launch or close.

That is, until *something* happens to get the viewer logs folder into a bad state again.

I found one way to consistently make this happen, I'm sure there are others.

Share this post


Link to post
Share on other sites

I've been having the same problem as Caius Septimus for the past two weeks. The crash logger window (sometimes several of them) appears every time I close the viewer. I also have the latest viewer (Second_Life_3_7_5_288464_i686), and even tried a reinstall.

Share this post


Link to post
Share on other sites

This might sound crazy, but could this maybe be in some way related to using the web-based teleport through the marketplace? Since deleting my logs folder, I've only experienced the quick flash crash logger, but I noticed that after using the marketplace to teleport to a store in-world, the crash logger lingers until I close it (as I reported in the OP).

I've since deleted the logs folder and am back to the quick logger.

Share this post


Link to post
Share on other sites

Not in my case Caius. I get the crash logger even when I run the the viewer and close it, without logging in.

Share this post


Link to post
Share on other sites

I am having the same problem. Crash logger appears everytime I close out SL. Has anyone gotten any feedback? Is there something I can do to stop it? It has become rather annoying, hanging up there in the corner of my screen.

Thanks,

Tan Vayandar 

Share this post


Link to post
Share on other sites

I get it too. And not only when quitting. I get it now and then in sl - without the client crashing. Just walk around and up comes crash logger. But I have just to click the x to close the crash logger window and continue what I was doing.

Share this post


Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 2301 days.

Please take a moment to consider if this thread is worth bumping.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...