Jump to content
Sign in to follow this  
Pter Moreau

nVidia GTX 870m issues

Recommended Posts

Hello All

I recently purchased a new laptop computer (i7 4800) with a nVidia gtx870m video card in it. 

When I enter SL it trys to use the intel HD 4600 graphics, which give me mid to hi graphics . If i try to use the nVidia gtx 870m card. SL says Im using a ATI GeForce Lulz , which gives me the lowest quality graphics.

Any one have any ideas how to use the GTX 870m card in SL. I have heard that older 700 series cards work great in SL, giving unltra graphics.

Share this post


Link to post
Share on other sites

Hi Pter,

I think your problem is due to the GTX 870 being so new that the viewers don't yet know about it. There's a file called "gputable.txt" that contains configuration information for various video chips. I just checked the version that accompanies the latest Firestorm release, and the table stops with the GTX 7xx family.

If you are handy with a text editor, and can find that file on your computer (on a Mac, right click the viewer and select "Open Package Contents" then go to the Resources folder where you'll find the file) open it and search for this line...

NVIDIA GTX 770M .*NVIDIA .*GTX *77[0-9]M.* 5 1 0 4.4

Change each occurance of 77 to 87, save the file and relaunch your viewer. No promises, but that may allow your viewer to recognize and use your whizzy new video adapter. Eventually the official viewer releases will contain a line for your adapter, until then, if that edit works, keep a copy of the file around to replace any you get with future releases that don't work.

Good luck!

Share this post


Link to post
Share on other sites

Information on the format of the table is here: http://blog.nalates.net/2013/08/26/gpu-table-performance/

Also, your video card software is likely not recognizing SL as a video game... excuse the use of 'game'. Go into your video setup and create a profile for Second Life. Set it for performance over power saving.

Without this profile your laptop, when running on battery, will always try to use the HD graphics system to save power.

Share this post


Link to post
Share on other sites

The loading screen for SL would tell me My card was a ATI. Now after your suggestion it calls it a GTX 870, and works great. Thank  you very much.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...