Jump to content

I have tried EVERYTHING I know and nothing works it all comes out the same. Shadow map help!


Antumbra
 Share

You are about to reply to a thread that has been inactive for 3671 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Everytime I bake my shadow map in blender it comes out so dark and black at the top! I can't even texture it cuz its so dark. Why does it keep coming out so dark? I need help so bad :( this is frustrating me and i've been trying to figure out why all day long. I have attatched a picture of my shadow map. Can someone please please help me with shadow mapping because idk how. I also use marvelous designer to make my mesh and i import them into blender and try to make them work for sl. So PLEASE someone! i'm desperate T_Tuvla2ysout-uJSwO60A.png

Link to comment
Share on other sites

I only use the default light set up in Blender and get very good ambient occlusion maps. That "is" what you want and of course you don't want them all that dark (you see that every once in awhile on mesh templates and it is not pretty).

So if you don't know how to bake and ambient occlusion map, just search for that in Google or Bing or whatever. There are bound to be plenty of tutorials. There are a few things that can go wrong with that process but if you try the ambient bake and have issues, send in a screenshot and folks can help you. You can of course export your UV map too and draw on that.

 

I also see comments about issues with Marelous Designer so that "might" be part of the issue. I don't know anything about that program except that the mesh can be very heavy.

 

Good luck. It IS an adventure  -- no question about it *wink*.

Link to comment
Share on other sites

Antumbra, it helps to take a breath and relax your mind. Working with 3D models seems difficult at first but it does get better. There are alot of experienced people here who are willing to help. I wish I had this when I first started years ago, and I feel sympathetic for the frustration of someone first starting out. 

One thing that helps immensly for finding the right help for your problem is helping people understand what your issue is actualy called. 

Are you baking "Ambient Occlusion"?

Or...

Are you baking the "Shadow Map" from lights in the scene?

Ambient Occlusion works just fine with the default light in the scene, but you need to adjust the settings to get the right amount, otherwise the Ambient Occlusion will cover too much of the surface area of the mesh.

What I see is Ambient Occlusion set to cover too much of the mesh.

Link to comment
Share on other sites

I'm going to throw out something completely different and it may not be this at all but given that there's very little information to go on, i'll offer this.

All of the following are stated after consulting my Crystall Ball v1.0.  If it's incorrect, then I may have to upgrade to Crystal Ball v1.1 but here goes...

You're using blender... you've chosen to add a solidfy modifier...you've baked an ambient occlusion map.

What has happened is that the UV map for the solidified faces are at the same UV coordinates as the outer face but get baked second.  You see this when watching the AO bake, it does it normally and then appears to go "dark" as it bakes the inner face at the same place and what you're left with is the ambient occlusion map of the inside of the dress, hence dark.

You can turn off the render of the solidify modifier in the modifier stack, then it won't take part in the bake process.

If it's not this then whatever anyone else has to offer applies instead.

Link to comment
Share on other sites

@Chic AO bakes do not even need a light source, they are done by sampling nearby geometry

 

@ sassy Wouldn't be that sassy, that would result in a bunch of ugly triangles from baking the same coordinates twice

 

(Not shooting anyones stuff down, just wanting to clarify things. Knowing about the turning solidify off is VERY useful. But also knowing you don't need to set any lights up for the AO map but DO need to set them up for the shadow map is also very useful)

Link to comment
Share on other sites


MIstahMoose wrote:

 

@ sassy Wouldn't be that sassy, that would result in a bunch of ugly triangles from baking the same coordinates twice


It depends on various things like what the thickness of the solidify is.  I've used this method in order to deliberately generate both exterior and interior AO bakes when using the solidfy modifier.

We do need more info though as to the process that's being used.

Link to comment
Share on other sites

Hi

As others have already said instead of adding lights to your scene and baking out shadows  you probably should be baking out Ambient Occlusion  (no lights are needed )

Have a look at this thread , message 3 and 4 :

http://community.secondlife.com/t5/Mesh/Need-advice-buildings-in-blender/m-p/2368791#M24858

Set the Samples to 5 and play about with the Distance and Strength values until you get something you like.

Then set the samples to somewhere around 20 or 30 for the final bake.

 

 

 

 

Link to comment
Share on other sites

Not really related to this, but it is also worth noting that AO bakes are influenced by your avatar's pose. For instance, you will notice that when you bake pants or short, between the legs are very dark. If you move the legs so that your avatar is making more of an X shape, then the shading between the legs will be less dark.

Link to comment
Share on other sites

Then I'm guessing the answer is as Sassy suggested in message N°5.

Your  dress has inner and outer faces and the 2 are overlapped on the UV map ?

If that is the case you would need to separate them so that you have 4 UV islands instead of just 2

For a quick check to see if this is the cause:

Save a  copy of your Blender file and in the new file,  in Edit mode with Face select activated select a large group of those inner faces and delete them.

Then try re-baking the Ambient Occlusion.

Is a part of the bake now with much lighter shading ?

 

Edited to add:

 Before you do the above you could try bumping up the Strength value as in the image below, (The default is 0) and then baking. This may give you a much lighter texture but is not the correct way to do it . ;)

AO .png

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3671 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...