Jump to content
Sign in to follow this  
Maestro Linden

Deploys for the week of 2014-03-10

Recommended Posts

Second Life Server (main channel)

The main channel will be updated to get the server maintenance project that was on BlueSteel and LeTigre last week.  This project contains assorted bug fixes.

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_Server/14#14.02.28.287383

Scheduled Tuesday 2014-03-11 04:00-09:00 PDT

 

Second Life RC BlueSteel, RC LeTigre, and RC Magnum:

BlueSteel and LeTigre are joining Magnum on inventory update project.  This project enables support for a new version of the inventory service, AISv3.  To make use of this new feature, login with the Sunshine RC Viewer.

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_BlueSteel/14#14.03.07.287758
https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_LeTigre/14#14.03.07.287758
https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_Magnum/14#14.03.07.287758

Scheduled Wednesday 2014-03-12 07:00-10:30 PDT

 

We will be monitoring this thread as the code gets released, so feel free to note any observations you have about the server updates.  If you have a specific bug you'd like to report, please file a Jira

Share this post


Link to post
Share on other sites

OK, I'm putting this here because not sure where else to go with this.

In this thread, where the OP got a little testy with those of us trying to help her she stated and posted a screen shot with the error message, "login failed (Waiting for server response)."

I can count a half dozen other times this has come up in the Forum or Answers yet can find no reference to this error message in the Knowledge Base or Wiki.

So the best any of us have been able to offer is the Knowledge Base article, Login Failures.

Are any of you Server Devs able to offer any more insight into this error message and if there is more insight is it possible to update the Knowledge Base accordingly?

Thanks Much,

Your Favorite Martian

Share this post


Link to post
Share on other sites

Hi Perrie, that sounds like a generic timeout failure.  Either the login server was taking too long to respond, or the viewer was having trouble establishing a connection to the login server (the latter could be any number of networking issues).  The viewer's SecondLife.log may have more details related to the failure.

Share this post


Link to post
Share on other sites

Perrie

I'm now almost completely certain from all the data I get that the Login issue is a server timeout event.  Now, as to WHY the login server times out, that's another thing and it is up to Linden Labs techs to sort that out.

I noted that the Login server got some maintenance at the end of last week, so maybe the knicker elastic has been tightened...who knows?

 

ETA 16:00 GMT:

OK so I was tempting fate by saying that, I had another non-response upon my first Login attempt at about 14:40GMT, 2 mins later absolutely no issue!  Just seen Monty's post, that was where I started!  No, it wasn't a restart, the sim is only just now restarting.

Share this post


Link to post
Share on other sites

Thank you Maestro.

I had a suspician that that was going to be the answer but wanted to be sure.

Much appreciated.

Share this post


Link to post
Share on other sites

Since restart I can't see mech items. Nor can my friend on different viewer. We can't send im's to anyone and ther parcel name no longer exists. it just has the sim name (Fietzo)

Share this post


Link to post
Share on other sites


Perrie Juran wrote:

OK, I'm putting this here because not sure where else to go with this.

In
, where the OP got a little testy with those of us trying to help her she stated and posted a screen shot with the error message, "login failed (Waiting for server response)."

I can count a half dozen other times this has come up in the Forum or Answers yet can find no reference to this error message in the Knowledge Base or Wiki.

So the best any of us have been able to offer is the Knowledge Base article,

Are any of you Server Devs able to offer any more insight into this error message and if there is more insight is it possible to update the Knowledge Base accordingly?

That's actually a very specific error message that comes from the XML RPC system used, for example, by the login process.  You can find it in viewer sources in llxmlrpctransaction.cpp.  It indicates that a response was never received for a request or that a request was never fully sent to servers.

Problems of this sort are usually due to maintenance or other issues on the servers.  But if they persist, then there's an issue somewhere in the pipeline (client, networking gear, isp, backbone, linden).  In this case, viewer log files are the place to start looking.  Jira or support can be one way to get eyes on the problem.  For those who want to self-diagnose from the log files, you can learn how to read some of their content here:  http://jira.phoenixviewer.com/browse/PHOE-2707

 

Share this post


Link to post
Share on other sites

Thank you for the additional information.  Is it OK if I add this in a reply in the KB?

The OP in the thread I referenced is going to give us all grey hairs prematurely.  She just now reported a new error message:  SSL Peer Certificate or SSH Remote Key was not OK.

Sheeeeeesh!

Share this post


Link to post
Share on other sites


Perrie Juran wrote:

Thank you for the additional information.  Is it OK if I add this in a reply in the KB?

Sounds like a reasonable addition, sure.

Share this post


Link to post
Share on other sites

OK, this is the current Grid Status

 

[updated 7:25 AM PST, 11 March 2014] The rolling restarts for the main Second Life server channel are now underway.

[Posted 8:28 PM PDT, 10 March 2014] We will be performing rolling restarts for regions on the main Second Life server channel on Tuesday, March 11th, beginning at approximately 3:00 AM PDT. Please refrain from rezzing no copy objects, making inworld L$ transactions and remember to save all builds.


When did you guys actually start?

I could understand a PST/PDT mistake on a Monday morning, but last I heard today was Tuesday.

The initial announcement (Monday evening) was 3am PDT. You say 4am PDT, We don't get the status update until 7.25am PST, which should be 8.25am PDT. And we have the standard "please refrain from rezzing"

Your original timetable reckons this will take about 5 hours (posted at the head of the thread), and I am not too bothered by unexpected overruns, but on top of the weekly **bleep**-up over the timing of the Grid Status announcement—when do you really start?—we have this confusion over the time zone.

I'm in Europe. We're making the transition between work-day and evening. And every Tuesday, every Wednesday, we have to deal with this horribly slipshod reporting of just when you start this important, routine, maintenance work.

How many years has it been like this? How many years have you failed to tell us the Grid Status? In your carefully documented procedures, does nobody have the job of sending a Status message when you start?

And the switch to Daylight Saving Time is hardly something new,

How can we trust you whan you cannot cope with these regulkar events?

Share this post


Link to post
Share on other sites


Cully Andel wrote:

Since restart I can't see mech items. Nor can my friend on different viewer. We can't send im's to anyone and ther parcel name no longer exists. it just has the sim name (Fietzo)

Hi Cully, it sounds like there's something wrong with Fietzo - that sounds like a 'capabilities' outage.  Please contact support if the issue is still occurring. 

Share this post


Link to post
Share on other sites

Maestro


Maestro Linden wrote:

 I would recommend using the release calendar (found on the right side of
) when planning around rolls.



This week that would not be a good idea, since according to the Google calendar the rolls were slated to start at 5:00am!

Now granted that the calendar does not say either PST or PDT but either way it is still wrong!

The last few weeks the roll has been slated to start at 3am on the calendar, so why the reversion to 5am this week??

I no longer have ANY faith in the GSP's timing, since it is so often initially wrong and only corrected by some Ninja editing.  Just once it'd be nice to have an honest admission of a mix-up on the GSP.  Is that too much to ask?

 

ETA Wednesday 2:30pm GMT:

Well there we go, the Google calendar now shows that the Tuesday rolls were slated to start at 3am....wow, more Ninja editing!  Oh and before you say anything yes I did refresh the page before sounding off!

Share this post


Link to post
Share on other sites

when the restart announcements are posted a day late, and a backdated "preannoucement" is added, the reality is made really obvious from the post date and when the messages come in through RSS. intentional or not, communications like that make the company look kind of shady.

Share this post


Link to post
Share on other sites

I looked at the Grid Status page at around 15:30 UTC, which is 08:30 PDT, and there was nothing at all about any restarts today.

I have just checked the page, and found this:

Posted by Status Desk on March 12th, 2014 at 06:47 am PDT

[updated 6:48 PM PDT, 12 March 2014]  The rolling restarts for the RC server channels are now in progress.

[Posted 10:33 PM PDT, 11 March 2014] We will be performing rolling restarts for regions on Magnum, BlueSteel and LeTigre RC server channels. They will begin on Wednesday, March 12, at approximately 7:00AM PDT.

Let me just point out the mess you are making in detail.

1: You get confused by the difference between AM and PM. That is morning and afternoon, sunrise and sunset. It should be pretty obvious. OK, so sunrise was at 7:35 am PDT, and it would still be dark, but the sun will not set until 7:14pm. I also suspect a thick layer of fog around Battery Street, and it may be metaphorical rather than meteorological.

2: This is the usual in progress message (with the usual warning about rezzing objects and L$ transactions) posted before the start-time listed on the Calendar (hurrah), but saying "now in progress" rather than telling us the process is about to start.

3: one and three quarter hours later the message was not on the Status Page.

I don't know who you have running the Grid Status Page, but they're obviously not firing on all cylinders today. And with that sort of reliability, why should we trust it? What is special about the server roll-outs that leads to these mistakes, or is there nothing on the GSP we can rely on?

 

Share this post


Link to post
Share on other sites

Maestro, there is nothing on the Grid Status Page about the Wednesday Release Channel Grid Roll though it is on the Twitter Grid Status feed. Things do seem a little confused.

Share this post


Link to post
Share on other sites

Maestro

This is heaping idiocy upon incompetence...the GSP is now devoid of any reports of the RC rolls...what on EARTH is up with those people, are they TRYING to make Linden Lab look bad?

Take it from me and many others...they are succeeding!

 

Share this post


Link to post
Share on other sites

Between the guy complaining about AM vs PM, and the complaints about the status page, you guys are a regular circus.

Can only sit back and wonder why you have nothing better to do with your time than badger poor Maestro. :matte-motes-nerdy:

Still, it does give me a daily dose of laughter every morning.

Share this post


Link to post
Share on other sites

Darien

I never thought of You as a sniper...there we go.  Look, it's simple - the GSP is there simply and solely to give us correct info on potential issues inworld, and WHEN they are to happen.

If the GSP staff care so little or are so incompetent that they do not know what day it is or what time it is and give us innaccurate information, are we not entitled to complain?  It may not bother you...you run on US time and therefore are less affected by confusions over Daylight Saving time - not all of us are so fortunate.

It isn't a major issue, unless you think that competent staff ought to be able to give coherent and consistently correct information to us, the masses of non-US users.  Be in no doubt, Darien, SL would not survive without non-US users.

As to pestering Maestro - well, he is our only real point of contact with Linden Lab, so I guess he's in the barrel.  I appreciate Maestro's preparedness to engage with us users, he's not unique and I DO value him.

In the limit, Dari, Yes, we DO have better things to do with our time, which is why accurate trustworthy information our the Grid is important.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×