Jump to content
Sign in to follow this  
vixtris

Which Avastar version do I use?

Recommended Posts

Hi guys,

 

I looked all over the forum (maybe not enough) to try to find which version of avastar I need to use for the fitted mesh. I tried both 1-0 and 1-1, and I do not see the new bones in either of those (in the vertex groups). Which version do I download, or what do I need to do to see these new bones for fitted mesh? I also downloaded other versions of Blender, but that didn't seem to help the situation. Sorry if this question is already answered somewhere, I wasn't able to find an answer.

 

Thanks.

Share this post


Link to post
Share on other sites

avastar 1 and 1.1 only work with Blender 2.49.  These two versions of Avastar predate "mesh" implementation in SL and do not have any facility to do things with the SL avatar.

 

To do Mesh and rigging you need a newer version of Avaster than what is listed above

and a Blender version newer then 2.5

 

If you still are interested in Avastar after that then I suggest you examine this web page  http://blog.machinimatrix.org/avastar/

 

Share this post


Link to post
Share on other sites


hibit Spad wrote:

avastar 1 and 1.1 only work with Blender 2.49.  These two versions of Avastar predate "mesh" implementation in SL and do not have any facility to do things with the SL avatar.

Hi, Hibit; I am sure you mixed up Primstar with Avastar. So here is a more detailed answer:

http://blog.machinimatrix.org/2014/03/05/which-avastar-to-use/

In a nutshell:

 

  • Use Avastar-1.0 as the stable released version (supports Liquid mesh)
  • Use the most recent Testversion for testing purposes (supports Fitted Mesh, but currently has a glitch, for more details you might follow the link above)

You always can wait for the official release of the next version. That will be tested well and will have no known bugs.

Share this post


Link to post
Share on other sites

DOH

 

Your right Gaia.  Thank you.  

 

Lesson learned don't answer forum questions during a school lecture.

 

 

Share this post


Link to post
Share on other sites

Thanks Gaia! I wasnt sure if 1.0 supported the fitted mesh or not. currently I am using the test version of 1.1, and I figured out how to get the new bones to show up after watching one of your tutorials.

I read the link you gave me, it says that there is a glitch with the sliders. I am not sure what exactly the glitch is... although the weights of the stomach and love handles are a little weird (i think that can be fixed with manual weight painting though, right?) but the major problem for me is i cant figure out how to get the fitted mesh to stretch with the breast size slider (unless that is the glitch?).

Share this post


Link to post
Share on other sites

Well, about the breast size slider, i had the same problem... And unless it is a glitch, the problem is as far as i can see, that the breasts has no weights when you make it fitted mesh.. I think you have to weight paint the breasts to the collission bone things inorder to make them move..
I weightpainted them in a quick test, and then they move with the breast sliders when it was fitted mesh.. :-)

Share this post


Link to post
Share on other sites

skinning_01.pngYou can try it with the newest testversion. And in the tool shelf, in the Skinning panel you find 2 buttons for "Fitted Mesh" and "Classic Skinning". These buttons will preset your mesh with initial weights for the cBones and mBones.

You also need to "Attach" the sliders. Then the sliders will affect the meshes. (The button tells what will happen when you press it. Actually i believe that is confusing, so i added an entry to my "to improve" list)

Please take care about the operator panel (which appears at the bottom of the tool shelf and is labelled "Bone Presets" in this context). There you have a few extra options to influence what weights are copied from where to where in order to get a much better initial weighting.

 

But note: The glitch that i mentioned is that right now fitted Meshes are not displayed correctly in Blender. However it looks like they still are exported correctly. I will look at that in more detail after we have fixed the main problem.

Share this post


Link to post
Share on other sites

@ Connor - what bone/vertex group did you add the weight paints to for the breast slider?

 

@ Gaia - thank you! I will try that out soon.

Share this post


Link to post
Share on other sites

Sry for the late reply... :-)
They are called LEFT_PEC and RIGHT_PEC... However, i noticed that they don't show up in the Vertex Groups before i add some weights to them, i just select them inside the breast and then weightpaint...
And good luck with it.. I am not new to weightpainting, but I must admit i have given up trying to weightpaint it so it works and it follows the avatar without being a complete mess as it is now.. I hope you have more luck with it.. :-)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...