Jump to content

Jerky Motion when Capturing


Toysoldier Thor
 Share

You are about to reply to a thread that has been inactive for 2545 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

So for a couple weeks I have tried pretty my everything to resolve this frustrating problem while trying to capture and produce my first Machimina. 

The problem is simple... when trying to capture a flycam scene through my art gallery, the movements are jerky.

Some points to consider that you all may ask me and hopefully I can answer in advance:

 

  1. The level of jerkiness is far more pronounced when there is a lot of screen content movement such as rotating the camera or flying close by a wall / object.  If I cam camming straight forward toward a target/subject the jerkiness is almost gone.
  2. When not capturing, the flycam motion is 100% fluid and smooth - regardless of any movement of the camera.  I am using a 3DConnexions joystick with full feathering and slow coordinates response so that it provides a very stable flycam experience.
  3. I have a pretty darn powerful computer, HD7950 graphics card, i7-860, 8GB RAM, two monitors 1024x1920 and 2650x1600, and both an SSD and standard HD.
  4. I have tried the Beta and non-Beta version of FS, Singularity, and LL latest viewers.  No real change in the problem between any of these versions.
  5. I set my viewer to have a HIGH priority on my system cpu so that it beats all other apps.
  6. I have even set the Graphics mode down to the LOWEST QUALITY setting to ensure there is the least amount of viewer load on the system.  No real improvements.
  7. I have tried Microsoft Expressions 4 and Camtasia Studio and played with all their settings for fps, bitrate, compression, with minimal improvements but not great.
  8. I have told the programs to store to both my SSD and standard HD - no difference and I did not see either drive stressed out during capturing.
  9. With Camtasia I used the XVID Codec which further reduces dropped frames during capturing and I noticed that the jerkiness is happening even if there is almost no dropped frames.  It seems to be more of an issue of contension between the Viewer and any capturing app.
  10. I have tried even small screen sizes like 854x480 (as well as many other larger sizes) and the jerkiness does not seem to be inpacted by thes capture screen size.
  11. I have captured on both my ultra high res and 1080 monitors with no improvement.  In fact  I even shut off my 2650 rez monitor to ensure my GPU was only process one monitor feed.  No improvement.
  12. I have watched my CPU and RAM usage during the captures and neither is close to max.  Nor is my graphic card stressed out.
  13. I wanted to try FRAPS but every time I try ro download it, my Anti-Virus instantly considers it to have a trojan - YES its being downloaded right from the FRAPS website.

I AM FRUSTRATED - RAN OUT OF IDEAS  - PLEASEEEE HELP !!!

 

Link to comment
Share on other sites

 

Here is a small youtube example that shows the jerkiness of the movement as content passes by.  I want to say again that as soon as I pause or stop the capturing, these same flycam motions are SMOOOTHHH as SILK!  There is no jerking - even if I were to set my viewer to its highest quality and on my large 2560x1600 screen in full screen, the motions are silky smooth. 

*** I removed this video from youtube as it was no longer needed ***

Link to comment
Share on other sites

I have no idea what's causing your problem, but I wonder if setting the process affinity for SL and your video capture software to different cores might avoid some scheduling contention.

That's my shot in the dark!

ETA: Don't ask me how you do that, I'm a Mac girl. But I do recall Windows allowing for that control.

ETA2: If the scheduling conflict is occuring in the GPU, I doubt setting process affinity will make a difference.

Link to comment
Share on other sites

Thanks Madeline for the ideas.

I tried your idea of keeping the FF and Capture apps on different CPUs.  I even shut down my Anti-Virus as that could also be a potential cause.  I made the apps both be HIGH priority.

It had not positive effect with Camtasia.  Using Microsoft Expressions4 Screen Capture was a bit better but still not a silky smooth as when the capture is stopped.

It could be a conflict in the AMD GPU hardware / driver.  If so I dont know how one would fix that.

What capture app do other Machimina creators use?

I was going to try the free version of FRAPS but my AntiVirus instantly considered the download to be a Trojan so I didn't download it.  I suspect its a false positive because of the executable name FRAPs uses setup.exe.

I was told by one person that an app called MOVIESTORM is used by Hollywood types.

But what do ppl use and do they get this screen jerkiness?

Link to comment
Share on other sites

jjccc, you misunderstood my problem.

To reiterate, I have ZERO problems with panning zooming flying around the SL sim with my be 3Dconnexion joystick.  It is as silky smooth as one could ever want the motions to be.  In fact even with my viewer in its highest setting and everything enabled and running my screen at about 2550x1570 screen size, my camera motions are flawless.

The problem is that as soon as I try to RECORD / CAPTURE the screen motions using capturing software from Camtasia Studio, Microsoft Expressions4, and now another software (which i cant recall at the moment but the icon looks like a mouse on steriods), the captures are jerky / jumpy.  Not flowing smoothly.

So my question to you as you seem to have been able to RECORD without jerkiness, what capture software did you use?  Windows system? etc?

Link to comment
Share on other sites

WELL PROBLEM SOLVED.... 

After trying 3 other video capturing applications, I finally ignored my Anti-virus (thinking its just a false positive) and downloaded the FRAPS app.  I figured if the other 3 failed to solve the problem on the jerky high motion video capture, FRAPS will likely have the same issue.

I WAS WRONG !  FRAPS IS A SAVIOR & SOLVED THE JERKINESS COMPLETELY !

It didnt matter how intense my graphic setting on the viewer, FRAPS captured my high motion video almost as silky smooth as no recording being on.  I didnt expect 100% perfect but FRAPS got rid of about 97% of it.  More than adequate.

So for anyone else that has this problem, TRY FRAPS !

Link to comment
Share on other sites

Well I have always used FRAPS. And yes I am lusting over your computer specs *wink*.

I do have a couple of comments.

Smooth pans in my experience have not so much to do with hardware :D and a lot (A LOT) to do with FPS. If you can't get the FPS above 15 it is almost impossible to get a smooth cam. Some of that has to do with your computer specs but LAG is also a product of the sim, its design and the current server code (changes often).

 

I recently had to choose between smooth cams and shadows in a sim that was 7fps. I went with the shadows and did my best to artify the jerky. I COULD have made lovely smooth cams (didn't check but likely about 35fps without shadows) but I wanted those shadows. YOU shouldn't have that problem often and glad FRAPS solved the issue. I read all the reviews a few years ago and watched some side by side videos of screen captures and only installed FRAPS. I tend to research and go with the supposedly best product.

Cheers.

Link to comment
Share on other sites

  • 4 weeks later...
  • 6 months later...

WOW JJCCC!  Very impressed with the Machinima of my art gallery!!  I was learning machinima for the first objective of creating a video of my art gallery in SL.  I loved your video you made.

Thank you ... i really enjoyed watching it. And yes... the sim where my art gallery is on can be laggy - its mainland and LL doesn't give a lot of resource horsepower to those sims.  It prevents me from having Art receptions at my gallery as the sim would crash if I have over 35 avatars.... I had a concert there once and at 40 the sim crashed.

I will surely investigating the frame blending software even though the FRAPS surely has solved the lag issue.

Link to comment
Share on other sites

Setting Fraps to 60fps in movie tab. The feathering is in flycam settings in second life. Me>Preferences>Move&view>other devices.For editing software I am using VirtualDub. My problem now is the movie looks fine untill I compress it. Then the quality is bad. Compressed video looks good when capturing without using flycam.  Any thoughts on how to make the movie look good when compressed?

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2545 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...