Jump to content

Arm sticks during AO


Myshel Neiro
 Share

You are about to reply to a thread that has been inactive for 2802 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hi all!

I'm having an issue with an Animation Override I'm attempting to make.  The animation itself only touches the lower body.  I've set the animation override using llSetAnimationOverride and it looks fine, right up until I attempt to select something.  My avatar moves her arm as expected, but after I deselect, the arm sticks in that position and won't return to neutral until I change animations,  An example stuck position is shown in the image below.

stuck.png

Any idea what's going on?

 

Thanks,

Myshel

Link to comment
Share on other sites

This is not a scripting problem.

Animations have different priorities and if you want to supress the built in standard animations you need to upload your sitting animation with a higher priority.

Some viewers allow to switch of some of the built in animations like pointing, typing, shout etc. thats another way to get rid of them.

Scripts have no influence on priorities nor the built in automatic animations.

Link to comment
Share on other sites

Thanks for your reply.

Here's the thing though, I do not want the arm animation supressed.  I am fine with the avatar's arms flailing about while selecting things.  The problem I have is that it IS supressing these animations.  It allows the arms to move to the selected target, but then the arms freeze in that position until the animationOverride is removed.

Oddly, if I crank up the priority and use an llStartAnimation, it works as I would expect - arms move about while selecting, and when the object is done being touched, the arms return to a resting position.  It's only a problem with llAnimationOverride, which is why I suspected this is more scripting than animation, although it certainly walks the line! I would just use llStartAnimation, and I still may if no one can help me out here, but the code controlling the animation is much cleaner if I'm able to use llAnimationOverride.

In terms of animation priorities, I've used animations between 2-4 and they all have the same issue.  Also, I see that beyond the selecting animation, when the AO starts on login, the arms are permanently stuck in the T-pose until the animationOverride is removed.

Link to comment
Share on other sites

hmmm, I made a little AO for me that only uses llSetAnimationOverride. Runs a little timer to change the standing animation by llSetAnimationOverride from time to time.

I have no issues but I don't point anywhere and I don't use sitting animations. So it's perfect for me :)

In your case you say the animation affects only the lower body. The pointing animation maybe needs a reset.
Try to use a full body animation with low priority. I'm no expert with animations though, mabe the animations forum is a better place to ask.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2802 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...