Jump to content
  • 0

Parts of object still show even after being put away


93ai
 Share

You are about to reply to a thread that has been inactive for 3785 days.

Please take a moment to consider if this thread is worth bumping.

Question

I've been having issues with parts(mainly boxes) of objects, such as a gun for example, still floating in place after I put away said object. I would imagine this would be a computer or viewer issue, but honestly I have no idea. Is there a way to fix this or do I just have to live with it?

 

Edit- I did not attach the item to my HUD. The symbol is only a single cube, I know the differences between the two types so that isn't the issue. Teleporting does not solve the issue. I have been able to rez, sling, and draw most guns I have without the same issue. Maybe it would help if I could get some images of what I'm having problems with? I used an invisible Avatar to make it easier to see what's going on. Below is basically what I'm trying to see if I can fix.

When slung/put away:
Snapshot1_001.png

 

When drawn:

Snapshot_001.png

The numbers of boxes floating isn't consistent, sometimes there's more, sometime less. I've spent roughtly 15 minutes drawing and slinging the gun and have not had all the boxes disappear.

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hi 93ai,

This sounds like a lag/communications problem, with your viewer not being informed of an object's being removed from the scene and returned to inventory. Do these "ghosts" persist after a TP to another sim and subsequent return?

Update your question via "Options" over there on the right so we don't bump other's questions off the front page and we can all keep track of suggestions in one place.

ETA: Are you able to select the floating bits and take them into inventory?

Lindal may be on the right track, in that you have returned to inventory a thing which is only part of what you rezzed as a "coalesced object". Coalesced objects are groups of objects that are held in inventory as a group, but are not linked to each other. When you rezz such a coalesced object, all the composite pieces take their relative places in the new location, but are not linked to each other. If you de-select the collection, their coupling disintegrates and they return to being individual unselected objects. If you then select one to take it back into inventory, the rest do NOT follow. They stay rezzed and must be removed one at a time, or shift-selected into another group and taken back as a new coalesced object.

ETA2: The thing you took back into inventory would be a single box. But the thing you originally rezzed may have been a little pile of boxes, a coalesced object. Are you able to select the hanging things and take them back into inventory? If so, I think that's the problem.

If you have rezzed these gun things before without issue, then I'm at a loss for an explanation. Keep us informed!

Link to comment
Share on other sites

  • 0

Look at the problem object in your inventory.  Is its symbol a little stack of cubes, rather than a single cube?  If so, the item is actually a number of separate objects.  If you wear it, and then right click a part of it and Detach it, the other parts will stay attached to you.  You can simply right click and detach them too, one at a time.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3785 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...