Jump to content

Badly need help: Second Life refusing to run with Windows 8.1*continued in thread*


You are about to reply to a thread that has been inactive for 2277 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I upgraded to Windows 8.1 earlier today in the hopes of helping the computer work better, I reinstalled Second Life but this message keeps appearing:

 

Error:

 

Second Life is unable to run because your video card drivers did not install properly, are out of date, or are for unsupported hardware. Please make sure you have the latest video card drivers and even if you do, try reinstalling them.

 

If you continue to receive this message, contact the Second Life Support Portal

 

I have updated the drivers four times, my graphics cards are two AMD Radeon 4800 HD series cards, they have been updated often as required and SL was working just fine with Windows 7 this past Wednesday.  I'm not technically minded, to me things like this which I read on another thread:

 

If you can't see the files or folders described above:
    1) Using File Explorer navigate to -> Libraries / Computer / ( C: ) / Users /
    2) Press the Continue button to get permission to obtain permanent permission edit this directory.
    3) From the View drop-down menu option select Options & Change Folder & Search Options
    4) Select the View Tab
    5) Under the Hidden Files and Folders options click on the - O Show hidden files, folders & Drives radio button
    6) Push the Apply Button then the OK button.

2) Login using that Viewer and wait for a complete Login and Inventory rebuild.

 

and this:

 

 1)   Open C:\Users\<username>\AppData\Local and delete the contents of the SecondLife folder.
    2)   Open C:\Users\<username>\AppData\Roaming and delete the contents of the SecondLife folder.
    3)   Uninstall Second Life using the Programs and Features tool in the Windows Control Panel.
    4)   Download and install the latest release of the Second Life Viewer from http://secondlife.com/support/downloads/.

    Note: <username> is your PCs Windows 8 User Account Login Name

If you can't see the files or folders described above:
    1)   Using File Explorer navigate to -> Libraries / Computer / ( C: ) / Users /
    2)   Press the Continue button to get permission to obtain permanent permission edit this directory.
    3)   From the View drop-down menu option select Options & Change Folder & Search Options
    4)   Select the View Tab
    5)   Under the Hidden Files and Folders options click on the - O Show hidden files, folders & Drives radio button
    6)   Push the Apply Button then the OK button.

 

Are very confusing for me, I don't understand what any of it means.  I can barely understand how to use Windows 8 as it is let alone try to understand technical jargon that is very hard for me to understand and grasp thanks to the learning disability I have.

And I can't even find a continue button.

 

I badly need help to find out why SL isn't working, I can't reinstall Windows 7 since I don't have the disc for it, I can't go to Windows 8 itself since I bought the complete 8.1 package.

Please, I badly need help with this, I'm not supposed to be getting stressed and this is causing unneeded stress.

 

Link to post
Share on other sites

Open your viewer, but don't try to log in... instead, go to Help and click on About Second Life (or your chosen viewer name).  There, you will find your system information; copy it and paste it here.  It should look something like this...

CPU: Intel® Core i7 CPU         920  @ 2.67GHz (2653.44 MHz)
Memory: 12280 MB
OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GTX 660/PCIe/SSE2

Windows Graphics Driver Version: 9.18.0013.3165
OpenGL Version: 4.4.0

...only with your specs and not mine, of course.

...Dres

Link to post
Share on other sites


Reina Beaumont wrote:

Aye, I did, I installed them four times yet it keeps saying that they've installed
but there were errors while installing
.  When i try to call up the report it just appears as a mess with no words instead of in English as requested.

This is most likely your problem and one with which I cannot help you.  Perhaps someone more familiar with Windows 8 will come along and be able to help.  Meanwhile, it wouldn't hurt for you to search the web for information about AMD driver issues to see if you can find anything.

Good luck ...Dres

Link to post
Share on other sites

I can't open the viewer, it comes up with that message before the viewer appears and then stops trying to load it.  All I know is that my graphics cards are:  

AMD Athlon 64 X2 Dual Core Processor 4800+ 2.50 GHz

 

Uh, that's your cpu, not your gpu, hun.

Link to post
Share on other sites

This has been an ongoing problem for people with retired Radeons.

AMD did not produce Windows 8,1 drivers for old cards (HD 4xxx and back), and those old installers have trouble on Windows 8.1 even if the video card is a newer one.

It will be good to check under the control panel, in add/remove programs, if any AMD Install Manager stuff did make it in before it failed, and uninstall all of that first,

Next, you can use this Microsoft page to try to get the right driver installed.

This won't add the Catalyst control center etc., but the driver itself is the same one AMD included with Catalyst in late 2012/early 2013. Hopefully this will do the trick for you, I don't have such an old card to try it on. That MS page will lead you to an ActiveX thingy and won't work in the common browers, you'll have to use IE for it.

If, after that, you still don't have a configuration that works with SL, it is probably time to either get a newer video card, or downgrade to Windows to 8.0 or older. A new card may be less effort.

 

Adding -- someone found a sort of workaround to force the old AMD installer to work -- http://forums.anandtech.com/showpost.php?p=35618600&postcount=19

 
 
Link to post
Share on other sites

I can't afford to downgrade, it cost me £93 to buy Windows 8.1 as it is, that's a lot of money on a very tight budget.  Either it's a case of waiting for LL to update the SL viewer so that it can handle Windows 8.1 on older cards or somehow getting a new computer and I've already gone through about six or seven because of SL since 2007.

I tried that file you linked to, but I don't know how to use it.

Link to post
Share on other sites

OK, so again, you have to load that page in IE for it to work. At the bottom of the screen you will see a yellow box asking if it can install a program from Microsoft, go ahead and do that.

Next, pick your card from the available updates and press the Add button. This thing works like an online store, you'll see a "view basket" link at the top of the page.

Click on view basket, and you'll get a Download button. Pick that.

You will end up with a new folder and inside, a file called something.cab

To install a .cab file:

- Tap on the Windows key or left-click the start buton, type in Device Manager, and run it

- In the list that pops up, skip doen to Display adapters, open that up, and find your Radeon.

- Right-click on the Radeon icon, and pick "Update driver software..."

- It asks "How do you want to search for driver software?" Pick the second option, browse my computer

- Pick that folder that the downloader made earlier

- Click the Next button and Windows will try to install it.

 
 
Link to post
Share on other sites

That sadly didn't work, it just said that I already have the best driver instaled for the display adaptor.

 

It looks like it's going to be a long while before I can get back in SL again, I tried other viewers, Firestorm didn't work, one called Radegast barely worked, it was so laggy that I couldn't move, nor make use of much of anything.
I've contacted the Star Trek group I'm in and notified them of my sudden and likely indefinite leave of absence while I get the problem sorted out, somehow.

 

I was really hoping that installing Windows 8 would finally deal with the problems the computer keeps having, but now it's gone and caused more.  Just can't get a break, it's one thing after another.

Link to post
Share on other sites

Those methods sadly didn't work, I think I know why, my graphics card is an ATI Radeon HD 4800+ series, just a 4800 though and from what the requirements are saying my card isn't compatible.  Yet it was working just fine before I installed Windows 8, aside from the usual lag and slow loading it worked as it had been doing for the past couple of years or so.

 

Looks like I'm going to have to find some way to afford a more compatible card, if I can find one for a reasonable price.  That could take some time.

 

It's always one thing after another.

Link to post
Share on other sites

I'd suggest you try the viewer found here:

 

http://wiki.secondlife.com/wiki/Linden_Lab_Official:Alternate_Viewers

 

The one labeled "Second Life GPUUpdate Viewer version 3.6.11.283787"

 

 

Support added for the following gpu families:

 

  • Newer NVIDIA GTX 700 series
  • AMD R7/R9
  • Intel Iris Pro

IT's less likely the problem is windows 8, and more likely the viewer isn't supporting your GPU driver. So this 'beta' viewer is meant to correct that. Worth a shot.

 

 

 

Link to post
Share on other sites

To get good information on your system you can use the free programs System Explorer, CPU-Z, and GPU-Z. You can also see what your computer is actually doing with those tools.

If you have an older copy of of the SL viewer, try getting a copy of the GPU Table from the older version. (gpu_table.txt) See if the entry for your 4800 is different than the current viewer's version. You can try editing the newer version to match the older version.

Win8.1 does step up the driver requirements. In some cases rejecting older drivers during the upgrade and loading Win8.1 generic drivers. I suspect this is the problem you have. The most likely problem is the lack of an OpenGL driver of the right flavor. You may not be able to circumvent that problem. You can Google for work-arounds. But, I would not be hopeful. Win8 has new anti-copy/anti-pirate features and new security measures that make it difficult to work with.

 

Consider a new video card. You can get nVidia 9800, 200, 400, and 500 series cards on eBay for great prices. People are upgrading to 600's and 700,s and selling off their 'older' cards. nVidia GTX260 cards go for US$60 on ebay.

Link to post
Share on other sites

Why people are actually buying Win 8 to replace their trustworthy Win7, that question still remains.

Anyway, just a shot in the dark here:

Try Linux. Userfriendly Linux distros like *buntu, Mint, Zorin, Linux Lite, Puppy Linux et al have saved and reactivated many many outdated computers who where destined for the bin but now having a second life. :smileyhappy: That stuff just works, is secure and often faster. And it's FREEEEEEEEEE!!!!

Link to post
Share on other sites
  • 1 year later...

this answer is rather pointless.
firstly the problem bing discussed is that SECONDLIFEW WONT LOAD because there is a graphics driver issue preventing it from doing so. apparently.

so how can those instruction be AT ALL followed?

secendlyt, the normal way to get system inforemation is simply to:

click "start"

then RIGHT CLICK on "computer"
look to the bottom of the menu that pops up

then click "properties.
and BING!!!! you have system info

Link to post
Share on other sites


garaouelle Giha wrote:

this answer is rather pointless.

This reply is rather pointless... as this thread was started over a year ago and the OP hasn't returned to the forum since their last post to this thread.  I do hope that the reason why they haven't returned is that they were able to fix their issue, but, at this point, it doesn't matter that my suggestion was pointless.

When I try to help someone here, I do so to the best of my ability, which sometimes falls short.  Luckily, it's not unusual for others to jump in and help, who are better informed about some things than I... such as, in this case, Windows 8.

If you've read the whole thread, it should've become apparent that Windows 8.1 did not play well with the current, at the time, SL viewer code and LL had to make some changes in order for it to work with some GPUs.  I'm quite sure that whatever changes were made to the beta at the time worked and were eventually added to the main viewer code, making this a non-issue at this time... which actually makes your necro-posts here even more pointless.

...Dres

Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 2277 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...