Jump to content
Sign in to follow this  
Jacob Knopfli

Ubuntu 13.10 and the death of ia32-libs

Recommended Posts

So I've been using Ubuntu for a bit now, and have always needed to "sudo apt-get install ai32-libs" to get my SL viewer of choice (Firestorm) to work.  I've just upgraded to Ubuntu 13.10 (x64) and went though the usual motions, only this time...

 

me@mycomputer:~$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5 lib32bz2-1.0

E: Package 'ia32-libs' has no installation candidate

 

....Uh.  Crap.  Now what?  Without those 32 bit libraries, I simply cannot start a viewer.  I'm just....stuck.  I need some help!

Share this post


Link to post
Share on other sites

No solution, me's much too clueless to find any solutions ... but why don't you just use the BEST *buntu out there, a.k.a. MINT? No problems and no tricks needed to get my viewer running. I'm using Mint 64-bit btw and run Singularity 64 on it. It's all good and with some luck we'll get better Nvidia drivers with Mint 16. :smileyhappy:

Share this post


Link to post
Share on other sites

Just upgraded my test machine - SL still works fine on it, without any tweaks. I'm using the original SL viewer, haven't bothered trying any TPV since I rarely use them anymore.

I'll see how it looks like on a fresh install this weekend.

Share this post


Link to post
Share on other sites

I accepted the upgrade today from raring to saucy, expecting it to be fine. At first it was. Then I discovered that due to the error you mentioned, the only SL viewer still working is singularity. So I backed up my documents to my other drive and installed Mint. I always liked Mint better anyway... However eventually Mint will have to upgrade to saucy and we will be faced with this same problem unless someone finds a workaround by then (january isn't it?).

Share this post


Link to post
Share on other sites

I always get confused by all them funny animals but if Saucy Salamander is 13.10 then we're expecting Mint 16 at the end of November. Can hardly wait ... if I don't switch to Manjaro before that.

Share this post


Link to post
Share on other sites

Sooo I finally gave in and installed a blank (K)Ubuntu 13.10 to see exactly which libraries are missing. Instead of getting the entire ia32-libs, you can just do this:

sudo apt-get install libgtk2.0-0:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 libidn11:i386 gstreamer0.10-pulseaudio:i386 gstreamer0.10-plugins-base:i386 gstreamer0.10-plugins-good:i386 gstreamer0.10-ffmpeg:i386

libgtk is needed by the client itself. Pango is needed by webkit and IDN is needed by the Vivox voice module. Gstreamer is of course for media, though I have not thoroughly tested what works there and what doesn't. I suspect all it needs is the gstreamer pulseaudio package and ffmpeg.

One thing I know is missing is flash support for webkit - I've honestly never bothered to get that going, nor bothered with quicktime. Hence movies will probably not play at all.

Share this post


Link to post
Share on other sites

Hi folks...

I just did a 24hr plus marathon workin on this issue.  Hopefully I will find a safe way of adding the ia32-libs back into the new 13.10.

Be Very careful with just adding ia32-lib it may trash your Ubuntu 13.10 install.  Upgrades of the older Distros should / may work.

I have tested and retested with a fresh install of 13.10. Meaning that I cleaned the hard drive out each time.  You can look at this WIKI but be warned..  The proper ia32-lib should be ia32-lib-multiarch.  That is for the newer distros of Linux.  ia32-lib is old.  I was able to repeat the 13.10 blow up each time with the old ia32-lib install.

Now this may be just my system here.
Again...  Be careful...

 

http://wiki.phoenixviewer.com/ia32-libs-in-ubuntu-13-10

If someone does find the proper way to use the Multiarch without adding a repo, Please let me know in world or via Firestorm Support Group. If I am mot there ask someone if they can find me.

 

TC

GEE McAuley

Share this post


Link to post
Share on other sites

Well, the advantages of Multiarch.

The user now does not have to install one metapackage but can  figure out which libs are necessary and install them all manually. ( which of course only works  for packages available in .deb format, yay!)

Extremely convenient move, realised by the idiotic Debian devs and now adapted by Ubuntu ( thus coming in Mint 16 too)  who introduced Multiarch to make devs' and packagers' lives easier without spending one single thought on their users.

Wo needs users anyway?


The only advantage of the removal of the ia32-libs is that Firestorm finally moved their prolonged back and work on a 64 bit linux version, wonder if LL will follow.

Of course, as it's Firestorm powered by Microsoft © a fairly useless WIndows 64 bit version has to be released first, otherwise the Widowsians would revolt or burst out in tears.

Share this post


Link to post
Share on other sites

Good evening,

Funny I should find this post as I am looking for a fix to the same lacking in saucy. If the SL installer is a .deb package, the control file needs to be updated. It would be good to alert the SL devs and let them know. I have/had the same issue with Google Earth. Extract your .deb package, enter the package directory and then the DEBIAN directory where you will see a file called control. Open it with your text editor (gedit, leafpad, etc) and find the Depends: line. Mine looked like this:

Depends: lsb-core (>= 3.2), ia32libs

I changed that to:

Depends: lsb-core (>= 3.2), lib32z1, lib32ncurses5, lib32bz2-1.0

Save your file, close your editor and go up out of that directory. Make sure you have fakeroot installed and then open a terminal in that directory. Just to be clear, I was in:

/home/username/Downloads/google-earth-stable_current_amd64/

opened a terminal in:

/home/username/Downloads/

ran the command:

fakeroot dpkg --build google-earth-stable_current_amd64

Let the build finish and then you can install your package with gdebi or whatever. I hope this helps.

Have a good one. :matte-motes-smile:

Share this post


Link to post
Share on other sites

The only form I've seen any (first or thrid party) viewer packaged for linux would be bz2 archives. I'm sticking to mint 15 (raring) until someone finds an acceptable permanent solution to the defunct libraries in saucy. For those who use saucy, there are 2 viewers who make 64bit linux viewers. Singularity and Kakua. Singularity has had a 64bit linux viewer for almost a year now. I prefer Singularity because it has RLV support, while Kakua doesn't. Aparently the code is hard for them to work with, even though Singularity incorporates it into their almost daily alpha builds with no fuss. I think waiting for Firestorm to release a 64bit linux viewer we will be holding our breath a long time...

Share this post


Link to post
Share on other sites

Ubuntu stuff is all well and good, but does anybody out there in SL run Debian Wheezy? I *used* to run Ubuntu until Unity.. blech.. Now its Debian & Cinnamon.. Anyway, I'm beating my head against the wall with the same problem there... Seems all of the Debian derivatives have dumped ia32-libs.. I admit the multiarch idea is great, but HOW IN THE heck does one install a 32bit app thats not a .deb and apparently has not been built "multiarch-aware"??


Tas

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...