• 0
Sign in to follow this  
Followers 0
AgEnTHuskey1488304671

Sounds I upload I can barely hear, but other's are crazy loud.. How can mine be louder?

Question

All the sounds I make when uploaded to SL are always quiet... I turn my volume to full and zoom in and I can still barely hear them.... However my friends upload sounds and theirs turn out being so loud and good... Can anyone maybe tell me what I'm doing wrong so I can actually hear the sounds I make :)?

I don't know how much it will help, but sounds are Made with Audacity... When I preview them on media player they are nice and loud even when not on full volume... Once uploaded they can barely be heard.

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0

All the sounds I make when uploaded to SL are always quiet... I turn my volume to full and zoom in and I can still barely hear them.... However my friends upload sounds and theirs turn out being so loud and good... Can anyone maybe tell me what I'm doing wrong so I can actually hear the sounds I make :)?

I don't know how much it will help, but sounds are Made with Audacity... When I preview them on media player they are nice and loud even when not on full volume... Once uploaded they can barely be heard.

Share this post


Link to post
Share on other sites
  • 0

That's normal.  You have to make your sounds extremely loud in Audacity or whatever sound editing program you use and then upload them.  It's a delicate operation, because if you make the sounds too loud in Audacity, you will end up clipping them. Do the best you can, though. Once the sounds are uploaded, there's no way to make them any louder. 

BTW, sound volume drops off with distance from the sound source, but it is possible to script "slave" speakers so that you have more than one sound source in an area.  To do that, use the LSL functions llLoopSoundMaster and llLoopSoundSlave, which you can find described in the LSL wiki.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Hi Agent,

Make sure you are exporting the sound as 16-bit WAV at 44.1KHz. I imagine you are already doing that.

The last step before exporting should to select the entire clip, then pick "Normalize" from the Effect menu. Make sure "Remove any DC offset" is checked and "Normalize maximum amplitude to:" checked, and set to somewhere between zero and -1.0dB. This will scale your entire clip so that the loudest sound is just below clipping.

That said, I can't explain why your clips sound fine when played in Media Player, but not in SL.

If Rolig's and my suggestions don't help, come back and edit your question (Using the Options pulldown on the right) so we can continue working on it all in one place without pushing other people's questions off the front page.

Good luck!

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Besides normalizing the clip, some audio editors offer the option to compress it.  This will make it seem louder.  Be careful when applying compression...too much will distort the sound. 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 0