Jump to content
Sign in to follow this  
Caleb Linden

Deploys for the week of 2013-08-19

Recommended Posts

Second Life Server (main channel)

Server Side Appearance (SSA) project is getting promoted to the main channel on 2013-08-20.

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_Server/13#13.07.26.279129

 

Second Life RC BlueSteel

This project fixes some bugs related to LSL scripts in child prims of linksets, and also addresses some server crash modes. 

(The same project from last week's roll)

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_BlueSteel/13#13.08.16.279995

 

Second Life RC LeTigre

This project fixes some bugs related to LSL scripts in child prims of linksets, and also addresses some server crash modes.

(LeTigre now contains the the same build as this week's RC BlueSteel)

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_LeTigre/13#13.08.16.279995

 

Second Life RC Magnum

This project includes a few internal bug fixes which shouldn't show any visible changes to the residents.

(This project was moved from LeTigre to Magnum this week)

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_Magnum/13#13.08.17.280013

 

We will be monitoring this thread as the code gets released, so feel free to note any observations you have about the server updates.  If you have a specific bug you'd like to report, please file a JIRA.

 

Share this post


Link to post
Share on other sites

Want to join us in the bet in general discussion on how many people will ask why they don`t rez? spoiler.png

Thanks for the updates, but i`m secretly saying a prayer for tomorrow :matte-motes-wink-tongue:

 

Good luck with the rollout! ;)

Share this post


Link to post
Share on other sites

https://jira.secondlife.com/browse/SUN?  

there are not many issues but it still says there are 6 unresolved issues

have these issues been sufficiently dealt with?

will the promised polishing code fix those?

I have been excited about  the coming of SSA for a long time.

I am hoping to never have a bake fail again.

oh yes and I think it will be humorous seeing the grey people and the grey people complaining or maybe even wondering why they  are grey

 

Share this post


Link to post
Share on other sites

Caleb

The SL Blog-post indicated that by the end of the Wednesday RC channel rolls, SSA would be Grid-wide.  Looking at what is slated for LeTigre and Bluesteel that would appear not to be the case. 

Can you please clarify:

1)  Is SSA going to be on all channels as of tomorrow's rolls

2) If not, why not?

Until SSA is rolled to all channels SL sailing and flying will be severely impacted where sim crossings are involved.

 

ETA:  I was under the impression that code had been rolled to the servers that prevented login and rezzing in the final minute before a server shut down for a roll.  I was just booted between 30 seconds and one minute after logging on.  No warning was given.  What is the reason, is that code not on Main Server?

Share this post


Link to post
Share on other sites

Hi,

1)  Is SSA going to be on all channels as of tomorrow's rolls

I made a mistake in my statement. The code that is on Main Channel should exist on ALL RC channels as well

It's only going to be on the channel called Second Life Server which amounts to the majority of regions.

2) If not, why not?

RC (for Release Candidate) regions contain code that is newer than the main channel. AND that build is merged with the Main Channel code

As for the region shut down fix, they are essentially on all RC channels and are functionaly the same. Magnum only has a prettier warning text.

 

C

 

Share this post


Link to post
Share on other sites

An old bug seems to have crept back in.  I was working on a lot about a half an hour before the sim was restarted.  I stopped when I got the 5 minute warning.  When the sim came back up all the work I had done had been undone - both the objects on the land and the terraforming had reverted back to as it was before I started.

It is my understanding that when rolling restarts happen that the sim is "captured" as is before it's restarted with the new server implementation but this isn't what's happening.  It seems to be using whatever the last capture happened to be, which is too old.

I'm excited about server side baking but really hope you guys can get a chance to take a look at this aspect.  Thanks!

Share this post


Link to post
Share on other sites

That old bug, Imagin - has in my experience never been fixed and can therefor not "come back" ;-)   It's always a good general rule not to do that kind of stuff just before a roll, or atleast take a copy before you TP out. (granted a bit hard for terraforming).


Sure would be sparkle sweet if it did get fixed though...

Share this post


Link to post
Share on other sites

Well now I'm totally confused!!! Two usually very good news blogs, the Firestorm blog, and the Lindens own News release all say that by the end of Wednesday's RC rolls every region will have SSA enabled. However Caleb seems to be saying that won't be the case unless I've totally misread his reply to Ayesha Askham. Any chance of clarification of the reply to the question - Will SSA be enabled on ALL SL regions by the end of Wednesday's Grid rolls?

Share this post


Link to post
Share on other sites


Imagin Illyar wrote:

An old bug seems to have crept back in.  I was working on a lot about a half an hour before the sim was restarted.  I stopped when I got the 5 minute warning.  When the sim came back up all the work I had done had been undone - both the objects on the land and the terraforming had reverted back to as it was before I started.

It is my understanding that when rolling restarts happen that the sim is "captured" as is before it's restarted with the new server implementation but this isn't what's happening.  It seems to be using whatever the last capture happened to be, which is too old.

I'm excited about server side baking but really hope you guys can get a chance to take a look at this aspect.  Thanks!

This bug has never gone away.

You just hadn't been caught by it in a while.

But it has never gone away.

Share this post


Link to post
Share on other sites

Unfortunately, this still did not fix my intermittent "We are sorry, Linden Lab has discovered degraded performance on your connection to the region you are on." error.  Oddly, it is stuck on "Downloading Clothing" before issuing that message.  Why is it downloading clothing if baking is done on the server?  (Firestorm-Release v4.4.2.34167 - Server 13.07.26.279129)

It worked the first time I logged on, but failed the second time.  The first time I was initially gray but then all textures were applied.  Also, the old Phoenix viewer still shows my avatar as visible and fully rezzed, though I don't know if others see me that way.  The notice says that when SSA/B is enabled, my avatar will not be visible on old viewers like Phoenix.

 

Share this post


Link to post
Share on other sites

Hi Dagger and all who are confused by my previous statement as it was incorect.

SSA should be on all Main Channel and RC Channels.

What happens  to the RC Channels whenever we have a new Main Channel release, is that they get merged together.

In other words, RC Channels contain the feature set of Main Channel plus more.

 

If for any reason, the RC Channels are exhibiting a different behavior from the set of features in the Main Channel, we want to have it reported via JIRA.

 

Sorry about the confusion!

Share this post


Link to post
Share on other sites

Caleb

Thanks once again for disentangling our understanding of the SSA rollout.  It is greatly appreciated that you bother to tell us what we have inside out!

 

I can only hope that the pre-restart changes come to Main Server soon! :smileyhappy:

 

PS FWIW SSA seems to be working really well on the Main Server sims I have been to this afternoon (UK).

Share this post


Link to post
Share on other sites

Hello,

after today's update region "Lionetz" appears to be experiencing trouble. I can teleport in, but can't teleport out (end up crashing and relogging into the last known location). Also scripts are not saving. Also meshes are not rezzing at all.

Also, llRequestURL returns invalid URL format: http://sim10429:12046/...

JIRA: https://jira.secondlife.com/browse/BUG-3663

Share this post


Link to post
Share on other sites

Ask an estate manager/owner to restart, if non is online, submit a support ticket for downed region and say what you said here as it`s a known issue and happens every where and they will restart it

You don`t need premium and anyone can ask it for any sim

Share this post


Link to post
Share on other sites

Well my experiences after the rollout were very mixed.


My partner couldn't see any layers on the body itself, but could see prims and mesh attached to me.  We figured out that he had not done a completely clean install of the new viewer - I had to tell him where to go in Win7 64bit to find the other files that needed deleting.  Once he did that and reinstalled, he could see layers on the body instead of gray.

 

Others who probably also didn't know what "clean install" all entailed saw something completely different - they saw me as completely naked, save any prim or mesh attachments I wore.  I was at Fermi Sandbox and was informed by a manager that I was naked.  I changed outfits to one with a kilt and the manager told me he could see the kilt, but the rest of me still appeared to be naked.  He sent me home, and sent me a picture of what he saw, and he DID see me naked - he didn't even see the tattoo layers I was wearing.

 

I switched to a completely mesh outfit and went to a friend's sim.  They saw the mesh, but did not perceive the alpha layers I was wearing underneath, so again, naked pieces of me were showing through the mesh.

 

I don't know if you can write something which can assist people in cleaning out the files that are not deleted with a standard uninstall, but if you can, this might be extremely helpful, or this thread will be flooded with people seeing either grey bodies or naked bodies with just attachments.

 

Just a suggestion, because 9 out of 10 computer users do NOT know how to go into their folders and find the bits and pieces us geeks know to delete.

Share this post


Link to post
Share on other sites

Marie Resch wrote:

Well my experiences after the rollout were very mixed.

My partner couldn't see any layers on the body itself, but could see prims and mesh attached to me.  We figured out that he had not done a completely clean install of the new viewer - I had to tell him where to go in Win7 64bit to find the other files that needed deleting.  Once he did that and reinstalled, he could see layers on the body instead of gray.

Others who probably also didn't know what "clean install" all entailed saw something completely different - they saw me as completely naked, save any prim or mesh attachments I wore.  I was at Fermi Sandbox and was informed by a manager that I was naked.  I changed outfits to one with a kilt and the manager told me he could see the kilt, but the rest of me still appeared to be naked.  He sent me home, and sent me a picture of what he saw, and he DID see me naked - he didn't even see the tattoo layers I was wearing.

I switched to a completely mesh outfit and went to a friend's sim.  They saw the mesh, but did not perceive the alpha layers I was wearing underneath, so again, naked pieces of me were showing through the mesh.

I don't know if you can write something which can assist people in cleaning out the files that are not deleted with a standard uninstall, but if you can, this might be extremely helpful, or this thread will be flooded with people seeing either grey bodies or naked bodies with just attachments.

Just a suggestion, because 9 out of 10 computer users do NOT know how to go into their folders and find the bits and pieces us geeks know to delete.

Marie Resch,

We at SL Answers have been giving out the Clean Install information for many months leading up to this deployment.  This includes full instructions for the deletion of the support folders found in the /appdata areas of the various Windows OS versions including Windows 8. This Clean Install method is a reliable repair option for a number of SL Viewer issues related but not limited to "Compromised XML configuration files, Caches with non clearing textures in them, texture indices that will not reset." - an example post is found below.

http://community.secondlife.com/t5/Viewers/why-won-t-it-allow-me-to-change-clothes-or-teleport/qaq-p/2150253/comment-id/6976

As we have been fielding questions regarding unusual Viewer failures for as long as I can remember I'm amazed that more people using the SL Answers forum have not run across our Clean Install mandate. One of the most notable failures when using these instructions is when the OP chooses to skip the clean-out step. Redirecting them to complete the Clean Install/reinstall as written usually remedies this issue.

Thank you for providing a 2nd POV testimony regarding this important SL Viewer repair method. BTW - It works great in situations where Firestorm is acting up as well.

My 10 Cents Worth - I wish SL would simply include the "Uninstall All Support Files" option as one of the uninstall selections. 

 

 

Share this post


Link to post
Share on other sites

Well, I submitted a JIRA, few hours later, everything returned to normal. This was really weird behavior. It might have restarted/crashed or so, but the most important thing is that it works correctly now.

Share this post


Link to post
Share on other sites


KarenMichelle Lane wrote:


Marie Resch wrote:

Well my experiences after the rollout were very mixed.

My partner couldn't see any layers on the body itself, but could see prims and mesh attached to me.  We figured out that he had not done a completely clean install of the new viewer - I had to tell him where to go in Win7 64bit to find the other files that needed deleting.  Once he did that and reinstalled, he could see layers on the body instead of gray.

Others who probably also didn't know what "clean install" all entailed saw something completely different - they saw me as completely naked, save any prim or mesh attachments I wore.  I was at Fermi Sandbox and was informed by a manager that I was naked.  I changed outfits to one with a kilt and the manager told me he could see the kilt, but the rest of me still appeared to be naked.  He sent me home, and sent me a picture of what he saw, and he DID see me naked - he didn't even see the tattoo layers I was wearing.

I switched to a completely mesh outfit and went to a friend's sim.  They saw the mesh, but did not perceive the alpha layers I was wearing underneath, so again, naked pieces of me were showing through the mesh.

I don't know if you can write something which can assist people in cleaning out the files that are not deleted with a standard uninstall, but if you can, this might be extremely helpful, or this thread will be flooded with people seeing either grey bodies or naked bodies with just attachments.

Just a suggestion, because 9 out of 10 computer users do NOT know how to go into their folders and find the bits and pieces us geeks know to delete.

Marie Resch
,

We at SL Answers have been giving out the Clean Install information for many months leading up to this deployment.  This includes full instructions for the deletion of the support folders found in the /appdata areas of the various Windows OS versions including Windows 8. This Clean Install method is a reliable repair option for a number of SL Viewer issues related but not limited to "
Compromised XML configuration files, Caches with non clearing textures in them, texture indices that will not reset.
" - an example post is found below.

As we have been fielding questions regarding unusual Viewer failures for as long as I can remember I'm amazed that more people using the SL Answers forum have not run across our Clean Install mandate. One of the most notable failures when using these instructions is when the OP chooses to skip the clean-out step. Redirecting them to complete the Clean Install/reinstall as written usually remedies this issue.

Thank you for providing a 2nd POV testimony regarding this important SL Viewer repair method. BTW - It works great in situations where Firestorm is acting up as well.

My 10 Cents Worth
- I wish SL would simply include the "Uninstall All Support Files" option as one of the uninstall selections. 

 

 

I also know that most SL users don't think or don't know to look in Second Life Answers - it would help tremendously if a reference was made to these tutorials/instructions on a person's dashboard or something.

I'm not having any problems, because I did do a clean install; however, I don't want to be hassled going across the grid because othes haven't and they see me naked, if you know what I mean :P

Thanks for the information.

P.S. The major link in the middle of that information is apparently broken.  It said page does not exist.

Share this post


Link to post
Share on other sites


Marie Resch wrote:

I'm not having any problems, because I did do a clean install; however, I don't want to be hassled going across the grid because othes haven't and they see me naked, if you know what I mean
:P

Thanks for the information.

P.S. The major link in the middle of that information is apparently broken.  It said page does not exist.

I live on a region that's had server-side appearance running for weeks. Occasionally I'd briefly appear naked but only with a first bake from a region that didn't have SSA running to one that did if I'd changed clothes on the non-SSA region and were wearing specific types of outfits. Given that there are no longer any non-SSA regions this problem should be gone. Also, once you have a fully-clothed version of yourself on the servers everyone will see you that way regardless if they did a clean install or not. Nobody will see you naked now (unless, of course, you ARE naked.)

Share this post


Link to post
Share on other sites

I did notice baking sometimes gives incomplete and blurry results. I'm not sure if my appearance is the same for other people when that happens though. But it happens most often when I change multiple layers in succession.

Like, when I put on a shirt, and just before my character starts replacing the texture, so when the server is probably in the middle of the rebaking process, I add a jacket as well.

What seems to happen there, is something like this:

put on shirt -> server starts rebake process -> put on jacket -> server starts a second rebake process -> first rebake process finishes -> server stops both rebake processes because the first rebake process finished and (correctly) sends the results of the second rebake process.

But, that second process is incomplete, resulting in a blurry texture getting sent to your avatar. This can be fixed by wearing another layer of clothing to that area of your avatar, like an undershirt or a tattoo. But I can't say I find that an ideal situation. Especially not if the incomplete bake was actually for the appearance you were after. I'd almost wonder what happens if multiple people start changing outfit at once on the same sim.

Taking off the jacket and then putting it back on doesn't seem to fix it. It seems like the server keeps the resulting texture in cache for a little while, so adding another layer of clothing or a tattoo (even if it just has a transparent texture defined for that area, just as long as there is a texture defined) is the best solution we have for now.

 

Suggestion for a better solution: make the avatar rebake function send a message to the server instead to make the server rebake the character, and have the updated texture sent back to the viewer.

Share this post


Link to post
Share on other sites

I've had this happen before, as well.  All I've had to do is use the texture refresh option on myself (rather than rebake... which doesn't work) for it to rez correctly... though I'm not sure this option is available on all viewers (I use Firestorm).

...Dres

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...